Jump to content

Sign in to follow this  
arsenerker

FSX-SE Nvidia Inspector doesnt override AA

Recommended Posts

With those versions things work as intended, some recent drivers have given odd results. With FSX-SE in DX10 1920x1200, I've started a fresh profile (fsx.exe so works with FSX too). Should already have Antialiasing - Behaviour Flags set to Treat 'Override any application setting' as 'Application-controlled'. Followed with On, Default, Application-controlled, Application-controlled / Off, Disabled. Then I've been trying multipliers of Antialiasing - Transparency Supersampling. With the stock B58 I can set 2x, 4x, or 8x, SSAA and see the difference, specially in a forest canopy whereby the tree shimmer drops to barely any at 4x, and at 8x is practically gone. If I set 4x or 8x Sparse Grid Supersampling, there is shimmer apparent, even at 8xSGSS, not much but certainly more than simply 8xSS. However, loading up the C340 is a different matter. The plane and the VC look badly antialiased, unless I set Sparse Grid Supersampling. With the SGSS setting the instruments and aircraft look a lot better, but the slight shimmer to the tree canopy exists. So in a nutshell, only use SGSSAA where it's needed - in DX10 and DX11 with certain aircraft models.


Steve Waite: Engineer at codelegend.com

Share this post


Link to post
Share on other sites

I am trying to use nVidia Inspector, and I am confused as to why it doesn't work if I turn OFF AA in FSX Settings?  And when I turn it ON in FSX, how am I to know that it is Inspector or FSX that is doing the AA???

 

I thought that I was supposed to turn AA OFF(uncheck the box) in FSX.  And then the nVidia Inspector drivers (when set to: 'Override any application settings') would over ride the AA and apply it's settings.  But it does not work.
 
Here you say it should be turned ON.  
  

AA for FSX and FSX-SE must be turned on.
 
Best regards,


  
But in this 'nVidia Inspector Complete Guide' at SimForums it says to turn it OFF.  This instruction is right after the first nVidia Inspector profile window. So, I am confused..
 

IN FSX graphics settings, make sure AA is unchecked and Filtering is set to Trillinear


 

My nVidia Inspector Settings:

 

hvDVJip.png

Share this post


Link to post
Share on other sites

Not everyone agrees on AA on or off in FSX settings.

 

If you hit "apply Changes" in NI, these settings will work.


Bert

Share this post


Link to post
Share on other sites

Thanks for the reply.  

 

Ok..  Well since AA only works if I check it on in FSX, I am doing that.(I get terrible jaggies if I turn it OFF in FSX, and Apply that profile in NI)  And then I am trying to change the AA settings in NI to see if it is having any control over the AA.  But I don't see any difference.  So, I don't know if NI is working.

Share this post


Link to post
Share on other sites

AA has always been a problem in FSX.  The settings in the AVSIM FSX Configuration Guide will definitely remove any jaggies though. 

 

Best regards,


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post
Share on other sites

Not everyone agrees on AA on or off in FSX settings.

 

If you hit "apply Changes" in NI, these settings will work.

If using DX9 AA should be turned off in FSX settings, and defined in NI. With DX10 it's the opposite, set AA in FSX on, also the AA compatibility for DX1x in NI needs to be set to the Bioshock option.


Thanks

Tom

My Youtube Videos!

http://www.youtube.com/user/tf51d

Share this post


Link to post
Share on other sites

With DX10 it's the opposite, set AA in FSX on, also the AA compatibility for DX1x in NI needs to be set to the Bioshock option.

 

Doesn't seem to be the case for me. I'm successfully running in DX10 with Steve's fixer and in NVIDIA Inspector Antialiasing compatibility for DX1x is set to 0x00000000 (the default?). What makes you think that it needs to be set to Bioshock?


 i7-6700k | Asus Maximus VIII Hero | 16GB RAM | MSI GTX 1080 Gaming X Plus | Samsung Evo 500GB & 1TB | WD Blue 2 x 1TB | EVGA Supernova G2 850W | AOC 2560x1440 monitor | Win 10 Pro 64-bit

Share this post


Link to post
Share on other sites

I actually had the same exact problem. My solution was to upgrade to DX10 and use Steve's DX10 fixer. By setting AA through his application, my pictures come perfect  :smile:


Sidhant Vaidya

 

Boeing777_Banner_Pilot.jpg

Share this post


Link to post
Share on other sites

This is what my sim looks like with the settings in the AVSIM FSX Configuration Guide - Almost perfect.

 

2015-4-12_16-47-56-185.png

 

My system:  i7 4770K w/GTX780 video card.

 

Best regards,

 

Best regards,

So, did you adhere to this quote, or did you apply all tweaks?

 

[We have done some testing with various tweaks vs no tweaks and we see little or no change to FSX performance. In fact, with no tweaks installed, the frame rate is sometimes higher. If you own the latest Intel i7 core chipset (Haswell) with a high-performing video card such as the GTX 780, you should avoid tweaks and simply tweak your display driver and adjust the LOD_Radius and Texture_Max_Load settings in your FSX.cfg.]


Keith Sandford.

Share this post


Link to post
Share on other sites

So, did you adhere to this quote, or did you apply all tweaks?

 

[We have done some testing with various tweaks vs no tweaks and we see little or no change to FSX performance. In fact, with no tweaks installed, the frame rate is sometimes higher. If you own the latest Intel i7 core chipset (Haswell) with a high-performing video card such as the GTX 780, you should avoid tweaks and simply tweak your display driver and adjust the LOD_Radius and Texture_Max_Load settings in your FSX.cfg.]

I adhered to the quote.  No tweaks.  Just used the NI settings and set LOD_Radius to 6.5 and Texture_Max_Load to 2048 or 4096.  I'm also using DX10 Preview with Steve's DX10 Fixer.

 

Best regards,


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post
Share on other sites

A little note this thread after updating nvidia drivers and setting up inspector.

 

Above mentioned AA problem occurred and I had to check the AA box inside FSX. Although all looked fine it is doubtful that any other inspector controlled setting took place.

 

Finally I deleted the FS10 profile and then I could point the right .exe for inspector and could uncheck the AA box and get the desired result without jagged edges.

 

FPS dropped as well about 5 steps, so the other settings most certainly were applied.

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,080.00 of $25,000.00 Donate Now
×
×
  • Create New...