Jump to content

Sign in to follow this  

scasm error when recompiling; anyone able to say what's wrong?

Recommended Posts



I am trying to recompile a bgl file (this is FS9) from an .sca file (made with BGLAnalyze FS5-8) but I keep getting the same error each time. The resulting bgl is slightly smaller than the original and the information lost means the runway turns from black to light brown - some overlay information is apparently lost.


The cmd windows shows this after running the scasm line:


found sections: 0x00000200
Error in line 39
  -> Runway(  N46:14:17.01 E006:06:32.14                Alt   430
Heading  45             L
  -> in expression .. FF                Threshold 0             T ..
VIS SCN -> entrys: 223  mem: 41814
Linebuffer 393/1048576
Maxlabels 11/1500  Maxpatches 16/2000
Scasm compilation status: error(s) 1


and the original .sca file (whole object), is this:


; ----------------------------------------
; Object # 1, offset: 0x000A size: 110 bytes (0x006E)
;; Lat: 0004E681Dh Lon: 00458189Bh
; ----------------------------------------
Area( 5 N46:14:17.01 E006:06:32.14 30 )
    LayerCall( :L000020 24 )
    Jump( : )
    Smoothing( 1 )
    Runway(  N46:14:17.01 E006:06:32.14 
             <<<-------------------------------------- this is 'Line 39'
        Alt   430.1
        Heading  45.4
        Length   12795 ; in feet
        Width      164 ; in feet
        Markers  77
        Id       5
        Lights   16
        Surface  FF
        Threshold 0
        ThrOffN    1082
        ThrOffF    0
        ExtN       0
        ExtF       0
        ThrLightsN 01
        AprLN      9
        ThrLightsF 41
        AprLF      10
        StrobesF   9
    Smoothing( 0 )


Looks OK to me?? The file is from an LSGG scenery I found on an FS backup drive. Looks like screenshots of the Flylogic Geneva - not that I recall buying that particular airport (well it'd be over ten years ago now). I am having a go at getting rid of some of the less than attractive features, like the blurred grass and apron tarmac textures (this is really old scenery now of course - maybe I should just buy the FSDT version, but I am frustrated not to be able to get this to work!); this scasm error is stopping me from doing so though.


Tried adding:


Set( LINBUF 1024 )
Set( BUF 600 )



to the start of the .sca file before compiling but that doesn't help.


Any insight appreciated. Thanks.



Martin Stebbing, EGLF (UK)

Share this post

Link to post
Share on other sites

Looks to me like the compiler doesn't like Surface FF.


Maybe try Surface  1 or Surface  01




The best gift you can give your children is your time.


Share this post

Link to post
Share on other sites

Joe, you were quite right. I changed FF (what does that mean?) to 01. At first, it didn't look hopeful, as the file size was reduced from the original by just a fraction, but in FS9 everything looks good, runway and all, so I can go ahead with my modifications.


Many thanks.

Martin Stebbing, EGLF (UK)

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...