Jump to content

Recommended Posts

Hi guys,

 

I'm having a problem with my Saitek cyborg v1 joystick in FSX. When I leave my throttle on idle, FSX shows my throttles at around 25%. At full throttle on the joystick, FSX shows my throttles at 75%. When I click calibrate, FSX's calibration system shows no problems at all with throttle position; 0% on the stick corresponds to 0% on the throttle, and 100% corresponds to 100%. When I use the same stick in XPX or Aerofly FS, the problem doesn't exist. This hasn't happened to me in the 2.5 years I've owned this stick and is a relatively new problem (a few weeks). The problem started when I unplugged my joystick and plugged in another Saitek controller (the pro yoke). The problem actually started with the pro yoke, so I thought it was specific to the yoke. Now I'm flying with my joystick, and the problem still exists. It's really annoying! What can I do? FSX SP2, by the way.

 

Thanks

Share this post


Link to post
Share on other sites

From your description I would check if you have two different axes mapped to the throttle.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...