Jump to content

Sign in to follow this  
flapsdown

Alabeo C404 Titan: Anybody take a chance on it yet?

Recommended Posts

Guest

To get v1.1 you need to go to your products page and re-download.  There is no obvious indication on the web site that there is an update (no blue "update") tag next to the product.

 

But after download you should have a ALC404Xv1.1.exe

 

Alabeo did an excellent job with this aircraft at this price point.  Very FPS friendly, very good on VAS, visually excellent, GTN 750 support, weather radar, and it's pretty close to hitting the marks on the performance tables. Bargain for $35.

 

There is no uninstaller so I deleted the Aircraft from SimObjects prior to installing v1.1

 

Cheers, Rob.

Share this post


Link to post
Share on other sites

There is no uninstaller so I deleted the Aircraft from SimObjects prior to installing v1.1

 

Actually, there is an uninstaller, it's just hiding in the root folder of your flightsim (for me, D:\FSX), it's called Uninstall_ALC404X.exe - though I suspect it does nothing more than the same thing as what you did...

Share this post


Link to post
Share on other sites

I did a re-load of the full product..

 

 

To get v1.1 you need to go to your products page and re-download.  There is no obvious indication on the web site that there is an update (no blue "update") tag next to the product.

 

But after download you should have a ALC404Xv1.1.exe

 

Alabeo did an excellent job with this aircraft at this price point.  Very FPS friendly, very good on VAS, visually excellent, GTN 750 support, weather radar, and it's pretty close to hitting the marks on the performance tables. Bargain for $35.

 

There is no uninstaller so I deleted the Aircraft from SimObjects prior to installing v1.1

 

Cheers, Rob.

 

Thank you Bert and Rob for the info regarding the update.

 

Brgds

 

Jean-Pierre

Share this post


Link to post
Share on other sites

When it's all said and done, the flying is the thing, and I am having a hoot of a time running this C404 around ORBX's new American Samoa region - that works for me...

Share this post


Link to post
Share on other sites

When it's all said and done, the flying is the thing, and I am having a hoot of a time running this C404 around ORBX's new American Samoa region - that works for me...

 

Flapsdown I definitely have to agree with you on this one!  I own about 90% of everything ORBX has developed.  I was gonna skip their latest Samoa Region but after picking up the TITAN, the two together are a perfect match!  I just use my Saitek panels to operate the auto pilot and off I go!  I'm having a blast with the both of these beauties!! :lol:

 

Share this post


Link to post
Share on other sites

If you do not use the provided autopilot, you are fine...

 

If you try using the installed autopilot,  it fails as soon as you push the FD button.. which does not engage  :rolleyes:

 

Yes, you can push the HDG button instead, but that is not the way the real autopilot operates.


Bert

Share this post


Link to post
Share on other sites

Indeed Bert, I got caught out when switching off the FD and both the  Nav and Alt Hold went off with it :o - but cycling them (Nav/Alt), back on seems to work -> "FD" = Feign Death for the AP I think :P

 

Chris B.

Share this post


Link to post
Share on other sites

I can find a lot more things to like about it than to dislike. I've got 5 hrs on the Hobbs and I downloaded it a little over 24 hrs ago, I've tried my best to hate every minute of it but I've failed miserably!. :smile:

 

What am I missing with the autopilot? To me it seems to behave the same as the C337 and the C340? I haven't found anything yet I couldn't make it do and that includes a hands-off LPV approach for 31 at KHIO to within 50' of the runway.

 

Admittedly I don't own the RXP gauges and I'd be pretty disappointed if it was the GTN that didn't work so I do understand you RXP guy's frustrations.

 

I like it, what can I say? I'd buy it again. :smile:

Share this post


Link to post
Share on other sites

Jim, what happens when you turn off Instrument Reflections?

 

Does your GTN still show up in the VC?


Bert

Share this post


Link to post
Share on other sites

The GTN display goes away for me if I turn the reflections off - I reported that to Alabeo, but it did not get in the update - plus the "Home" button is labeled "Direct To" as well when in the VC...

Share this post


Link to post
Share on other sites

Yes, mine goes away too with reflections off.. Also sometimes the direct to button and home buttons need to be clicked a few times to get them to work. I'm entirely too blind to notice the Home button labeled incorrectly, lol. I love the GTN integration but it's sorta lost on me because I fly zoomed all the way out and can't see it without zooming in on it. I don't like doing that because then my head goes below the panel and I can't see out the windshield so I always open the 2D pop-up whenever I need to do something in the GTN anyway.

 

I can't download v1.1. It keeps trying to give me "ALC404X.zip" where according to Rob's post at the top of the page I should be getting "ALC404Xv1.1.exe". It starts downloading and then stops dead after a few megs with "download failed". I used up all my downloads so I submit a ticket. They reset my downloads but it's still trying to give me "ALC404X.zip" and it's still failing after a few megs. I reopened the ticket with the above info, we'll see what happens. In the future I believe I'll hold off on new releases until SimMarket has the item in stock, that way I can also grab a couple things from other vendors on the same transaction if I wanted to.

Share this post


Link to post
Share on other sites

 

 


I can't download v1.1. It keeps trying to give me "ALC404X.zip"

 

Hey Jim - believe it or not, V1.1 is provided by a zip of the same name as the original, so "ALC404X.zip" was probably OK if you had been able to download it, unzipped, the .exe would have shown "1.1" - just another odd thing from Alabeo...

 

...as far as the eyes go, I hear ya - even though I like having the GTN in the VC for quick visual path references while flying, in truth, since I run 2 monitors in FSX, I almost always have the GPS pulled over onto my second screen.

 

Chris B.

Share this post


Link to post
Share on other sites
Guest

 

 


If you try using the installed autopilot,  it fails as soon as you push the FD button..

 

Hmmm ... interesting, I've never actually tried pushing the FD button (panel), I'm using my GF MCP-PRO (set to FS Default) and the FD switch works fine, as do the other functions on the MCP-PRO.

 

Have to check that out.

 

Cheers, Rob.


 

 


It keeps trying to give me "ALC404X.zip" where according to Rob's post at the top of the page I should be getting "ALC404Xv1.1.exe".

 

Per Chris, the zip will be the same name, but when you unzip it you should get v1.1.

 

Cheers, Rob.

Share this post


Link to post
Share on other sites

Thanks for the info on ALC404X.zip guys, I'm not sure why it's cutting me off. I've got new satellite internet now and it won't do mediafire downloads unless I turn off "web acceleration" in the modem settings. ASN reports "multiple IPs in use" and blocks wx downloads if I try to use it with web acceleration enabled for example. I've tried it both ways on the Alabeo download though without success. The mediafire downloads just won't start with web acceleration enabled, this one starts and pretty much maxes out my speed then stops dead in it's tracks at around 7 megs like the server is booting me or something. I've still got 5 days and 5 gold-plated gigs left with Verizon before they shut it off so maybe I'll try that this evening.

Share this post


Link to post
Share on other sites

The GTN750 integration seems like it needs much more work. Now the aircraft has 2 transponders (GTN750's transponder and the transponder unit) and there is no DME which makes it useless for IFR flying. In addition to this DME is considered a critical piece of equipment and such on oversight isn't very encouraging. I hope they fix these issues and they don't forget about it and move onto the next project.

 

The B1900D has a similar error when they left out the standby Artificial Horizon (Which is necessary by law for this aircraft) and they also added an FMS which was basically useless and unrealistic..



y572_3.jpgC172Siggy1_zps11944daf.jpg

Marlon Carter - AVSIM Reviewer

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    50%
    $12,670.00 of $25,000.00 Donate Now
×
×
  • Create New...