Sign in to follow this  
vgbaron

Prepar3D Version 3

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

i just wonder if the navigraph expansion is already compatible with v3 as also the citation and hawker as i managed to manually put into v3

Share this post


Link to post
Share on other sites

found solution for p3d v3 but for some reason the only thing missing is the weather radar.

step by step is:

1-run the installer and if you have p3d v3.x choose p3d v2 option.
2- next choose the path of you p3d v3 main folder mine is at: C:\Program Files (x86)\Lockheed Martin\Prepar3D v3
3- next dont worry about the message that says it couldnt find the DLL.XML for p3d v2 and finish the installation.
4- go to you DLL.XML file. Mine is at:
C:\Users\Master\AppData\Roaming\Lockheed Martin\Prepar3D v3  and open to edit with notepad or i recommend downloading notepad++. Google it if interested.

5- Lastly you need to add this in it.
Launch.Addon>
    <Name>Carenavigraph</Name>
    <Disabled>False</Disabled>
    <Path>C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\Carenavigraph.dll</Path>
  </Launch.Addon>

Make sure that when you add it is before </SimBase.Document>
and that the path matches the destination of where your main p3d v3 folder is.

Also note that i am running windows 10 in case something is different.

Share this post


Link to post
Share on other sites

i tried this solution many times but with no luck. i remember that i tried somethings with the hawker to and the navdata showed up in FMC and can type but FMC is not responding , but some LSK'S did work and can change menu some of it but typing in it ,,,forget it whits is the same whit the phenom 300, only here when exp pack is installed .. no navdata present but can use the FMC on g1000 if i install without the exp pack than all is oke, navdata is present , but not in the carenadonavigraph navdata folder ! nothing there, so where is the standard navdata located ?? i tried an other solution here: https://carenado.zendesk.com/hc/en-us/categories/200269637-Hot-Issues but no luck. only a blinkin cursor in flightplan and on proc by DEP shows 0 only

Share this post


Link to post
Share on other sites

So i am experiencing CTD when i put the navigraph extension v1.3 in P3D 3.4.14, anyone else having same issue?

Share this post


Link to post
Share on other sites

So i am experiencing CTD when i put the navigraph extension v1.3 in P3D 3.4.14, anyone else having same issue?

Yes, notice it today after updating to 3.4.14

Will open a support ticket via Carenado website.

 

Amos

Share this post


Link to post
Share on other sites

I have been using the Phenom 300 and no CTD's related to Navigraph.  I just downloaded the lastest NAV data and it loaded properly How can you tell if the crash is related to Navigraph?  As stated on many occasions, you cannot try to load the Carenado module CMeteoxml.dll so you need to disable that entry in the dll.xml if the entry is there.  You also need to rename the CMeteoxml.dll in the main P3D folder to CMeteoxml.off so it will not load (every .dll in the main P3D folder will load whether you want it to or not).  The Phenom 300 is running great in P3D but there are some issues when I fly near FSDT KLAX in Orbx SoCal territory.  There is something in the KLAX area that is eating up VAS.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

I bought it today from their site and it had a P3D3 installer.  Works fine as far as I see.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this