Sign in to follow this  
bigpappy777

P3D V3 Compatible

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

It is not compatible at this time. This company does a very poor job at updating their aircraft when new P3D versions come out. Every other payware addons I have is now V3 compatible but this one. To add insult to injury they continue to release new aircraft all the while providing no support to those aircraft that people have already purchased. I would be very careful buying a P3D products from Carenado. 

  • Upvote 1

Share this post


Link to post
Share on other sites

I have 50 flights with it in 3.2 with no issues.  Just purchased it a few months ago, maybe a different version.

Share this post


Link to post
Share on other sites

Just purchased P3Dv3. I got the 1900 working by downloading from the site of my original purchase (over 2 years ago) and installing that way. Looks great!

Share this post


Link to post
Share on other sites

Looks okay, but I wouldn't say great in P3D v3.3. There are still exterior texture issues. It's funny that their P46T Malibu, which is an older aircraft in their hanger, and it works better in P3D than the 1900.

Share this post


Link to post
Share on other sites

I just tried to have a flight yesterday night with P3DV3.4 and the autopilot had totally random behavior, you just can't set the alt in the alt setting for instance.

This plane was absolutely OK before but it seems that V3.4 changed the rules.

Share this post


Link to post
Share on other sites

Thanks for posting this, NN_Avirex. I was considering to get the 1900D during the sale, but it appears it wouldn't be of any use for me.

 

Peter

Share this post


Link to post
Share on other sites

I just tried to have a flight yesterday night with P3DV3.4 and the autopilot had totally random behavior, you just can't set the alt in the alt setting for instance.

This plane was absolutely OK before but it seems that V3.4 changed the rules.

Fancied getting this plane since back in my FSX days but only got it after I upgraded to P3DV3.4. I'm glad you posted you were having problems with it because I for the life of me couldn't figure out what I was doing wrong...

Share this post


Link to post
Share on other sites

Try the 2D AP panel with the 1900 in P3D. The AP definitely works better that way.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this