Jump to content
Sign in to follow this  
willultra99

UT2 for V3

Recommended Posts

It is pretty easy, look for your exe.xml of P3D. add these lines to it. Remember to add the path of the UT"services.exe.

 

 <Launch.Addon>
     <Disabled>False</Disabled>
     <ManualLoad>False</ManualLoad>
     <Name>UT2</Name>
     <Path>IS WHERE YOUR UT2SERVICES.exe IS LOCATED ON YOUR SSD</Path>
     <NewConsole>True</NewConsole>
  </Launch.Addon>
 
Then look for the simobjects.cfg. Add this line under the very last entry of the .cfg and replace the big red X with the next following number.
 
SimObjectPaths.X=PATH WERE THE UT2 AIRCRAFTS ARE INSTALLED WITHIN FSX\UT2 Aircraft
 
You shouldnt get an error message as you have FSX properly installed.

Greetz


MJ


 


My youtube blog________________________Prepar3D v2.5/v3


youtubefooter.jpg

Share this post


Link to post

 

It is pretty easy, look for your exe.xml of P3D. add these lines to it. Remember to add the path of the UT"services.exe.

 

 <Launch.Addon>
     <Disabled>False</Disabled>
     <ManualLoad>False</ManualLoad>
     <Name>UT2</Name>
     <Path>IS WHERE YOUR UT2SERVICES.exe IS LOCATED ON YOUR SSD</Path>
     <NewConsole>True</NewConsole>
  </Launch.Addon>
 
Then look for the simobjects.cfg. Add this line under the very last entry of the .cfg and replace the big red X with the next following number.
 
SimObjectPaths.X=PATH WERE THE UT2 AIRCRAFTS ARE INSTALLED WITHIN FSX\UT2 Aircraft
 
You shouldnt get an error message as you have FSX properly installed.

 

 

Hi Mickey, thanks for this. It seems my ut2services dont get loaded and also dont appear in the addon task bar within P3D. something must be wrong. if you could help would be great.

FSX is installed and working as well as UT2 with latest db schedule.

 

This is how i have it set now:

 

For the exe.xml locations there is two on my system:

 

1. C:\Users\stephan\AppData\Roaming\Lockheed Martin\Prepar3D v3

2. C:\ProgramData\Lockheed Martin\Prepar3D v3

 

So I added these lines to both, I confirmed that the ut2services.exe is in that folder specified below:

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="AceXML" version="3,0" id="exe">
<Descr>AceXML Document</Descr>
<Filename>exe.xml</Filename>
  <Launch.Addon>
    <Name>Flight Recorder</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>G:\Prepar3D\Ecosystem\Aerosoft\Flight Recorder\AS-FlightRecorder.dll</Path>
  </Launch.Addon>
</SimBase.Document>
<Launch.Addon>
     <Disabled>False</Disabled>
     <ManualLoad>False</ManualLoad>
     <Name>UT2</Name>
     <Path>C:\FSX\steamapps\common\FSX\Flight One Software\Ultimate Traffic 2\UT2Services.exe>
     <NewConsole>True</NewConsole>
  </Launch.Addon>
 
For the simobjects.cfg file I am not sure I am doing it right as you mentioned just adding the single line to it.
No need to add the [Entry.10]....?:
 
[Entry.0]
Title=Default Airplanes
Path=SimObjects\Airplanes
Required=True
Active=True
[Entry.1]
Title=Default Avatars
Path=SimObjects\Avatars
Required=True
Active=True
[Entry.2]
Title=Default Rotorcraft
Path=SimObjects\Rotorcraft
Required=True
Active=True
[Entry.3]
Title=Default Ground Vehicles
Path=SimObjects\GroundVehicles
Required=True
Active=True
[Entry.4]
Title=Default Boats
Path=SimObjects\Boats
Required=True
Active=True
[Entry.5]
Title=Default Animals
Path=SimObjects\Animals
Required=True
Active=True
[Entry.6]
Title=Default Misc
Path=SimObjects\Misc
Required=True
Active=True
[Entry.7]
Title=Default Submersible
Path=SimObjects\Submersible
Required=True
Active=True
[Entry.8]
Title=Default Weapons
Path=SimObjects\Weapons
Required=True
Active=True
[Entry.9]
Title=Default Countermeasures
Path=SimObjects\Countermeasures
Required=True
Active=True
SimObjectPaths.0=C:\FSX\steamapps\common\FSX\SimObjects\UT2 Aircraft
 
I tried both .0 and .10....
 
thanks 

Stephan Faessler // designer, painter

P1 // vACC Switzerland Controller

impulseai

970abb2d.png

Share this post


Link to post

[Entry.9]

Title=Default Countermeasures

Path=SimObjects\Countermeasures

Required=True

Active=True

SimObjectPaths.0=C:\FSX\steamapps\common\FSX\SimObjects\UT2 Aircraft

 

I tried both .0 and .10....

 

thanks

 

 

Hi Stephan,

 

0 < 9. Has to be 10. Also try this entry in Simobject.cfg. This assumes 10 is the next sequentially available number. Also you csn set Required=False for this entry. UT2 is not default:

 

[Entry.10]

Title=UT2 Aircraft

Path=C:\FSX\steamapps\common\FSX\Simobjects\UT2 Aircraft

Required=False

Active=True

 

The single line entry you added, needs to be put into your FSX.cfg file. If FSX is installed on your machine, put it in the actual file. If not, add it into the fake/copy you created. Put it into the [Main] section. Again if, for any reason, there are any other Simobjects entries, they have to be consecutive.


Regards,

Graham Derreck

CYMM

Share this post


Link to post

Hi Stephan,

 

0 < 9. Has to be 10. Also try this entry in Simobject.cfg. This assumes 10 is the next sequentially available number. Also you csn set Required=False for this entry. UT2 is not default:

 

[Entry.10]

Title=UT2 Aircraft

Path=C:\FSX\steamapps\common\FSX\Simobjects\UT2 Aircraft

Required=False

Active=True

 

The single line entry you added, needs to be put into your FSX.cfg file. If FSX is installed on your machine, put it in the actual file. If not, add it into the fake/copy you created. Put it into the [Main] section. Again if, for any reason, there are any other Simobjects entries, they have to be consecutive.

 

Hi Graham, thanks.

hmmm. still nothing. this is how it looks like now:

 

in C:\Users\stephan\AppData\Roaming\Lockheed Martin\Prepar3D v3:

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>exe.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>as_btstrp_config_manager</Name>
    <Disabled>False</Disabled>
    <Path>as_srv\as_btstrp_config_manager.exe</Path>
  </Launch.Addon>
</SimBase.Document>
<Launch.Addon>
     <Disabled>False</Disabled>
     <ManualLoad>False</ManualLoad>
     <Name>UT2</Name>
     <Path>C:\FSX\steamapps\common\FSX\Flight One Software\Ultimate Traffic 2\UT2Services.exe>
     <NewConsole>True</NewConsole>
  </Launch.Addon>
 
in C:\ProgramData\Lockheed Martin\Prepar3D v3:
 
<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="AceXML" version="3,0" id="exe">
<Descr>AceXML Document</Descr>
<Filename>exe.xml</Filename>
  <Launch.Addon>
    <Name>Flight Recorder</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>G:\Prepar3D\Ecosystem\Aerosoft\Flight Recorder\AS-FlightRecorder.dll</Path>
  </Launch.Addon>
</SimBase.Document>
<Launch.Addon>
     <Disabled>False</Disabled>
     <ManualLoad>False</ManualLoad>
     <Name>UT2</Name>
     <Path>C:\FSX\steamapps\common\FSX\Flight One Software\Ultimate Traffic 2\UT2Services.exe>
     <NewConsole>True</NewConsole>
  </Launch.Addon>
 
in the same location for the simobjects.cfg:
 
[Entry.0]
Title=Default Airplanes
Path=SimObjects\Airplanes
Required=True
Active=True
[Entry.1]
Title=Default Avatars
Path=SimObjects\Avatars
Required=True
Active=True
[Entry.2]
Title=Default Rotorcraft
Path=SimObjects\Rotorcraft
Required=True
Active=True
[Entry.3]
Title=Default Ground Vehicles
Path=SimObjects\GroundVehicles
Required=True
Active=True
[Entry.4]
Title=Default Boats
Path=SimObjects\Boats
Required=True
Active=True
[Entry.5]
Title=Default Animals
Path=SimObjects\Animals
Required=True
Active=True
[Entry.6]
Title=Default Misc
Path=SimObjects\Misc
Required=True
Active=True
[Entry.7]
Title=Default Submersible
Path=SimObjects\Submersible
Required=True
Active=True
[Entry.8]
Title=Default Weapons
Path=SimObjects\Weapons
Required=True
Active=True
[Entry.9]
Title=Default Countermeasures
Path=SimObjects\Countermeasures
Required=True
Active=True
[Entry.10] 
Title=UT2 Aircraft
Path=C:\FSX\steamapps\common\FSX\Simobjects\UT2 Aircraft
Required=False
Active=True
 
in the fsx.cfg under [Main]:
[Main]
User Objects=Airplane, Helicopter
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
SimObjectPaths.6=SimObjects\UT2 Aircraft
ProcSpeed=7080
PerfBucket=7
Maximized=2
Location=440,130,1480,908,\\.\DISPLAY1
HideMenuNormal=0
HideMenuFullscreen=1
DisablePreload=1
 
thanks and sorry for the troubles.
appreciated, thanks 
 
 

I just got an xml error by active sky mentioning an error. so my typing or spacing must be wrong...


Stephan Faessler // designer, painter

P1 // vACC Switzerland Controller

impulseai

970abb2d.png

Share this post


Link to post

Stephen, Here is the exe.xml you referenced in your last post:
 
<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>exe.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>as_btstrp_config_manager</Name>
    <Disabled>False</Disabled>
    <Path>as_srv\as_btstrp_config_manager.exe</Path>
  </Launch.Addon>

</SimBase.Document>
<Launch.Addon>
     <Disabled>False</Disabled>
     <ManualLoad>False</ManualLoad>
     <Name>UT2</Name>
     <Path>C:\FSX\steamapps\common\FSX\Flight One Software\Ultimate Traffic 2\UT2Services.exe>
     <NewConsole>True</NewConsole>
  </Launch.Addon>

 

The following entry is in the middle of the document. It has to be the last entry:

</SimBase.Document>

 

Your exe.xml should look like this:

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>exe.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>as_btstrp_config_manager</Name>
    <Disabled>False</Disabled>
    <Path>as_srv\as_btstrp_config_manager.exe</Path>
  </Launch.Addon>

  <Launch.Addon>
     <Disabled>False</Disabled>
     <ManualLoad>False</ManualLoad>
     <Name>UT2</Name>
     <Path>C:\FSX\steamapps\common\FSX\Flight One Software\Ultimate Traffic 2\UT2Services.exe>
     <NewConsole>True</NewConsole>
  </Launch.Addon>

</SimBase.Document>

 

Entry in bold to help location 


Regards,

Graham Derreck

CYMM

Share this post


Link to post

thanks Graham, do i have to edit both exe.xml

i have two locations for the exe.xml files


ok updated it in only this location:

C:\Users\stephan\AppData\Roaming\Lockheed Martin\Prepar3D v3

no errors on startup which is good but no traffic...do i have to set traffic on under settings as well? normally this externally controlled...


ok updated it in only this location too:

C:\ProgramData\Lockheed Martin\Prepar3D v3

 

no error and started up but also no traffic :-(


edit: ok the path was wrong at the end.

now i get a red stop sign for a few sec then sim starts. but still no traffic

 

here is the exe.xml:

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>exe.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>as_btstrp_config_manager</Name>
    <Disabled>False</Disabled>
    <Path>as_srv\as_btstrp_config_manager.exe</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Name>UT2</Name>
    <Path>C:\FSX\steamapps\common\FSX\Flight One Software\Ultimate Traffic 2\UT2Services.exe</Path>
    <NewConsole>True</NewConsole>
  </Launch.Addon>
</SimBase.Document>
 
 
<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="AceXML" version="3,0" id="exe">
<Descr>AceXML Document</Descr>
<Filename>exe.xml</Filename>
  <Launch.Addon>
    <Name>Flight Recorder</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>G:\Prepar3D\Ecosystem\Aerosoft\Flight Recorder\AS-FlightRecorder.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Name>UT2</Name>
    <Path>C:\FSX\steamapps\common\FSX\Flight One Software\Ultimate Traffic 2\UT2Services.exe</Path>
    <NewConsole>True</NewConsole>
  </Launch.Addon>
</SimBase.Document>
 
 

edit 2:

okay so I removed the entry in this location : 

C:\ProgramData\Lockheed Martin\Prepar3D v3

 

and i see traffic now from UT2, but i have no VC now. my entry must be still wrong in the exe.xml ?

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>exe.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>as_btstrp_config_manager</Name>
    <Disabled>False</Disabled>
    <Path>as_srv\as_btstrp_config_manager.exe</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Name>UT2</Name>
    <Path>C:\FSX\steamapps\common\FSX\Flight One Software\Ultimate Traffic 2\UT2Services.exe</Path>
    <NewConsole>True</NewConsole>
  </Launch.Addon>
</SimBase.Document>

Stephan Faessler // designer, painter

P1 // vACC Switzerland Controller

impulseai

970abb2d.png

Share this post


Link to post

 

thanks Graham, do i have to edit both exe.xml

i have two locations for the exe.xml files

ok updated it in only this location:

C:\Users\stephan\AppData\Roaming\Lockheed Martin\Prepar3D v3

no errors on startup which is good but no traffic...do i have to set traffic on under settings as well? normally this externally controlled...

ok updated it in only this location too:

C:\ProgramData\Lockheed Martin\Prepar3D v3

 

no error and started up but also no traffic :-(

edit: ok the path was wrong at the end.

now i get a red stop sign for a few sec then sim starts. but still no traffic

 

here is the exe.xml:

 

<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>exe.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>as_btstrp_config_manager</Name>
    <Disabled>False</Disabled>
    <Path>as_srv\as_btstrp_config_manager.exe</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Name>UT2</Name>
    <Path>C:\FSX\steamapps\common\FSX\Flight One Software\Ultimate Traffic 2\UT2Services.exe</Path>
    <NewConsole>True</NewConsole>
  </Launch.Addon>
</SimBase.Document>
 
 
<?xml version="1.0" encoding="Windows-1252"?>
<SimBase.Document Type="AceXML" version="3,0" id="exe">
<Descr>AceXML Document</Descr>
<Filename>exe.xml</Filename>
  <Launch.Addon>
    <Name>Flight Recorder</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>G:\Prepar3D\Ecosystem\Aerosoft\Flight Recorder\AS-FlightRecorder.dll</Path>
  </Launch.Addon>
  <Launch.Addon>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Name>UT2</Name>
    <Path>C:\FSX\steamapps\common\FSX\Flight One Software\Ultimate Traffic 2\UT2Services.exe</Path>
    <NewConsole>True</NewConsole>
  </Launch.Addon>
</SimBase.Document>
 
 

 

 

Hallo Stefan, 

 

you dont have to set traffic within P3D as UT2 is in charge. You need to edit just the exe.xml which is located in the C:\ProgramData\Lockheed Martin\Prepar3D v3

 

What you can do is to check if UT2 is listed under the Add On menu in P3D. If it starts during Sim startup you should here the Ultimate Traffic 2 aural. If this is not the case you can start it manually via a double click on ut2services.exe.


Greetz


MJ


 


My youtube blog________________________Prepar3D v2.5/v3


youtubefooter.jpg

Share this post


Link to post

Hallo Stefan, 

 

you dont have to set traffic within P3D as UT2 is in charge. You need to edit just the exe.xml which is located in the C:\ProgramData\Lockheed Martin\Prepar3D v3

 

What you can do is to check if UT2 is listed under the Add On menu in P3D. If it starts during Sim startup you should here the Ultimate Traffic 2 aural. If this is not the case you can start it manually via a double click on ut2services.exe.

 

Hi MJ

That did not work, i have to edit the location in AppData Roaming LM P3D location. if i use this location C:\ProgramData\Lockheed Martin\Prepar3D v3. I see no AI traffic but when I use this location : C:\Users\stephan\AppData\Roaming\Lockheed Martin\Prepar3D v3 I see AI traffic and the menu entry in the add on bar, but i dont have any VC with this option...

 

edit:

 

ok got it to work now, I removed this line: 

    <NewConsole>True</NewConsole>
 
now the VC appears and AI traffic is started with add on entry, nice.
will give it a try now if all works thanks much everyone!!

Stephan Faessler // designer, painter

P1 // vACC Switzerland Controller

impulseai

970abb2d.png

Share this post


Link to post

 

Hi MJ

That did not work, i have to edit the location in AppData Roaming LM P3D location. if i use this location C:\ProgramData\Lockheed Martin\Prepar3D v3. I see no AI traffic but when I use this location : C:\Users\stephan\AppData\Roaming\Lockheed Martin\Prepar3D v3 I see AI traffic and the menu entry in the add on bar, but i dont have any VC with this option...

 

edit:

 

ok got it to work now, I removed this line: 

    <NewConsole>True</NewConsole>
 
now the VC appears and AI traffic is started with add on entry, nice.
will give it a try now if all works thanks much everyone!!

 

 

Sounds great  :smile:  UT2 is a great add on but can give lots of headache to install into P3D. If you have the ne FSUIPC version then you can try to limit the traffic further see here http://www.avsim.com/topic/500104-fsuipc-4959-now-has-an-ai-traffic-limiter-somewhat-like-the-traffic-optimizer-addon/page-3?hl=%2Bfsuipc+%2Btraffic#entry3533837


Greetz


MJ


 


My youtube blog________________________Prepar3D v2.5/v3


youtubefooter.jpg

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...