fscottee

New G2XPL feature - latest build

Recommended Posts

 

I've got the latest build and its great.  Couple things I notice...

 

Ttextures are now the same quality as those that are produced by FSEarthtiles (FSX/P3D).  It seems g2xpl tiles always seemed washed out and lacking in contrast and saturation - that's been fixed.  

 

And the new ability to draw out the area you want higher res using Google Earth KML files is a gift from heaven.

 

The way it works is this.  I draw out my area I want at say ZL18 (60 cm).  I then tell g2xpl if I want the remainder of the tile to be Zl15, ZL16, or ZL17. 

 

Saves space and time if needs be. 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I just donated to developer. He responded within 30 mins (hats off to him) and sent me the latest beta version. Can't wait to try it. Would be great if there was a way of only keeping the polygon area whilst excluding the rest of the tile and keeping it as standard textures.

Share this post


Link to post
Share on other sites

hmm and for owners of the old full versions (already donated), is there some update to download or should I write Rob an email ??

 

cheers !!

Share this post


Link to post
Share on other sites

hmm and for owners of the old full versions (already donated), is there some update to download or should I write Rob an email ??

 

cheers !!

You need to email Rob.

Share this post


Link to post
Share on other sites

I do like the addition of being able to access WMS map services like the USGS site (national map viewer).  FYI these are the same photoscenery used by MegasceneryEarth 2.0 for their FSX scenery.  Now we can have it too, with autogen on top.

Share this post


Link to post
Share on other sites

fscotee, do you know what quality or ZL Megascenery earth uses? I mean there latest one? I just got the latest beta of g2xpl and have been using it to create my own orthophoto sceneries and the results haven't been consistent. I tried making sceneries for areas around Korea and Vietnam, and using virtualearth to pull my images from. I'm guessing thats bing maps. I don't know which service provides the best quality. I have been using google in the start and they seem to be the best, at least for coverage in the US, not sure about other countries. However I can only download a certain amount from google before I get an error. So I would have to wait a few days and do it again. This makes it a pain in the butt to create sceneries.

 

Now does the USGS service you mention have any limits on the amount you can download like google? and how is the quality of their textures? I would like to use them the next time I fire up g2xpl. Does it need to be configured or anything?

 

Would love to hear your thoughts. Thanks.

Share this post


Link to post
Share on other sites

The USGS textures can be viewed here:

 

http://viewer.nationalmap.gov/viewer/

 

On the left, select either "imagery 1 foot" or "imagery 1 meter", and give it a few seconds to load.  The 1 meter imagery is what MSE 2.0 uses.  The 1 foot imagery only covers about 40% of the USA.   I'm not sure what MSE 4x is using.  Hopefully it's more than just USGS since there it limited coverage.

 

I haven't run into a download limits with USGS.  If you start g2xpl while in X-Plane, just select USA as the service and it loads auto automatically.

 

Bing seems to be the most consistent and I don't see any download limits.

Share this post


Link to post
Share on other sites

fscottee thanks for the info. I run g2xpl primarily through the command line only. I don't launch it through X-Plane. I looked at my g2xpl.ini file and this is the only entry I found for USGS, but it says its for Scandinavia only.

 

[service5]
active=no
module_config=server=http://isse.cr.usgs.gov|path=/arcgis/services/Orthoimagery/USGS_EROS_Ortho/ImageServer/WMSServer/?REQUEST=GetMap&VERSION=1.1.1&SERVICE=WMS&SRS=EPSG:4326&STYLES=default&FORMAT=image/jpeg&LAYERS=0&BBOX=%lo1,%la1,%lo2,%la2&width=%r&height=%r
resolution=4096
comment=hitta.se, Scandinavia only
map_version=
test_point_long=
test_point_lat=

Share this post


Link to post
Share on other sites

USGS is only for USA.  The config file is all confused for some reason.  It writes over itself, I thot Robert was going to fix it but its still happening.  Regardless, it still works even though it looks screwy.  The easiest way I found is to go into X-Plane and set up g2xpl, and run it briefly from there.  Exit out and go to the command prompt and restart it by typien g2xpl.  It will start where it left off.

Share this post


Link to post
Share on other sites

Thanks for the tips. So I'm guessing ZL17=50cm? Which is what Megasceneryearth 2.0 is?

 

Strange, when using USGS as the service, I get an error after 3 minutes and it quits with this message:

 

G2xpl quits with exit code -21:
 
Even very low resolution textures are not available for requested area when usin
g activated Service(s)
program has been running for 7 min, 39 sec
 
Press any key to close G2xpl window
 
I was trying to create orthos for Austin, Texas area. Any ideas?

Share this post


Link to post
Share on other sites

ZL17=1 meter, ZL18=50cm.

 

The error you get with USGS is normal because the map service won't allow you to download different resolution tiles.  For instance, if you want to download 50 cm tiles via USGS, and the scenery you are downloading isn't 100% 50cm, then g2xpl would try to download the next best resolution and continue with 1 meter as an example.  USGS won't allow that, you can't switch.  So what it does is download all the 50cm tiles and that's it. 

 

Two option,s you can change the resolution to 1 meter and stick with USGS or keep resolution at 50cm and change the map service to Bing or Google, or something else.  G2xpl will then fill in the rest of the tiles that didn't get downloaded.

 

USGS covers the entire USA with 1 meter, but there are places where the resolution is even less than that.  So you'll still run into that problem occasionally.

Share this post


Link to post
Share on other sites

But I have my g2xpl settings to grab ZL17, so thats 1 meter, but I'm still getting that error. I have to rerun it everytime it happens.

 

And just of now I'm getting another error:

 

Launching 20 worker threads & 8 consumer threads
Corrupt JPEG data: premature end of data segment_____________________< 224926
Invalid JPEG file structure: two SOI markers
 
G2xpl quits with exit code -30:
 
Error while decoding jpg data
program has been running for 8 min, 44 sec
 
Press any key to close G2xpl window

Share this post


Link to post
Share on other sites

USGS isnt entirely 1 meter, so you're probably in an area where it's less resolution. So you'll get the error.

 

You can look in the texture folder it creates to see how many tiles it downloaded.  Simply go into the config file and change the map service to Bing or Google and it will use those map services to download the remainder of the tiles.

 

I've never seen the other error there.  You may want to delete the scenery and start over.

Share this post


Link to post
Share on other sites

Just got this program the other day and having some teething issues (probably just me). Have produced a few things but one thing I am not sure about is if I produce a 1x1 area at ZL17 it is saying about 27GB but after reading around most places say a 1x1 tile should be around 8GB at ZL17.

 

Any ideas?

 

I have used the polygon shape on a few areas and those are fine and come in around 4GB even though the are covered is about 40-50% of the 1x1 tile so not sure why the whole tile is then 5 or 6 times larger.

Share this post


Link to post
Share on other sites

I've found the Bing aerial imagery better quality than the USGS imagery, at least when I generated Massachusetts. The USGS imagery seems to have lots of banding and a change of season in this area, whereas Bing was very consistent (and I've found it to be the case in large parts of Europe as well)

Share this post


Link to post
Share on other sites

How much larger would a tile being with night textures as well as without night textures the lighting is a little dull. A z16 is around 2GB so would it double the size?

Share this post


Link to post
Share on other sites

Hi I'm posting here hoping might get some help with g2xpl, I donated and received full version, (oct-7-15), "g2xpl 6_71". Installed per the install link online info i think had a hard time understanding, Am running it by command line. Problem is I haven't had a successful  scenery creation yet. Am posting below my command window documentation and attaching my g2xpl.ini in hope that someone that's got a better understanding than me might help me get this application working. Please!

My computer is:

Asus i7-4770, 24 gb ram, graphics-EVGA GeForce GTX 970 4GB SSC Gaming ACX 2.0+ Cooling Graphics Card w/ CUDA, windows 10 home, 6 TB H/Drive space, will soon be upgrading to 32 gb ram, am  using cuda with cuda files that came with g2xpl.

 

COMMAND PROMPT WINDOW OPENED AS ADMINISTRATOR

 
J:\#-X-PLANE 10 UPDATED BETA3\X-Plane 10\Resources\plugins\g2xpl 6_71>g2xpl
G2xpl ver. 6.71 (enhanced version)
Contact: g2xpl@hotmail.com
Reading g2xpl.ini file for input parameters
Scenery name cannot be empty, will use name z_g2xpl
WARNING: it is not recommended to use more then 1 Service for generating 1 single texture (only_one_service_per_texture=no)
Config file g2xpl.ini read successfully
Press CTRL+C to break program execution
NVIDIA GPU (CUDA) acceleration used for DDS textures creation
All required DLL's successfully loaded
CACHE folder created
Creating/updating scenery z_g2xpl ...
Now will process 1 1x1 deg DSF scenery volumes
 
PROCESSING DSF (-87,34) VOLUME 1 OF 1
Copying DSF file +34-087.dsf into TEMP dir
Converting DSF file to text file with DSFtool.
DSFTool output messages:
************************************************************
Converting J:\#-X-PLANE 10 UPDATED BETA3\X-Plane 10\Resources\plugins\g2xpl 6_71\G2xpl_temp\+34-087.dsf from DSF to text as J:\#-X-PLANE 10 UPDATED BETA3\X-Plane 10\Resources\plugins\g2xpl 6_71\G2xpl_temp\+34-087.dsf.dsf2txt
File J:\#-X-PLANE 10 UPDATED BETA3\X-Plane 10\Resources\plugins\g2xpl 6_71\G2xpl_temp\+34-087.dsf had 112 ter, 0 obj, 153 pol, 4 net.
Converted J:\#-X-PLANE 10 UPDATED BETA3\X-Plane 10\Resources\plugins\g2xpl 6_71\G2xpl_temp\+34-087.dsf to J:\#-X-PLANE 10 UPDATED BETA3\X-Plane 10\Resources\plugins\g2xpl 6_71\G2xpl_temp\+34-087.dsf.dsf2txt
************************************************************
End of DSFTool output messages
 
DSF file successfully decompiled to text file
DSF file (-87,34) copied and disassembled successfully into temp folder
Initial scan of DSF volume...
DSF volume processing:
40262 orthophoto patches added to +34-087.dsf volume
Converting text files back to DSF binary file +34-087.dsf
Assembling DSF2TXT file
Converting dsf2text file back to dsf using DSFTool:
DSFTool output messages:
************************************************************
Converting J:\#-X-PLANE 10 UPDATED BETA3\X-Plane 10\Resources\plugins\g2xpl 6_71\G2xpl_temp\+34-087.dsf.converted.dsf2txt from text to DSF as J:\#-X-PLANE 10 UPDATED BETA3\X-Plane 10\Resources\plugins\g2xpl 6_71\G2xpl_temp\+34-087.dsf.tmp
Scanning for dimension properties...
Got dimension properties, establishing file writer...
ERROR: could not open file J:\
ERROR: Error convertiong J:\#-X-PLANE 10 UPDATED BETA3\X-Plane 10\Resources\plugins\g2xpl 6_71\G2xpl_temp\+34-087.dsf.converted.dsf2txt to J:\#-X-PLANE 10 UPDATED BETA3\X-Plane 10\Resources\plugins\g2xpl 6_71\G2xpl_temp\+34-087.dsf.tmp
************************************************************
End of DSFTool output messages
 
 
G2xpl quits with exit code -14:
 
Error during DSFTool conversion (from dsftxt file to dsf)
You might run out of RAM memory or the input DSF file format is not supported by G2xpl
 
Press any key to close G2xpl window
--------------------------------------------------------------
 
 
Don't see how to attach file so posting my g2xpl ini
 
 
#G2XPL config file[Main]scenery_name=z_G2xpl_scenery
Xplane_dir=J:\#-X-PLANE 10 UPDATED BETA3\X-Plane 10
 
[Plugin]plane_long=-86.9834
plane_lat=34.5810
hi_res_textures_threshold_radius_m=0
loop_rerun_distance_m=9000
loop_rerun_every_sec=300
pause_simulator_after_conv=yes
[internetServices]
ISMapsCacheDir=F:\xplane\G2xpl_cache
IS_zoom_level=17
blank_texture_threshold_percent=90
 
#Google[service0]active=yes
scenery_name=z_G2xpl_google
module_config="conn=20|rate=2.0|verbose=0|server=http://khm*.google.com|path=/kh?v=%v&x=%X&y=%Y&z=%Z&s=%b|balance_string=Galileo|balance=0123|useragent=Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0|captchaconfig="cookiedomain=google.com|cookieurl=www.google.com"
map_version=165
#Bing Maps[service1]active=yes
scenery_name=z_G2xpl_bing
module_config="conn=20|rate=2.0|verbose=0|server=http://ecn.t*.tiles.virtualearth.net|path=/tiles/a%s.jpeg?g=%v|quad=0123|balance=0123|useragent="
map_version=3179
#Yahoo maps
#removed = ovi maps#[service2]#active=no
#scenery_name=z_G2xpl_yahoo
#module_config="server=http://maps*.yimg.com|path=/ae/ximg?t=a&s=256&.intl=en&x=%x&y=%y&z=%z&r=1|balance=123|useragent="
#map_version=
#ovi Nokia maps (=Yahoo)[service2]active=no
scenery_name=z_G2xpl_ovi_yahoo
map_version=
 
#MapQuest maps[service3]active=no
scenery_name=z_G2xpl_mapquest
module_config="server=http://ttiles0*.mqcdn.com|path=/tiles/1.0.0/vx/sat/%Z/%X/%Y.png|balance=1234|useragent="
map_version=
 
[Graphics]
nominal_orthophotos_res=2048
force_rebuilding_partial_DDS_textures=no
used_resample_filter=1
cover_water_areas_orthophotos=no
remove_beach_info=no
filter_out_original_triangles=no
NVIDIA_CUDA_acceleration=yes
DDS_conversion_threads_no=4
 
[Night_textures]create_night_textures=no
ImageMagick_dir=
command_line_params_night_text=algorithm1
 
[Net]
http_proxy=
http_proxy_user_password=
download_threads_no=15
download_quota_kb=500000
[service0]
scenery_name=
map_version=
module_config=
active=no
[Main]
scenery_name=z_g2xpl
[service1]
scenery_name=
map_version=
module_config=
active=no
[service2]
scenery_name=
map_version=
module_config=
active=no
[service3]
scenery_name=
map_version=
module_config=
active=no
[service4]
scenery_name=
map_version=
module_config=
active=no
[service5]
scenery_name=
map_version=
module_config=
active=no
------------------------------------------------------
 
hoping for reply
Steve

Share this post


Link to post
Share on other sites

Hi Steve,

Not sure why you are getting the error but this is my ini file if that helps you.

 

#G2XPL config file

[settings]
scenery_name=z_+40 -115_Z16
Xplane_dir=
plane_long=-115.5
plane_lat=40.5
hi_res_textures_threshold_radius_m=0
loop_rerun_distance_m=14000
loop_rerun_every_sec=300
pause_simulator_after_conv=yes
IS_zoom_level_low_res_delta=0
IS_zoom_level=16
blank_texture_threshold_percent=80
create_tga_instead_dds_textures=no
 
nominal_orthophotos_res=4096
ks
used_resample_filter=1
cover_water_areas_orthophotos=no
remove_beach_info=yes
NVIDIA_CUDA_acceleration=no
gamma=1.000000
DDS_conversion_threads_no=0
create_night_textures=no
ImageMagick_dir=
command_line_params_night_text=algorithm1
http_proxy=
http_proxy_user_password=
 
download_threads_no=12
 
download_quota_kb=0
 
 
[service0]
active=no
module_config=server=http://khms*.google.com|path=/kh/v=%v&x=%X&y=%Y&z=%Z&s=%b|balance_string=Galileo|balance=0123|useragent=Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
map_version=190
 
comment=Bing maps, global Service
resolution=
test_point_long=
test_point_lat=
 
[service1]
active=yes
module_config=server=http://ecn.t*.tiles.virtualearth.net|path=/tiles/a%s.jpeg?g=%v|quad=0123|balance=0123|useragent=
map_version=4752
g
comment=usgs.gov maps, only USA
resolution=
test_point_long=
test_point_lat=
 
[service2]
active=no
map_version=
comment=Here maps, global Service
resolution=
test_point_long=
test_point_lat=
 
[service3]
active=no
map_version=
comment=Ovi maps, global Service
resolution=
test_point_long=
test_point_lat=
 
[service4]
active=no
module_config=server=http://ttiles0*.mqcdn.com|path=/tiles/1.0.0/vy/sat/%Z/%X/%Y.jpg|balance=1234|useragent=Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
map_version=
comment=MapQuest maps, global Service
resolution=
test_point_long=
test_point_lat=
 
[service5]
active=no
module_config=server=http://isse.cr.usgs.gov|path=/arcgis/services/Orthoimagery/USGS_EROS_Ortho/ImageServer/WMSServer/?REQUEST=GetMap&VERSION=1.1.1&SERVICE=WMS&SRS=EPSG:4326&STYLES=default&FORMAT=image/jpeg&LAYERS=0&BBOX=%lo1,%la1,%lo2,%la2&width=%r&height=%r
resolution=4096
comment=hitta.se, Scandinavia only
map_version=
test_point_long=
test_point_lat=
 
[service6]
active=no
module_config=server=http://static.hitta.se|path=/tile/v3/1/%Z/%x/%y|useragent=Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
map_version=
test_point_long=15.500
test_point_lat=56.500
comment=gulesider.no, Scandinavia only
resolution=
 
[service7]
active=no
module_config=server=http://map0*.eniro.no|path=/geowebcache/service/tms1.0.0/aerial/%Z/%x/%y.jpeg|balance=12345|useragent=Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
test_point_long=15.500
test_point_lat=56.500
comment=goeportal.pl Poland only
map_version=
resolution=
 
[service8] 
active=no
module_config=server=http://mapy.geoportal.gov.pl|path=/wss/service/img/guest/ORTO/MapServer/WMSServer?FORMAT=image/jpeg&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=Raster&SRS=EPSG:4326&STYLES=&WIDTH=%r&HEIGHT=%r&BBOX=%lo1,%la1,%lo2,%la2|useragent=
resolution=2048
test_point_long=19.500
test_point_lat=51.500
comment=grafcan (idecan), Canary Islands only
map_version=
 
[service9] 
active=no
module_config=server=http://idecan1.grafcan.es|path=/ServicioWMS/OrtoExpress?REQUEST=GetMap&VERSION=1.1.1&SERVICE=WMS&SRS=EPSG:4326&STYLES=default&FORMAT=image/jpeg&LAYERS=ortoexpress&BBOX=%lo1,%la1,%lo2,%la2&width=%r&height=%r|useragent=Mozilla/5.0 (Windows NT 10.0; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
resolution=1024
test_point_long=-16.5
test_point_lat=28.000
comment=Google Maps, global Service
map_version=
 
[service10]
active=no
test_point_long=16.111
test_point_lat=50.46
comment=mapy.cz Czech Rep and Slovakia
map_version=
resolution=

Share this post


Link to post
Share on other sites

Thanks razalom  used a few of your settings but did not work, guess the problems not my g2xpl ini, I did notice something else, I use flywithlua and went on my xplane and got a notice of sorts at top left side of screen stating lua could not open as could not find a directory, are there any issues with g2xpl and lua existing together  at same time in xp's plugins folder?? as LUA was running fine before installing g2xpl.

Steve

Share this post


Link to post
Share on other sites

I have flywithlua installed and it doesnt cause me any issues. Did you try not entering anything as the X-Plane folder location as I used to have my location added and it caused different issues to you and since I just didnt have a location that problem went away.

Share this post


Link to post
Share on other sites

ok give a try


Rats! no beans, thought you were on to something there, same issue, no change. wish I could find out what exit code 14 refers to.

Share this post


Link to post
Share on other sites

So J is a drive letter you have Xplane installed on?

 

Another thing you have 2 services set to yes. As per my ini I was using the 2nd one and had the google one off.

 

Also might be worth backing up your INI file and then copying my ini file information on to yours and see how that goes.

Share this post


Link to post
Share on other sites

I'm using win7 and indeed g2xpl runs fine.
But ....
After making a tile +40+30 with Z17, I noticed that all my .dds files 512x512 instead of 4096x4096.

The names of the .ter files are g2xpl_18_xxxx_xxxx_4096.ter
The names of the .dds files are g2xpl_18_xxxx_xxxx_512.dds  (under native Windows the .dds files are 4096x4096).

Is there somebody who can tell me why my .dds files are 512x512?

My g2xpl version is 6.90

I put it under the resources\plugins folder.

Share this post


Link to post
Share on other sites

I used this and love the resolution but am wondering how to create the overalys...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now