Jump to content

Sign in to follow this  
RVxSpeed

MSVCR120.dll CTD with P3D V3

Recommended Posts

 

 


So its hard to believe this is a general problem.

 

Nobody said it was.... and everything you have mentioned has been covered in a 400+ post thread over in the LM forum..., thanks for the suggestions. Both PMDG and LM are aware of that problem.

 

Your insertion of a video driver issue might best be served if it were a different thread on that subject alone, and I recommend you also give the LM forum a try.. it is active and LM participates.


Dan Downs KCRP

Share this post


Link to post

For the sake of testing i again have clicked on the pfd many times in this test. i was in the air for 10 hours but this time before i run p3d i disabled internet access of p3d.exe. After 10 hours passed when i re clicked on the cpt's PFD the display didn't get larger but also the screen didn't Show up in it's own place. its showed up after i reclicked on the PFD. This time error came up after i clicked on the right FO's FMC  with atc.dll error code c0000005. 

Share this post


Link to post

Nobody said it was.... and everything you have mentioned has been covered in a 400+ post thread over in the LM forum..., thanks for the suggestions. Both PMDG and LM are aware of that problem.

Hi Dan,

 

i was one of the silly ones who actually read the whole thread, but i can say this is no fun and simultaneously most probably the reason why it went quiet. Everyone who wants to help will make a turnaround if he sees tons of pages in this thread. At least one of you with the existing problem should make a summary for every newcomer who is willing to help if you want to get it fixed.

 

But this isn't the reason why i am answering.

 

You all were concentrated on which runtimes PMDG and LM are compiling agaist but the Nvidia driver itself brings in the vc++ 2013 (RTM = 12.0.21005.1) If you had followed the advices given, everyone googled for vc++ 2013 from MS in english language and gets this version 12.0.30501.0

 

I really don't know which update that is because not mentioned here:

 

https://onemanwenttomow.wordpress.com/2014/12/03/visual-studio-2013-version-numbers-and-updates/

 

this seems to irritate others, too

https://social.msdn.microsoft.com/Forums/vstudio/en-US/63ef21c3-aea0-46e9-9700-78c39b63f706/which-visual-c-redistributable-package-needed-for-visual-studio-2013-update-3-and-4?forum=vcgeneral

 

Why i am telling this?

 

Because i did some changes on my system and was being able to crash it with CPT PFD popup after 7h again.

 

So what were the changes?:

 

i reorganized vc++ 2013 runtimes (just kept the 2013 v12.0.30501.0)

i activated some of my context menu entries

i used NV inspector again for sparse grid 2x

 

So i wanted to be sure being stable again after doing the 3 following steps:

 

 

1) i extracted the Nvidia driver with 7zip went to MSVCRT folder and added the vc++ runtimes 32 and 64 bit ones manually. So i am having 2 versions of vc++ 2013 each 32 and 64 bit (RTM and v12.0.30501.0)

 

2) i used the shexview.exe tool (and disabled everyhing again and rebooted the sys (maybe i forgot to mention in my tutorial) before the next flight

 

3) opened NV inspector and set the filter options for ingame option.

 

did KLAX-YSSY today in realtime again played several times with the popup DUs and landed safely after 13:38 on 34L,

http://fs5.directupload.net/images/160224/tekdb9hy.jpg

 

tracked without any disconnect by IVAO:

http://fs5.directupload.net/images/160224/rlpuyofc.jpg

 

I don't think this is just coincidence :wink:

 

 

So i would suggest if you still crash check your runtimes more precisely and reinstall the ones the driver is being compiled against (vc++2013 RTM!) too. even they are being listed already reinstall them manually from the driver)

and don't use NI for a testflight and report back. But to be sure i'd recommend the 3rd step also for at least one flight to rule out everything whatever could have caused issues on my pc.

 

something about my environment:

 

still W7 64bitSP1 P3Dv3.1 last leg flown with 77W

FSUIPC active: 4.949g

Nvidia 361.75 WHQL 1920x1080; 680 GTX

ASN up to date (networked)

DEP disabled in UEFI bios, no HT (because i5 2500K)

no affinity mask

ingame setting far beyond default (no changes done there during all my flights)

 

Your insertion of a video driver issue might best be served if it were a different thread on that subject alone, and I recommend you also give the LM forum a try.. it is active and LM participates.

there is already an open topic about that in their forum.


n94knm9w.png

Share this post


Link to post

Hi Paul ,

 

just extracted and installed the vc++2013 RTM version from the nvidia driver and later on this weekend will give it a try ,

 

Thanks Gérard


Best regards ,

Gérard van Veldhoven

Boeing777_Banner_Pilot.jpg

18.png

Share this post


Link to post

crashed after 6.19 hours , with v12.0.30501.0 and RTM = 12.0.21005.1 installed , didn t used nvinspector , using a 4k monitor so ther is no need for nvi


Best regards ,

Gérard van Veldhoven

Boeing777_Banner_Pilot.jpg

18.png

Share this post


Link to post

 

 


crashed after 6.19 hours

 

Hi Gérard,

 

it's a pity to read this, are you at least able to prevent the crash without clicking panels?

 

For the sake of completeness, you also have netframeworkt 4.5.2 and 4.6 installed? (after installing 4.6 you don't see 4.5.2 in software menu anymore)


n94knm9w.png

Share this post


Link to post

Hi Paul ,

 

yes i have 4.5.2 and 4.6 installed , if i don't click the PFD i don't get any crashes , only get them when i click the du s , and it doesn't matter when i click them , if i click them while doing the pre checks i get them later on in flight , if i click on them after 6 7 hours it crashes immediately .

 

Tried every possible solution with Dan but can t seem to get it solved , only workaround for me is not to click the du s , since i have a 40 inch screen that is not a big deal for me .


Best regards ,

Gérard van Veldhoven

Boeing777_Banner_Pilot.jpg

18.png

Share this post


Link to post

Yup, Paul when you first posted your suggestions back on 2/24 I verified such things as vcredist version... this was something that we covered very early after release of P3Dv3.0 at the recommendation of a P3D beta. No joy.

 

Only 2D popup that is a problem for me is the left outboard DU used for Capt PFD...., so I just use the right outboard DU when I want to popup the  PFD in the 777 (I use the HGS in the 737) and I've never had an event after dozens of sessions. I suspect it to be a problem with the Direct3D module that only this one circumstance triggers and neither LM nor PMDG can find it because they don't have access to the Microslop module.


Dan Downs KCRP

Share this post


Link to post
Guest

 

 


Got to ask, has anyone tried v3.2 yet?

 

http://www.prepar3d.com/forum/viewtopic.php?f=6312&t=113995&start=525  Beau Hollis is lead 3D graphic dev with LM and believes the issue is fixed.  I have never been able to replicate this issue even after several dozen attempts with extremely long flight in V3.1 and similar testing in V3.2, so it appears that whatever is in my environment doesn't seem to trigger this issue.

 

My suggestion would be for those that have triggered the issue to "try again" in V3.2.

 

Cheers, Rob.

Share this post


Link to post

I have just had it on 3.2, so as far as i can see the issue is still around, i have only just found out about log viewer, so who knows how many times iv had it.

​But 3 hours into a flight with my Trip 7 i get a CTD...

 

​Tired of this now, i just want to fly... like i did in FS9...

Log Name:      Application
Source:        Application Error
Date:          12/03/2016 17:50:57
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Bertrude
Description:
Faulting application name: Prepar3D.exe, version: 3.2.3.16769, time stamp: 0x56df48ce
Faulting module name: MSVCR120.dll, version: 12.0.21005.1, time stamp: 0x524f7ce6

​LIAM REYNOLDS
 


Liam Reynolds - EGNS
 

sig_smaller.jpg

             Youtube Channel

Share this post


Link to post

Liam, LM has recommended on related posts in their forum that you do a complete uninstall of previous version and install complete P3Dv3.2.  Have you done this?


Dan Downs KCRP

Share this post


Link to post

Yes sir. It is how I've always done this, via add and remove, and then remove all LM P3D apps.

​I have posted on the thread that is running there also.

​Liam Reynolds


Liam Reynolds - EGNS
 

sig_smaller.jpg

             Youtube Channel

Share this post


Link to post

Okay, that is very interesting.  I only updated Client and Contents to v3.2 and could cause the MSVCR120 event so I was wondering if the full install per their recommendation was the solution.  I really didn't want to do that because I have over 60 airport/scenery addons.  It looks like I made the right call and saved myself a lot of time.

 

Liam, there is a ridiculously easy work around: Never use the Left Outboard DU 2D popup.  If you are in the NGX you've got the HGS available and in the B77X you can always use the Right Outboard DU 2D popup, which I do for every takeoff/approach in the B77X and I've never had an event.

 

I am planning a new build in the next few months, maybe, and then we'll see if that finally fixes it for me.  Afterall, a small percentage of users have this problem and it's not been tracked down yet so best solution is the easy workaround.


Dan Downs KCRP

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    31%
    $7,930.00 of $25,000.00 Donate Now
×
×
  • Create New...