Jump to content
Sign in to follow this  
AviatorMoser

A Frame-Time Analysis of P3D v3 -- Effects of CPU Affinity, Frame Lock, and HT

Recommended Posts

I am a little lost reading this post...

 

I normally run P3D along with AS16, and a charts program...not many exe.

 

What is the best AM for my 6700k HT on? And how i can know the best setting for the AS16 bat?


Lucky me using Proces Lasso....
Easy to use for all addons.

 

How do you use the program? Any special setup?


José Fco. Ibáñez /// i7 6700k (Delid) @ 4,6 Ghz /// Asrock Z170 OC Formula /// 16GB RAM G.Skill Ripjaws V 3200 /// GTX 1070 Founders Edition 8GB /// LG 27UD58 4K 27' // OCZ Vertex 4 SSD (X-Plane 10) & SAMSUNG 850 EVO SSD (P3D V3) /// Windows 10 Pro x64

 

sig_FSL-By-Wire.jpg

Share this post


Link to post

 

 

How do you use the program? Any special setup?

 

Simply install and run it. It's pretty self explaining.

Share this post


Link to post

Simply install and run it. It's pretty self explaining

I think specifically the question is asking 'how do I assign specific addons to specific cores or LP's'.

 

Every program needs to be installed and run... with all due respect, not very helpful if you are unfamiliar with the program

  • Upvote 1

Share this post


Link to post

Oh really? ;-)

It is Self explaining. Simple as that.

Click on a thread and assign the cores. Done.

Share this post


Link to post

 

 


Click on a thread and assign the cores. Done.

 

Ok. You win :)

Share this post


Link to post

Thanks Steve

 

Makes complete sense!! Now off to do some testing...

 

Much obliged to you and the folks in this thread, it's been an interesting read

 

Russ

Share this post


Link to post

HI, very good topic, Im still on FSX-SE but with Stevie's DX10 fix. 6800K 1070GTX HT=OFF AM=62 FPS unlimited in fsx and 30 in NI with 1/2 refresh rate. Usepools=0, This gives me the smoothest experience, before that i had fps in fsx set 31 and 30 in NI but it was not that smooth. I use 4x AA an ixer and 4sgss in NI .

 

Question this AM settings looks right to you? I will try p. lasso as well.  

Share this post


Link to post

Thank you so much FreeMeshX Dev! I was close to giving up on P3d as I didnt get any stable fps at all. I had a fresh install of 3.4 and only ASN, REX SC, FTX Global, vectory and Europe LC + ezdok. Even with all settihg low and add ons disabled my frames jumped from 10-50 all the time and I had micro stutters plus my CPU Usage was >95% all the time.

With this settings I have stable fps at 28-30 and CPU at 50-60% and no microstutters.

[MAIN]
FIBER_FRAME_TIME_FRACTION=0.01
[DISPLAY]
TextureMaxLoad=30
TEXTURE_BANDWIDTH_MULT=160
[JOBSCHEDULER]
AffinityMask=85

 


System: i7-2600K, 4x 3.40GHz | ASUS P8P67 Deluxe B3 | 8GB Kingston HyperX T1 DDR3-1600 CL9 | HD 6950 2GB | 750W BeQuiet! Dark Power Pro P9 - 80Plus GOLD | 2x SSD SATA 3

FSX: SP1+Acceleration+REX

Share this post


Link to post

 

Thank you so much FreeMeshX Dev! I was close to giving up on P3d as I didnt get any stable fps at all. I had a fresh install of 3.4 and only ASN, REX SC, FTX Global, vectory and Europe LC + ezdok. Even with all settihg low and add ons disabled my frames jumped from 10-50 all the time and I had micro stutters plus my CPU Usage was >95% all the time.

 

With this settings I have stable fps at 28-30 and CPU at 50-60% and no microstutters.

[MAIN]

FIBER_FRAME_TIME_FRACTION=0.01

[DISPLAY]

TextureMaxLoad=30

TEXTURE_BANDWIDTH_MULT=160

[JOBSCHEDULER]

AffinityMask=85

 

 

That's great and very similar to my setup!


Daniel Moser

 

92logo4.png

Share this post


Link to post

Let me ask generally - If I have a powerfull enough and oc-ed PC and if I don't use external software a lot (I have AS2016 only at the moment), then I don't need to mess with AM settings? Simply saying, the whole point about AF is to run P3D efficiently with external Add-ones. AM itself does not help to improve either VAS usage or P3D stand-alone internal performanc 

Share this post


Link to post

Let me ask generally - If I have a powerfull enough and oc-ed PC and if I don't use external software a lot (I have AS2016 only at the moment), then I don't need to mess with AM settings? Simply saying, the whole point about AF is to run P3D efficiently with external Add-ones. AM itself does not help to improve either VAS usage or P3D stand-alone internal performanc 

 

I'd put it slightly different: If you feel that your sim runs smooth enough with fluid panning and without major stuttering, then there's no need to fiddle around with AM's as you might not see any difference at all (or it gets much worse) ;)

 

Its not just about the addons, setting the correct AM (that works for your individual setup) can also help to spread the internal P3D tasks more evenly over all available LP's rather than just using Core-0 until its at its max capacity. In my case i had to use an external AM setting as this proved to be more effective than the scheduler task setting in prepar3d.cfg

Share this post


Link to post

I believe that AM can affect performance, particularly addressing micro stutters. I have a powerful PC. Or at least I think I do. ;)

 

But that is not a general statement, it worked for me. It might have no effect or even have a negative effect for your system. Only way is to try. Don't do it unless you have an issue you would like to address though.


GregH

System Spec: Core i7 6700K @ 4,7GHz; GTX980Ti, 32GB DDR4 3200; WD Black NVMe; Samsung EVO850 SSD; CH Products Yoke, Pedals & Quad; Airbus Side Stick, TrackIR; 1440p

Share this post


Link to post

I used to run my i7-6700k oc-ed to 4.7 with AM=16 and HT=OFF for almost 1 year, but once I realized that BF1 relies on HT heavily (as well as recent versions of PATC by the way), I had to switch HT back ON. Consequently, I changed AM to 85 and it only made things worse. 116 didn't help either. Apparently, I deleted p3d.cfg file, let it to be rebuilded itself, added nothing except for few VAS management tricks and bang....I have pretty stable sim now even with 4xSGSAA/ AS2016 and PRO-ATC. VAS still a problem in some busy areas, but I guess this is something beyond comprehensive manipulation of settings.

 

So far I'm happy, but the human nature is always calling for constant search of improvements :-)

Share this post


Link to post

if HT is on then use AM, at least to give the primary task a whole core. By default 1st and 2nd task get to share the same physical core.

  • Upvote 1

Share this post


Link to post

As soon as I set an AM, on matter which value, I get blurry textures and slow loading in P3D. (6700K @ 4.5 GHz, HT on)

No matter if I set it in p3d.cfg or on ProcessLasso.

 

No idea why...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...