Jump to content

Sign in to follow this  
NikkiA

v3.0.5778.43151 starting P3D with 3d red/blue anaglyph enabled

Recommended Posts

Starting p3d manually results in the normal 'non-red/blue/purple' view, so it's not a nVidia setting or something in the p3d config, I have no idea how to turn it off other than not using SLX :(

 

Thanks in advance

 

Nikki


"It's too small, IT'S....TOO...SMALL"

Share this post


Link to post
Share on other sites

Hi Nikki,

 

If I understand you correctly, P3D starts in some sort of 3D mode when SLX is used to start P3D? SLX does nothing more than run the prepar3d.exe file with the name of a flight file as a command line parameter. I have no idea how this could result in a 3D mode being activated, but I do believe it is somehow caused by the NVIDA 3D Vision stereo driver being triggered. If I remember well from the past, there's a shortcut key (Ctrl-T I think it was) to turn the 3D mode on and off.

 

As an alternative, you could start P3D manually (either outside of SLX or by going to the Profiles window and then select Tools|Start Prepar3D from the ribbon) and then (after P3D has finished loading and you have the 'green light' at the top right of the window) click on the Fly Now button. This will send the selected flight to P3D by using SimConnect.

 

thanks, Maarten


Maarten Boelens ([m][a:][R][t][ʏ][n])
Developer of SimLauncherX

ftx_supporter_avsim.gifC172Siggy1_zps11944daf.jpg

Share this post


Link to post
Share on other sites

I'm not sure if this is what the poster was talking about but it seems ever since updating SimLauncherX to the latest version I am getting this problem....when I start P3D the view is normal but when I hit the A key to remove the VC Panel from the view I get all sorts of colors on the screen.  When I hit the A key to go back to the regular VC views the clouds look all blocky (for lack of a better term).  I thought this was maybe a driver issue or something however it only happens when I start the sim using SimLauncherX.  If I start the sim normally first it doesn't do this.....I've never seen anything look like this and it's very strange!  As the original poster said I can't find any solution other than not using SimLauncherX which I love to use!  Screenshots linked below....can't figure out how to attach them...

 

Brandon Thetford

 

https://drive.google.com/file/d/0B8PKlIxLCee3RmE5THlwUi1vUVk/view?usp=sharing

 

https://drive.google.com/file/d/0B8PKlIxLCee3NW9EajBVdFRnVms/view?usp=sharing

 

 


Adding a little more information on this...I just tried SimLauncherX launching P3D without touching any options within SLX....the sim loaded fine and did not exhibit any of the behavior from the screen captures.  I tried it again but this time I adjusted the airport, time of day, and that was all.  When I launched P3D it loaded the sim and had the problems I mentioned with the crazy colors and blocky clouds.  Again this is only when I press the A key.  When the sim first loads it appears fine until I change the view.  The only other difference I noticed was the zoom of the cockpit view is set way more zoomed in than the default flight is set when I launch P3D by itself.  Hope this explanation makes sense...

 

Brandon

Share this post


Link to post
Share on other sites

I'm not sure if this is what the poster was talking about but it seems ever since updating SimLauncherX to the latest version I am getting this problem....

 

Yep, seems to be the same problem Brandon is having, just my colours always appear to be a variant of red and blue - looking closer they're not anaglyph since everything is red OR blue, never both...

 

q4BGvcel.png

 

(P3D v2.5 if it matters)

 

edit: Also, whatever is set in the saved scenerio file that is opened that is doing this, is carried over with the green button method too, as launching p3d normally brings up the standard p3d without freaky textures mode, then hitting the green 'play' button loads the scenario and brings in the freaky textures & colours with it.

 

Nikki


"It's too small, IT'S....TOO...SMALL"

Share this post


Link to post
Share on other sites

Hi Brandon, Nikki

 

I will try to reproduce it over the coming days. Can you send me a flight file that is giving you these weird problems? You can find my e-mail address on the front page of the user guide.

Can you tell me if this is happening when you start P3D without SLX running, then start SLX, do not launch a flight from SLX and then press the A key (or any other action that would cause the issue)?

 

EDIT: I would also like to have a look at your dll.xml, exe.xml files (in the %appdata%\Lockheed Marting\Prepar3D v2 folder for P3D 2.5 or in the %programdata%\Lockheed Marting\Prepar3D v3 folder for P3D v3) and the standard.xml file (%appdata%\Lockheed Martin\Prepar3D v2(3)\Controls folder). Are you using EZDock and/or TrackIR?

 

thanks, Maarten


Maarten Boelens ([m][a:][R][t][ʏ][n])
Developer of SimLauncherX

ftx_supporter_avsim.gifC172Siggy1_zps11944daf.jpg

Share this post


Link to post
Share on other sites

Hi Maarten,

 

I just sent you the files you requestd... But while I had p3d and SLX open I tried some other things and noticed some strange behaviour...

 

Fiddling with the 'startup camera' drop down and pressing the 'fly now' button to send the changes to P3d, 'RadarCamera' seems to consistantly give me the same view as the screenshot I posted above (which was set to the default 'Virtual Cockpit'). 'Cockpit' seems to give me a green/yellow texture corruption. 'Weapons' gives me a green/black corruption. and 'Virtual Cockpit' seems to give me either 'whatever it was last set to' or the correct normal behaviour, randomly. 'Static' gives the same green/black as 'Weapons'. Other views all seem to be normal.

 

At least now I have a temporary work around (send my flight to P3d, if it comes up corrupted hit the startup camera choice and manually select 'Virtual Cockpit', even if it's already on that, and spam 'fly now' until I get a non-corrupted view).

 

 

Nikki


"It's too small, IT'S....TOO...SMALL"

Share this post


Link to post
Share on other sites

Hi Maarten,

 

I also sent the files you requested and here is what I found out on my end.  Launching P3D first everything is fine.  I launched SLX and did not send a flight and everything was still fine.  I could hit the A key and not get the corruption.  As soon as I sent anything from SLX via the FlyNow button I got the corruption.  Now...I also saw that if I go into the P3D menu system and then come back out the corruption goes away and the blocky clouds look normal.  However as soon as I hit the A key again to cycle from Virtual Cockpit to Cockpit view it comes back.  Changing views from VC to Spot View or Tower view by hitting the S key does not do any thing abnormal and works fine....

 

So, it seems at least for now that I can use SLX and if I get the corrupted view I can go into the P3D menu and make it go away as long as I don't hit the A key......and during normal flights this is fine with me....however I do use the A key to remove the cockpit instruments and get a full scenery view when I am testing certain things like AI aircraft or doing scenery design so I do need this to work.  In the meantime I will try to do that testing without launching SLX.

 

Seems like this is some sort of problem with cameras but I have no ideas further than that....thanks for taking a look!

 

Brandon

Share this post


Link to post
Share on other sites

Hi Nikki, Brandon

 

Thanks for sending me the requested files. The issue should be solved now in the latest version. I made a mistake when reading the Camera.x.y sections in the flight files. When you saved the flight within SLX these mistakes were saved to disk and FSX/P3D would select the wrong camera view.

 

Maarten


Maarten Boelens ([m][a:][R][t][ʏ][n])
Developer of SimLauncherX

ftx_supporter_avsim.gifC172Siggy1_zps11944daf.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,035.00 of $25,000.00 Donate Now
×
×
  • Create New...