737ngx99

Awful AA in P3D v3

Recommended Posts

Hi

 

I've been struggling with the Anti Aliasing for a very long time in P3D v3. Its very shimmery and the planes looks "liny" and ugly. First i thought it was my 130$ monitor so i bought a QHD 2560x1440p IPS but that didn't solve the problem at all.

 

Have you guys any suggestions on whats the problem? I currently run a GTX 970 with i7 4790k @4.4Ghz.

 

 

Good day

 

Jacob

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi,

 

the usual suggestion is to use Nvidia Inspector and switch Antialiasing to "Enhance the Application Setting"  and "Transparency Supersampling" to 4x "SGSS" (Sparse Grid Supersampling). This should be accompanied by an in-game AA setting of 4x. Just google for details.

 

This inevitably incurs a framerate loss which may or may not be acceptable, but you have a strong system, thus try it.

 

I use the same monitor resolution as you, but a GTX 760 and find AA not that bad, although there is certainly room for improvement. 

 

Kind regards, Michael

 

 

Share this post


Link to post

Michael gave the answer. However, if FPS are an issue (especially in clouds) you could also try 2xSGSS NI and 8 x MSAA ingame.

Share this post


Link to post

Try 8xSS in NI and 8x MSAA in game. Read that on P3D forum

Share this post


Link to post

Here is my setting. Remember to apply this in Nvidia Inspector every time you are updating/installing drivers.

 

nvidiap3d.png

 

P3d%20setting.png

Share this post


Link to post

Thanks guys for the help. I will try these methods and let you know how it works!

 

/Jacob

Share this post


Link to post

Bad news.

 

Can't see any difference between using NI and not. Im starting to wonder if its my GTX 970 thats the problem. 

Share this post


Link to post

I believe the screenshot above is incorrect. You need to set antialiasing mode to "enhance the application setting" and antialiasing transparency supersampling to 4x sparse grid super sampling.

 

In P3D you must set MSAA to match the 4x or 8x you put in NI. So in this case I'd recommend 4x as 8x cripples performance when flying in heavy clouds.

 

There should be a big difference in appearance.

Share this post


Link to post

I believe the screenshot above is incorrect. You need to set antialiasing mode to "enhance the application setting" and antialiasing transparency supersampling to 4x sparse grid super sampling.

 

In P3D you must set MSAA to match the 4x or 8x you put in NI. So in this case I'd recommend 4x as 8x cripples performance when flying in heavy clouds.

 

There should be a big difference in appearance.

 

Per Steves instruction from another post its override application which is what I use - so it appears to be fine as posted above

Share this post


Link to post

SGSS (particularly 8X) is still very hard on performance, particularly in dense clouds. As you have a 970, you have another option which is the ability to enable Dynamic Super Resolution (DSR) through the Nvidia Control panel, which allows for much improved AA with low-no performance impact, even allowing you to run in-sim MSAA as low as 2X. You can also do away with using NVI which is a plus.

 

To enable:

- head into the Nvidia Control Panel and set DSR factors to something like 2X, and set the DSR Smoothness to the default of 33% to start. Click apply. Your desktop resolution should remain as-is; all you've enabled is the ability to select the higher DSR resolution within an application.

- Next, go into the display settings in P3D and select the new DSR resolution from the dropdown - you likely won't notice anything change immediately.

- Then, load up a flight and alt+enter twice to toggle in and out of windowed mode. DSR should now be enabled (the red info text will be much smaller, but the change in AA should also be immediately apparent).

- When you exit P3D, you resolution should switch back to your default.

 

Note: This method is only available on Maxwell and later GPUs.

Share this post


Link to post

Bad news.

 

Can't see any difference between using NI and not. Im starting to wonder if its my GTX 970 thats the problem. 

 

Don't believe you GPU is the problem..

Be sure to use the correct profile and select apply changes and run NI as admin.. Also check your settings in Nvidia control panel

Nvidia%20ctrpnl.png

Share this post


Link to post

I use "Enhance Application Settings" not override.  Also recommend you don't run a different DXGI (like SweetFX/Reshade and/or any product that puts a DXGI in the root of P3D).

 

da09e0257cf85b13394f31fd9ae0ec65.jpg

 

As far as monitors, one step up to 4K will make the AA look great without having to use NI SGSS AA.

 

Cheers, Rob.

  • Upvote 1

Share this post


Link to post

I too use "Enhance the Application Setting" and "4x Sparse Grid Super Sampling". Mind you, it's a moot point these days, since Nvidia Inspector ignores any changes that I try to make :mad:

Share this post


Link to post

Try 8xSS in NI and 8x MSAA in game. Read that on P3D forum

This setting will not eliminate cockpit panel shimmering such as in Carenados Kingair C90B. For that at least 2 x SGSS is required.

Share this post


Link to post

I use "Enhance Application Settings" not override.  Also recommend you don't run a different DXGI (like SweetFX/Reshade and/or any product that puts a DXGI in the root of P3D).

 

Thanks Rob for the post - much appreciated

Share this post


Link to post

I too use "Enhance the Application Setting" and "4x Sparse Grid Super Sampling". Mind you, it's a moot point these days, since Nvidia Inspector ignores any changes that I try to make :mad:

 

Sounds like a user policy/access rights issue, try running NI as Administrator and make sure your account is a true Admin account (Win8 and Win10 don't default to true admin account if your using that OS).

 

Cheers, Rob.

Share this post


Link to post

Thanks for the image Rob. 

Ye i get great results with 4 Sparse Grid,  eliminates probably 90% of the shimmering,  the other 10% (more or less) doesn't bother me enough to use 8 Sparse Grid.  NI is a great program 

Share this post


Link to post

 

Sounds like a user policy/access rights issue, try running NI as Administrator and make sure your account is a true Admin account (Win8 and Win10 don't default to true admin account if your using that OS).

 

I have tried running as Administrator, but it doesn't seem to make any difference. I use Windows 7 Home Premium 64bit. What puzzles me is that it worked perfectly fine not so long ago....on the same PC :huh:

Share this post


Link to post

How about DSR?

I found SGSS in NI is better.

 

Never liked the DSR-related small menu readings and windows (e.g. affects also IVAP from IVAO), which is a serious down-side of DSR. For me a no-go.

Share this post


Link to post

- did you click "apply changes" ? :smile:

 

- try choosing the prepar3d profile in NI and add a new programm to it => choosing your correct path to p3d.exe

 

- try changing the settings in NI to just and ONLY 4*SGSSAA - NOTHING else (no override no apply .. nothing ... vanilla)

Share this post


Link to post

Per Steves instruction from another post its override application which is what I use - so it appears to be fine as posted above

I agree with Richard. Steve is an authority on this subject.

I use "Enhance Application Settings" not override.  Also recommend you don't run a different DXGI (like SweetFX/Reshade and/or any product that puts a DXGI in the root of P3D).

 

da09e0257cf85b13394f31fd9ae0ec65.jpg

 

As far as monitors, one step up to 4K will make the AA look great without having to use NI SGSS AA.

 

Cheers, Rob.

Hi Rob..Just saw your post now. I'm not an expert but just wondering what's the benefits of using "enhance" vs "override"? I haven't done any tests yet but i normally set up my simulator according to your settings but I see Steve uses a different approach....

Share this post


Link to post

Remember, guys. The FSX engine uses voodoo magic. It does not work the same on everyone's PC :wink:

  • Upvote 1

Share this post


Link to post

I have tried running as Administrator, but it doesn't seem to make any difference. I use Windows 7 Home Premium 64bit. What puzzles me is that it worked perfectly fine not so long ago....on the same PC :huh:

Copied from another post of mine: I had exactly the same problem with my GTX 970 and found a fairly straightforward solution online. The first part of the fix is to get rid of GeForce Experience if you've got it installed. It would appear that it creates more problems than it solves. The second part was to download the Display Driver Uninstaller (http://www.guru3d.com/files-details/display-driver-uninstaller-download.html) which completely uninstalls your graphics driver - the Windows uninstaller can apparently leave a surprising number of driver related files which can affect the NVIDIA Control panel. Next, reinstall the drivers from NVIDIA, avoiding GeForce Experience, and restart your system. This worked for me after weeks of head scratching.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now