Sign in to follow this  
Charlie Kilo

DLL.XML

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

Hi,

RAAS Pro latest version install not writing to my P3D3.1 dll.xml. Any ideas why not? Thanks.

 

 

Please see the Trouble Shooting section regarding this.

 

Possible culprits:  Anti virus Interferences, not running with Admin rights causing write permission issues:

 

http://www.support.fs2crew.com/help/manuals/#pageid=help_and_trouble_shooting

 

 

You could try adding the entry to the DLL.xml manually.

Share this post


Link to post
Share on other sites

Hi,

 

There is no antivirus on that PC and I installed with admin rights. I did eventually add the entry manually.

 

Is it because my P3D install is on a separate hard drive (d:) to my program data folder (c:)?

 

Also, whilst we are here, I'm not getting any audio. The module is installed and RAAS appears in the P3D menu, makerunways has been run, but no sounds on the runway and no sound testing the audio either. Any ideas?

 

Charlie

Share this post


Link to post
Share on other sites

The separate drive shouldn't make a difference.

 

Something blocked our program from writing to your DLL.xml.

 

As for audio:  Are your speakers set to Stereo in the Windows Control Panel Speakers page?  Make sure they're set to Stereo and not Dolby 7.1

Share this post


Link to post
Share on other sites

Hi, any chance you could enable RAAS to work in all speaker setups? I have a 5.1 system and I use my sound driver to fill the 5.1 speakers with the stereo sound.

Share this post


Link to post
Share on other sites

On the 

 

 

 

Also, whilst we are here, I'm not getting any audio. The module is installed and RAAS appears in the P3D menu, makerunways has been run, but no sounds on the runway and no sound testing the audio either. Any ideas?

 

Charlie

 

On the RAAS panel, in the bottom section, make sure an audio device is selected.

 

You may have no audio device selected... therefore, no sound.


Hi, any chance you could enable RAAS to work in all speaker setups? I have a 5.1 system and I use my sound driver to fill the 5.1 speakers with the stereo sound.

 

In the Windows Control panel, is your speaker setup set to "Stereo"?

Share this post


Link to post
Share on other sites

Yes, set to stereo and all works. But I am only getting sound through 2 of my 5 speakers in P3D now. When my speaker setup is 5.1 I can use a setting to fill all 5.1 speakers with the stereo sound. Is it possible you can make RAAS work with 5.1 systems in the next update?

Share this post


Link to post
Share on other sites

Hi Bryan,

 

Is RAAS Pro your product?

 

I posted a similar issue (I think a few years ago) ... it doesn't seem valid to expect end users to switch from their 5.1 or 7.1 surround sound setups to Stereo only?  Such a change in audio configuration would prevent the surround environment from working ... such environments are emulated VERY well in many other 3rd party products (Majestic Q400, PMDG, etc.).  

 

I'm not trying to task anyone here ... but is the DirectSound API (mostly unchanged for DX8 days) not an option?

 

Cheers, Rob.

Share this post


Link to post
Share on other sites

Hi Rob,

 

We're using the Microsoft XACT audio engine.

 

I'm not sure if CRW78's issue is associated with P3D or not.

 

We'll see what he says.

Share this post


Link to post
Share on other sites

Hi guys,

 

I came straight from FS9 to P3D so not sure about FSX. In FS9 the sound came through 5 of 5 speakers because my sound settings allowed that to happen. The problem as I see it is follows:

 

I believe FS9, FSX and P3D only output stereo audio, but most audio card drivers (and maybe even the default windows ones) allow you to select a 5.1 or 7.1 (or anything better than stereo) system and have a checkbox option so that when you are listening to a stereo audio source it will upmix it accordingly and output it to the 'superior' speaker system that you have selected. In my case, I use the Prosim aircraft model in P3D which outputs in stereo, but that stereo sound comes out of all 5.1 of my speakers because I have the upmix option selected in my Asus Sound Studio settings. If RAAS requires the speakers to be set to stereo only for it to work, then this is at the expense of all other audio generated by my PC, and only 2 of my 5 speakers work.

 

CK

Share this post


Link to post
Share on other sites

The thing is the FS2Crew sound system is, as far as I know, independent of FS.

 

So your results in FS9 should be the same as FSX or P3D.

 

Which speakers do the RAAS sounds come out of on your 5.1 system?

 

Also, not sure if this would apply, but you know you can select the audio device used by RAAS at the bottom of the RAAS page.

 

Perhaps you have more than one audio device that could be used.

Share this post


Link to post
Share on other sites

Front Left and Front Right, these are the only ones that any sound comes out of because you told me in post #4 to set my speakers to stereo!

Share this post


Link to post
Share on other sites

When your speakers are set to 5.1, which speakers exactly do the sounds come out of?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this