Jump to content

Sign in to follow this  
RoyEP3

Shadow Flickers?

Recommended Posts

Can you guys tell me why I have flickering shadows?  I am running Prepar3d v3.1 with a 980Ti latest drivers.  Nothing has been modified in the Prepar3d.cfg.  

 

It seems that the shadows have pretty bad flicker unless zoomed in at 0.50 and beyond.  I've already tried reinstalling Prepar3d and Nvidia drivers.  I've lowered the graphic settings in Prepar3d as well and the flickers still persist, just at a lower quality.  Is this just a V3.1 issue?  Graphic settings are at the end of the video.

 

(flickering is worst at the beginning of the video)

Share this post


Link to post

I get shadow flickering on pretty much anything but scenery and internal aircraft shadows, so I turn them off. Nvidia 780. Been like that for a while though.

Share this post


Link to post

That's really unfortunate.  We take the time to build an expensive flight sim rig for high end graphics, only to have to turn off shadows.  Anyone else with success on fixing this shadow issue?

Share this post


Link to post

There´s no fix, It´s the way they are. 

Prepar3d forums have some complains about this issue. 

Share this post


Link to post
Guest

I think that mostly has to do with ground shadow resolution. But the flicker in that water tower shadow looks more like z-fighting.

 

this is the line in the prepar3d.cfg for ground shadow texture resolution:

GROUND_SHADOW_TEXTURE_SIZE=512

 

Mine is set to 512 because if you increase it its hard on performance.

 

Having said that I have on occasion increased it as high as 8192

with great results. However, you better already be flying over scenery

that isn't hungry in a lite aircraft :-)

Share this post


Link to post
Guest

 

 


But the flicker in that water tower shadow looks more like z-fighting.

 

Try 1m mesh, that seemed to cure that issue for me.

 

Cheers, Rob.

Share this post


Link to post

So if you use the correct zoom in the VC, there's no flickering?  Or is there a reason to no longer use the wideview setting and zoom at 1.00?  I'd have thought you'd be getting some serious zoomed out tunnel vision going on with a zoom as low as 0.4 (or for that matter 0.5,.0.6, 0.7)


Cheers

 

Paul Golding

Share this post


Link to post
Guest

I have it every now and then at mountain and hill slopes in the distance. Quite annoying. I don't seem to have it all then time but perhaps that is due to the time of day (If a hill has no shadows they obviously won't flicker). I have this since 3.0.

 

I btw use the wide view aspect and a zoom of 0.7.

Share this post


Link to post

I use this:

 

SHADOW_NUM_CASCADES_LOW=4

SHADOW_NUM_CASCADES_MID=4

SHADOW_NUM_CASCADES_HIGH=4

SHADOW_NUM_CASCADES_ULTRA=4

GROUND_SHADOW_TEXTURE_SIZE=4096

 

A typical scenario I get 55fps average - good shadows.

Tested a lot of scenarios, examples:

 

SHADOW_NUM_CASCADES_ULTRA=6

GROUND_SHADOW_TEXTURE_SIZE=4096

Same scenario I get 47fps average - best shadows in group - 1 second dip in trace during startup

 

SHADOW_NUM_CASCADES_ULTRA=6

GROUND_SHADOW_TEXTURE_SIZE=2048

Same scenario I get 51fps average - poorest shadows

 

SHADOW_NUM_CASCADES_ULTRA=12

GROUND_SHADOW_TEXTURE_SIZE=2048

Same scenario I get 33fps average - average shadows


Steve Waite: Engineer at codelegend.com

Share this post


Link to post
Guest

I use this:

 

SHADOW_NUM_CASCADES_LOW=4

SHADOW_NUM_CASCADES_MID=4

SHADOW_NUM_CASCADES_HIGH=4

SHADOW_NUM_CASCADES_ULTRA=4

GROUND_SHADOW_TEXTURE_SIZE=4096

 

A typical scenario I get 55fps average - good shadows.

Tested a lot of scenarios, examples:

 

SHADOW_NUM_CASCADES_ULTRA=6

GROUND_SHADOW_TEXTURE_SIZE=4096

Same scenario I get 47fps average - best shadows in group - 1 second dip in trace during startup

 

SHADOW_NUM_CASCADES_ULTRA=6

GROUND_SHADOW_TEXTURE_SIZE=2048

Same scenario I get 51fps average - poorest shadows

 

SHADOW_NUM_CASCADES_ULTRA=12

GROUND_SHADOW_TEXTURE_SIZE=2048

Same scenario I get 33fps average - average shadows

 

Interesting. So you sort of divided the in game shadow quality setting into two settings: you now use the 'in game' LOW setting for CASCADE setting but the 'in game' HIGH (or ULTRA) setting for TEXTURE SIZE. Nice. So even with P3D the cfg stays an interesting file... :wink:

Share this post


Link to post
Guest

Steve,

 

What are your FPS like during sunsets or dawn when your aircraft is within a shadow cast (i.e. your aircraft is behind a building shadow)?  I haven't tested this scenario in V3 yet, but in V2.x I saw close to 60% FPS drop with anything >2048.

 

Cheers, Rob.

Share this post


Link to post

That test scenario was extreme with heavy settings to produce lots of shadows. A more responsible setup produce 70+fps normally on that PC. Was late evening all in low flight for good shadows viewing. I find keeping the cascade count below 7 is key to good memory and fps. I'll check out some more extreme setups.


Steve Waite: Engineer at codelegend.com

Share this post


Link to post
On 13/01/2016 at 2:22 AM, SteveW said:

I use this:

 

SHADOW_NUM_CASCADES_LOW=4

SHADOW_NUM_CASCADES_MID=4

SHADOW_NUM_CASCADES_HIGH=4

SHADOW_NUM_CASCADES_ULTRA=4

GROUND_SHADOW_TEXTURE_SIZE=4096

 

A typical scenario I get 55fps average - good shadows.

Tested a lot of scenarios, examples:

 

SHADOW_NUM_CASCADES_ULTRA=6

GROUND_SHADOW_TEXTURE_SIZE=4096

Same scenario I get 47fps average - best shadows in group - 1 second dip in trace during startup

 

SHADOW_NUM_CASCADES_ULTRA=6

GROUND_SHADOW_TEXTURE_SIZE=2048

Same scenario I get 51fps average - poorest shadows

 

SHADOW_NUM_CASCADES_ULTRA=12

GROUND_SHADOW_TEXTURE_SIZE=2048

Same scenario I get 33fps average - average shadows

 

Sorry to revive this old monster, but this issue is still prevelant in v4 as well. I have tried the suggestions Steve has made, and v4 already has higher settings by default, but nothing I do seems to get rid of the horrible flickering effect..


Intel Core i7-6700k CPU Overclocked to 4.50GHz - 16GB RAM, Nvidia Geforce GTX980ti 6GB, Windows 10 Home 64-bit

Share this post


Link to post

I still get flickiering clouds as well... not sure how to fix it. Looks bad.


Aaron Vinci

----------------

Intel i9 10900K (no overclock) / Windows 10 Pro 2004 64 bit / 64GB DDR4 3200MHz CL 16RAM / EVGA NVIDIA GTX 1080 FTW 8GB RAM / 1TB NVME SSD (OS Drive) / 2TB SATA SSD / 4TB SATA HDD / 850watt PSU

Share this post


Link to post

Clouds seem to be fine for me. It's mainly the vegetation casting. And sometimes the building casting. These two always have really bad flickering. I've tried all of SteveW's suggestions and tried different resolutions, nothing seems to work! :(


Intel Core i7-6700k CPU Overclocked to 4.50GHz - 16GB RAM, Nvidia Geforce GTX980ti 6GB, Windows 10 Home 64-bit

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,080.00 of $25,000.00 Donate Now
×
×
  • Create New...