Jump to content

Sign in to follow this  
bradrcfii

Prepar3d and SimConnect

Recommended Posts

Microsoft Windows [Version 6.1.7601]

Copyright © 2009 Microsoft Corporation.  All rights reserved.
 
C:\Users\Brad>netstat -an
 
Active Connections
 
  Proto  Local Address          Foreign Address        State
  TCP    0.0.0.0:80             0.0.0.0:0              LISTENING
  TCP    0.0.0.0:135            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:445            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:2869           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:5357           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:47984          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:47989          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49152          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49153          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49154          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49155          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49158          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49165          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49185          0.0.0.0:0              LISTENING
  TCP    10.0.0.30:139          0.0.0.0:0              LISTENING
  TCP    10.0.0.30:49225        23.48.107.31:80        TIME_WAIT
  TCP    10.0.0.30:49226        23.48.107.32:80        TIME_WAIT
  TCP    10.0.0.30:49227        23.48.107.31:80        TIME_WAIT
  TCP    10.0.0.30:49228        23.48.107.32:80        TIME_WAIT
  TCP    10.0.0.30:49229        23.48.107.31:80        TIME_WAIT
  TCP    10.0.0.30:49230        23.48.107.31:80        TIME_WAIT
  TCP    10.0.0.30:49231        23.48.107.32:80        TIME_WAIT
  TCP    10.0.0.30:49232        96.17.164.144:80       TIME_WAIT
  TCP    10.0.0.30:49233        96.17.164.144:80       TIME_WAIT
  TCP    10.0.0.30:49234        96.17.164.144:80       TIME_WAIT
  TCP    10.0.0.30:49235        216.206.30.43:80       TIME_WAIT
  TCP    127.0.0.1:7789         0.0.0.0:0              LISTENING
  TCP    127.0.0.1:7789         127.0.0.1:49168        ESTABLISHED
  TCP    127.0.0.1:7789         127.0.0.1:49172        ESTABLISHED
  TCP    127.0.0.1:7789         127.0.0.1:49173        ESTABLISHED
  TCP    127.0.0.1:7789         127.0.0.1:49174        ESTABLISHED
  TCP    127.0.0.1:7789         127.0.0.1:49175        ESTABLISHED
  TCP    127.0.0.1:7789         127.0.0.1:49176        ESTABLISHED
  TCP    127.0.0.1:7789         127.0.0.1:49177        ESTABLISHED
  TCP    127.0.0.1:7789         127.0.0.1:49178        ESTABLISHED
  TCP    127.0.0.1:7789         127.0.0.1:49179        ESTABLISHED
  TCP    127.0.0.1:9990         0.0.0.0:0              LISTENING
  TCP    127.0.0.1:23401        0.0.0.0:0              LISTENING
  TCP    127.0.0.1:49168        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49172        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49173        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49174        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49175        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49176        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49177        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49178        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49179        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49181        127.0.0.1:65001        ESTABLISHED
  TCP    127.0.0.1:65000        0.0.0.0:0              LISTENING
  TCP    127.0.0.1:65001        0.0.0.0:0              LISTENING
  TCP    127.0.0.1:65001        127.0.0.1:49181        ESTABLISHED
  TCP    [::]:80                [::]:0                 LISTENING
  TCP    [::]:135               [::]:0                 LISTENING
  TCP    [::]:445               [::]:0                 LISTENING
  TCP    [::]:2869              [::]:0                 LISTENING
  TCP    [::]:5357              [::]:0                 LISTENING
  TCP    [::]:49152             [::]:0                 LISTENING
  TCP    [::]:49153             [::]:0                 LISTENING
  TCP    [::]:49154             [::]:0                 LISTENING
  TCP    [::]:49155             [::]:0                 LISTENING
  TCP    [::]:49158             [::]:0                 LISTENING
  TCP    [::]:49165             [::]:0                 LISTENING
  TCP    [::]:49185             [::]:0                 LISTENING
  TCP    [fe80::6c6c:aebf:ca03:a406%17]:445  [fe80::9503:fed9:67a8:a1c0%17]:5245
8  ESTABLISHED
  UDP    0.0.0.0:500            *:*
  UDP    0.0.0.0:3702           *:*
  UDP    0.0.0.0:3702           *:*
  UDP    0.0.0.0:3702           *:*
  UDP    0.0.0.0:3702           *:*
  UDP    0.0.0.0:4500           *:*
  UDP    0.0.0.0:5355           *:*
  UDP    0.0.0.0:50979          *:*
  UDP    0.0.0.0:56426          *:*
  UDP    0.0.0.0:58890          *:*
  UDP    0.0.0.0:58892          *:*
  UDP    0.0.0.0:62253          *:*
  UDP    10.0.0.30:137          *:*
  UDP    10.0.0.30:138          *:*
  UDP    10.0.0.30:1900         *:*
  UDP    10.0.0.30:5353         *:*
  UDP    10.0.0.30:63903        *:*
  UDP    127.0.0.1:1900         *:*
  UDP    127.0.0.1:44301        *:*
  UDP    127.0.0.1:48200        *:*
  UDP    127.0.0.1:48201        *:*
  UDP    127.0.0.1:48202        *:*
  UDP    127.0.0.1:50978        *:*
  UDP    127.0.0.1:56427        *:*
  UDP    127.0.0.1:56428        *:*
  UDP    127.0.0.1:56429        *:*
  UDP    127.0.0.1:56430        *:*
  UDP    127.0.0.1:56431        *:*
  UDP    127.0.0.1:59774        *:*
  UDP    127.0.0.1:63904        *:*
  UDP    127.0.0.1:63937        *:*
  UDP    127.0.0.1:65000        *:*
  UDP    [::]:500               *:*
  UDP    [::]:3702              *:*
  UDP    [::]:3702              *:*
  UDP    [::]:3702              *:*
  UDP    [::]:3702              *:*
  UDP    [::]:4500              *:*
  UDP    [::]:5355              *:*
  UDP    [::]:50980             *:*
  UDP    [::]:58891             *:*
  UDP    [::]:58893             *:*
  UDP    [::1]:1900             *:*
  UDP    [::1]:5353             *:*
  UDP    [::1]:63902            *:*
  UDP    [fe80::6c6c:aebf:ca03:a406%17]:1900  *:*
  UDP    [fe80::6c6c:aebf:ca03:a406%17]:63901  *:*
 
C:\Users\Brad>

Brad Rich
 

Share this post


Link to post

did you change the port specified in your simconnect.xml? (port 5000)

or was sim off?

i think you need to disable IPv6 in network settings as a start!

 

not sure which OS you’re on, do yourself a favor and manually disable firewall service! (and reboot)

more than once i had firewall service disabled from the firewall settings panel; the service was still blocking traffic!

manually setting it to disabled and rebooting always shuts it off completely,

Share this post


Link to post

The sim was off and I am running Windows 7.  I disabled IPv6 on both machines and in my router.  I am not sure what you mean to do by "manually disable" firewall service.  I did close the windows firewall service in the task manager.  I made sure the firewall is turned off in the control panel as well.

 

I just realized that i am not getting debug data.  I have the simconnect.ini file with the console set to =1 yet I am receiving nothing.  

 

I changed the port to 500 in both files since that is what I used running FSX.

 

NSTAT with the sim running. 10.0.0.20 is the client machine.

 

Microsoft Windows [Version 6.1.7601]

Copyright © 2009 Microsoft Corporation.  All rights reserved.
 
C:\Users\Brad>netstat -an
 
Active Connections
 
  Proto  Local Address          Foreign Address        State
  TCP    0.0.0.0:80             0.0.0.0:0              LISTENING
  TCP    0.0.0.0:135            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:445            0.0.0.0:0              LISTENING
  TCP    0.0.0.0:2869           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:5357           0.0.0.0:0              LISTENING
  TCP    0.0.0.0:47984          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:47989          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49152          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49153          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49154          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49155          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49158          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49167          0.0.0.0:0              LISTENING
  TCP    0.0.0.0:49185          0.0.0.0:0              LISTENING
  TCP    10.0.0.30:139          0.0.0.0:0              LISTENING
  TCP    10.0.0.30:445          10.0.0.20:49155        ESTABLISHED
  TCP    10.0.0.30:49155        10.0.0.20:49158        ESTABLISHED
  TCP    10.0.0.30:49243        66.150.99.92:80        TIME_WAIT
  TCP    127.0.0.1:7789         0.0.0.0:0              LISTENING
  TCP    127.0.0.1:7789         127.0.0.1:49168        ESTABLISHED
  TCP    127.0.0.1:7789         127.0.0.1:49169        ESTABLISHED
  TCP    127.0.0.1:7789         127.0.0.1:49173        ESTABLISHED
  TCP    127.0.0.1:7789         127.0.0.1:49174        ESTABLISHED
  TCP    127.0.0.1:7789         127.0.0.1:49175        ESTABLISHED
  TCP    127.0.0.1:7789         127.0.0.1:49176        ESTABLISHED
  TCP    127.0.0.1:7789         127.0.0.1:49177        ESTABLISHED
  TCP    127.0.0.1:7789         127.0.0.1:49178        ESTABLISHED
  TCP    127.0.0.1:7789         127.0.0.1:49179        ESTABLISHED
  TCP    127.0.0.1:9990         0.0.0.0:0              LISTENING
  TCP    127.0.0.1:23401        0.0.0.0:0              LISTENING
  TCP    127.0.0.1:49168        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49169        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49173        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49174        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49175        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49176        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49177        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49178        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49179        127.0.0.1:7789         ESTABLISHED
  TCP    127.0.0.1:49181        127.0.0.1:65001        ESTABLISHED
  TCP    127.0.0.1:65000        0.0.0.0:0              LISTENING
  TCP    127.0.0.1:65001        0.0.0.0:0              LISTENING
  TCP    127.0.0.1:65001        127.0.0.1:49181        ESTABLISHED
  TCP    [::]:80                [::]:0                 LISTENING
  TCP    [::]:135               [::]:0                 LISTENING
  TCP    [::]:445               [::]:0                 LISTENING
  TCP    [::]:2869              [::]:0                 LISTENING
  TCP    [::]:5357              [::]:0                 LISTENING
  TCP    [::]:49152             [::]:0                 LISTENING
  TCP    [::]:49153             [::]:0                 LISTENING
  TCP    [::]:49154             [::]:0                 LISTENING
  TCP    [::]:49155             [::]:0                 LISTENING
  TCP    [::]:49158             [::]:0                 LISTENING
  TCP    [::]:49167             [::]:0                 LISTENING
  TCP    [::]:49185             [::]:0                 LISTENING
  UDP    0.0.0.0:500            *:*
  UDP    0.0.0.0:3702           *:*
  UDP    0.0.0.0:3702           *:*
  UDP    0.0.0.0:3702           *:*
  UDP    0.0.0.0:3702           *:*
  UDP    0.0.0.0:4500           *:*
  UDP    0.0.0.0:5355           *:*
  UDP    0.0.0.0:61600          *:*
  UDP    0.0.0.0:63773          *:*
  UDP    0.0.0.0:63775          *:*
  UDP    0.0.0.0:63777          *:*
  UDP    0.0.0.0:63845          *:*
  UDP    0.0.0.0:63853          *:*
  UDP    10.0.0.30:137          *:*
  UDP    10.0.0.30:138          *:*
  UDP    10.0.0.30:1900         *:*
  UDP    10.0.0.30:5353         *:*
  UDP    10.0.0.30:50002        *:*
  UDP    127.0.0.1:1900         *:*
  UDP    127.0.0.1:44301        *:*
  UDP    127.0.0.1:48200        *:*
  UDP    127.0.0.1:48201        *:*
  UDP    127.0.0.1:48202        *:*
  UDP    127.0.0.1:50003        *:*
  UDP    127.0.0.1:52454        *:*
  UDP    127.0.0.1:56832        *:*
  UDP    127.0.0.1:56833        *:*
  UDP    127.0.0.1:56834        *:*
  UDP    127.0.0.1:60674        *:*
  UDP    127.0.0.1:63846        *:*
  UDP    127.0.0.1:63847        *:*
  UDP    127.0.0.1:63852        *:*
  UDP    127.0.0.1:65000        *:*
  UDP    [::]:500               *:*
  UDP    [::]:3702              *:*
  UDP    [::]:3702              *:*
  UDP    [::]:3702              *:*
  UDP    [::]:3702              *:*
  UDP    [::]:4500              *:*
  UDP    [::]:63774             *:*
  UDP    [::]:63776             *:*
  UDP    [::]:63778             *:*
  UDP    [::]:63854             *:*
  UDP    [::1]:1900             *:*
  UDP    [::1]:5353             *:*
  UDP    [::1]:50001            *:*
 
C:\Users\Brad>

Brad Rich
 

Share this post


Link to post

Thank you Brad,

yes win7 will do a this firewall bug i mentioned before; that's where i first run into it,

(seemingly all controls are set to OFF; but it’s not actually honoring the settings applied)

the easy way to fix this is to open an admin command prompt; run this commend and reboot after;

REG add "HKLM\SYSTEM\CurrentControlSet\services\MpsSvc" /v Start /t REG_DWORD /d 4 /f
(be sure to run this on both your client and server pc's than reboot after)

this will set your firewall service to disabled state after you reboot and will actually be turned off properly,

just don’t get confused when windows complains your security is compromised and offers to fix it for you;

it will simply turn your firewall back on!

 

check your netstat for port 500 established connection after reboot (TCP 10.0.0.30:500 ESTABLISHED),

if you see it you’re good to go; if not report back please,

 

currently I’m not seeing any communications on port 500 in any form;

if this is your client side you should see establish connection to 10.0.0.30 on port 500 (+/- 1 or 2 oprts up or down);

that should be visible in the netstat output,

 

a closer examination shows you are talking to 10.0.0.30 over the wrong port possibly

  TCP    10.0.0.30:445          10.0.0.20:49155        ESTABLISHED
  TCP    10.0.0.30:49155        10.0.0.20:49158        ESTABLISHED
can you please post both your current simconnect.xml (client and server side)

 

 

@SteveW

2. Install all three FSX simconnect versions:

C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\redist\Interface\FSX-RTM\retail\lib\SimConnect.msi

C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\redist\Interface\FSX-SP1\retail\lib\SimConnect.msi

C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\redist\Interface\FSX-SP2-XPACK\retail\lib\SimConnect.msi

there are actually 4 dll's he need to install,

C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\redist\Interface\ESPv1\retail\lib\SimConnect.msi

Share this post


Link to post

1) I made the registry change using command and rebooted both machines

2) I installed the ESPv1 MSI file.  (does the order of the MSI files make a difference)

3) I reinstalled FSUIPC-WideFS now connects

4) I moved the ini file to the correct location and logging now displays.  Task Manager shows this program as "SimConnect data logging" a good sign.

 

Is there any port forwarding involved?

 

The following link is a dropbox location showing you the files and their locations.  The nstat data does not seem to show port 500 defined in the xlm and cfg files.

 

https://www.dropbox.com/sh/fimci6peppmdk6l/AACOL0KncbWkIg2q16F4VBZKa?dl=0

 

Concerning Vpilot, I run the traffic proxy program on the server that connects and try to run Vpilot on the client that does not connect to the simulator.  About ready to try FSINN.

 

Thanks for your help thus far.  I really appreciate it.

 

Brad


Brad Rich
 

Share this post


Link to post

i never run this application myself;

i believe this is how they should be set for the two to talk to each other

 

Simconnect.XML on Brad (in C:\Users\Brad\AppData\Roaming\Lockheed Martin\Prepar3D v3\Simconnect.XML)

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <Address>10.0.0.30</Address>
    <MaxClients>64</MaxClients>
    <Port>12345</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>local</Scope>
    <Address>127.0.0.1</Address>
    <MaxClients>64</MaxClients>
    <Port>12345</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
</SimBase.Document>
Simconnect.cfg on Flight2 (in C:\Users\Flight2\Documents\Simconnect.cfg)

[SimConnect]
Protocol=IPv4
Address=10.0.0.30
Port=12345
MaxRecvSize=4096
DisableNagle=0
if you want to see debug window to confirm its working right;

put this inside a new simconnect.xml (in C:\Users\Brad\Documents\Prepar3D v3 Files\Simconnect.XML)

[SimConnect]
level=verbose
console=1
;RedirectStdOutToConsole=1
;OutputDebugString=1
;file=c:\simconnect%03u.log
;file_next_index=1
;file_max_index=99

Share this post


Link to post

The xml file on the server always had it's own IP address, in this case, 10.0.0.30.  I have never ran an xml file on the client.  Would not know where to put it.  How did you come to these conclusions?

 


Brad Rich
 

Share this post


Link to post

i am unsure how you have your network setup;
I gathered some information from your files and draw my conclusion;
assuming Brad is your main Sim PC (10.0.0.30); and Flight2 is your secondary application PC,

did you try these settings?
i suppose you need to place a simconnect.cfg in you application main directory on Flight2; and have it up and running,
you may need to read the manual for this application and figure out where you need to put simconnect.cfg there,

you probably weren’t aware before that you had simconnect running on both sides,
otherwise the application can’t talk with a remote pc if one isn’t in standby or listening for connection,
it doesn’t matter that your client application is knocking on the other sides door if no one isnt listening; and that is simconnect!

i think we jumped ahead bit forgetting the very basic,
can you post your output from -> ipconfig /all
from both your machines please
it’s best if you refer to them as Sim PC and remote application PC,

Share this post


Link to post

@SteveW

 

there are actually 4 dll's he need to install,

C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\redist\Interface\ESPv1\retail\lib\SimConnect.msi

P3D installs the esp simconnect on the server PC, but the point is you need to install that version on a remote client with the three legacy simconnects.


Steve Waite: Engineer at codelegend.com

Share this post


Link to post

the settings i posted above should work perfect for you;

follow the instructions and report back please,

Share this post


Link to post

P3D installs the esp simconnect on the server PC, but the point is you need to install that version on a remote client with the three legacy simconnects.

Does the order of the simsonnect installs matter. Some we updates.


Brad Rich
 

Share this post


Link to post

No, just put them on.


Steve Waite: Engineer at codelegend.com

Share this post


Link to post

Hi Chris,

 

I loaded your xml file.  I changed one parameter from local to "global" and used port 5000.  I do not know what IP address 127.0.0.1 is showing on nstat?  I have my router only to use ip address starting at 10.0.0.1 to 100.  10.0.0.30 is my sim server and 10.0.0.20 is my client.  I noticed that nstat does not show port 5000.  The other strange item is the FSX program showing in my uninstall list from the control panel.  If I try to uninstall it, I get an error.  I think it was placed there by one of the simconnect.msi installation programs.

 

The following dropbox location shows examples of all my files and sestet for both computers.

 

https://www.dropbox.com/sh/1cuqnur0eqqkqze/AACd4dkTbiOW-uVFZAHFkJoza?dl=0

 

Brad


Brad Rich
 

Share this post


Link to post

Hi Brad,

127.0.0.1 is default IP used by all systems/devices as a local and internal IP ONLY!

you cannot route anything to 127.0.0.1 or call 127.0.0.1 directly from a none local public IP;

but you can talk to the local valid public local IP 10.0.0.30 and that IP can contact local 127.0.0.1 if needed,

so far for general knowledge,

 

you shouldn’t have changed 127.0.0.1 local to global; use the code as i posted and only change the port!

on Simconnect.cfg Flight2 (in C:\Users\Flight2\Documents\Simconnect.cfg); did you atch the port as well?

 

Simconnect.XML on Brad (in C:\Users\Brad\AppData\Roaming\Lockheed Martin\Prepar3D v3\Simconnect.XML)

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <Address>10.0.0.30</Address>
    <MaxClients>64</MaxClients>
    <Port>5000</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>local</Scope>
    <Address>127.0.0.1</Address>
    <MaxClients>64</MaxClients>
    <Port>5000</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
</SimBase.Document>
Simconnect.cfg on Flight2 (in C:\Users\Flight2\Documents\Simconnect.cfg)

[SimConnect]
Protocol=IPv4
Address=10.0.0.30
Port=5000
MaxRecvSize=4096
DisableNagle=0

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,170.00 of $25,000.00 Donate Now
×
×
  • Create New...