Sign in to follow this  
camtah

PB not working on networked PC anymore...

Recommended Posts

Hello all. Sorry I don't have any cliff notes for you to read :-)

 

Background: My current FSX setup involves 2 PCs. PC1 is FSX running Win 8.1. PC2 is running Panel Builder, Saitek modules, etc. It is running Win 7 Home 64b. I use FSUIPC-4 and WideFS on PC2. I also use SPAD drivers for all the Saitek devices I use and they are based off PC2. The Yoke, throttles and pedals are all on the main FSX PC. I currently have PB 2.95 loaded and I use the PB-FSUIP driver on the FSX PC .I might add that the FSX computer and 2nd PC are dedicated to FSX.  I do not use Internet connection sharing between them as PC2 has no reason to reach the outside world at this time.

 

Up until a few weeks ago, these systems were part of my home network, all the same subnet 192.168.17.0 ( I work with networks in the real world) via Ethernet and Cat 6. I haven't had much time to enjoy the system in that past few weeks, but I am sure it was working fine when I last messed around.

 

The Issue started when I had to re-arrange my office/play room. I  This meant that I had to use the built in wireless adapter (5G and router is 6' away.) to connect to the home network on the existing subnet and I created an private subnet, 192,168.27.0 for both PC, and directly connected them via their respective Ethernet interfaces and a x-over cable.

 

Problem: The PB gauges on PC2 no longer respond at all.

 

I can ping between the 2 devices, I can start WideFS and I see a connection on PC via WideFS when FSX starts up. The Saitek modules via the SPAD drivers all work thru FSX. Therefore I concluded  that the network is up and running fine.

 

I suspect that the issue revolves around the multicast protocol between 8.1 and the Win7.  I have tried a lot of different combinations, such as shutting down the wireless adapter, added the reliable multicast protocol to each interface. On  PC1, I made sure the Ethernet was listed first under the advanced settings, etc. I downloaded the checker program from PB and I get no data coming over at all on PC2

 

I did install the PB gauges on the FSX PC using the the simconnect driver and they work in this case. I was able to throw the battery switch on the Saitek multipanel and watch the PB  fuel gauges spring to life.

 

I only have 2 IP addresses: 192.168.27.1 for the FSX, 192.168.27.2 for the networked pc. I had to set a default gateway on  PC2 pointing to the FSX PC1 Interface.  No default gateway is set on this interface. The multicast route is correct on both PC. The firewalls for both PC on this private network is turned off. I did check the box to add the devices to the firewall anyway. I even backed down to version 2.92 to see if that might have an issue.

 

The only thing I can think of is that PC1 gets all the updates and PC2 I don't (it is isolated from the internet and there are other reasons).  I am at a loss here and I wonder if anyone else has any ideas.  Maybe 8.1 and 7 don't get along anymore. Not interested in going to 10 base don my experience with my laptop (another story)

 

Thanks for the ear. I know this was a lot to digest...

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The answer to this os simple. PC 1 has two NIC's of which only one of which has a default gateway assigned (NIC1) so when your pc tries to send traffic to the Multicast subnet 224.0.0.0/4 it will only do so over NIC1 as this has the default gateway.

 

This is why things are broken for PC 2 and why PB worked fine on PC 1. So that gives you two possibilities, the first is to mess with your PC's routing table to use NIC 2 for all 224.0.0.0/4 traffic, as you work in networking I wont teach you to suck eggs and explain how to do this in detail. Or bring PC2 into the same network by maybe purchasing another wireless nic.

 

 

Happy flying.

Share this post


Link to post
Share on other sites

Thank you for your reply. I have it working and this is what I found:

 

When both interfaces on PC1 are up I have the multicast 224.0.0.0 routes:

 

224.0.0.0        240.0.0.0         On-link      127.0.0.1

224.0.0.0        240.0.0.0         On-link      192.168.17.5 <--Wireless IF to home network/internet

224.0.0.0        240.0.0.0         On-link      192.168.27.1 <-- Private Ethernet to PC2/Panelbuilder (192.168.27.2)

 

When I disabled the Wireless Interface, the multicast route for it was no longer displayed on the table. I thought this was correct, yet I still could not get PB to function across the network. I then rebooted and decided to do leave the wireless interface up, but do a route delete on the multicast address instead  and viola ..it worked....  

 

Oh well..at least I have a work round. I only use the home network portion to backup my system to my WHS and update/download SW. 

 

Thanks again for making me revisit what I thought I already looked at....I must admit I was exhausted after fighting with this..

Share this post


Link to post
Share on other sites

Just a note regarding the issue with multiple network interfaces:

 

We are working on a solution that will allow you to select which interface to use. We have some initial success with this, but still have to make it a bit easier to configure. Not sure when we can get this released.

 

Right now, if you have multiple interfaces, windows 'decides' the best one to use.

Share this post


Link to post
Share on other sites

I guess I spoke too soon...I misspoke..I was running v2.92 when I got it to work. I originally had v2.95 installed but I backed it out during my testing. I re-installed v2.95 and now I cannot get it to work....(more head scratching)...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this