Sign in to follow this  
JNS

Can't find download of Learjet 35 v2.2.5

Recommended Posts

Hi.  I purchased the Learjet 35 P3D v3  from PC Aviator.  I have version 2.1.  I just checked a few minutes ago and they still have v 2.1.  Is there someplace I can download version 2.2.5?

 

Thanks,

Jeff

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You have to wait until Flysimware sends the updated version to the vendors and then wait for the vendors to update to the newest installers. It could be a matter of days up to a matter of weeks.

I am too waiting.

Share this post


Link to post
Share on other sites

Thanks, Samaritano.  I will give PC Aviator a call on Monday and see if I can get the ball rolling.

 

Jeff

Share this post


Link to post
Share on other sites

Thanks, Martin. Do you happen to know what version added P3D v3 support?  I have 2.1, but when I try to load it into the sim it keeps saying  either I have FSX or don't have P3D or it's an earlier version.  I have P3D v3.1.  It also mentions the gauges as not being for my sim.  I've got the GTN version of the GPS.  At the time I purchased all indications were that the aircraft would work in version 3 and when I installed I was careful to check to install correct version.  I have now uninstalled the Learjet 2.1 and am waiting on the new version.

 

 

Thanks,

Jeff

Share this post


Link to post
Share on other sites

Hi Jeff,
 
I installed it into P3D 2.4 so I can't comment on P3D 3.1 but I was under the impression that v3.1 is supported. Make sure you uninstalled the previous version using their uninstall menu. They have a small section on trouble shooting listed below?

http://flysimware.com/website/contact.html

 

Cheers

Martin
 

Share this post


Link to post
Share on other sites

Hi.   I had no other previous version of the Learjet when I installed 2.1.  I got lucky when I uninstalled 2.1.  I didn't know they had their own Uninstaller and I used the Windows Control Panel Uninstaller which happened to be mentioned by FlightSimWare as an alternative to their own Uninstaller.

 

Thanks,

Jeff

Share this post


Link to post
Share on other sites

The FSW uninstaller is located in the P3D root directory, no issues with P3D V3.1 but I am using the default GPS.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this