Jump to content

Sign in to follow this  
bbuckley

FullScreen goes completely Black

Recommended Posts

Any help greatly appreciated!

I've been flying FSX (specs below) on PilotEdge for almost a year now. I have been flying DX9 fullscreen with no issues. I just installed SteveFX DX10 Fixer and am trying to run in DX10 for some graphics improvements. After setting everything up I have it running great in both windowed and fullscreen mode UNTIL I connect to the PE Server. After connecting if I switch to fullscreen I get a totally black screen but it's obvious the underlying FSX is running. I can switch back to windowed using alt-enter and then everything is fine. If I just disconnect from the PE Server I can then switch to fullscreen fine. The FPS and shadows are much improved over DX9 so I'd like to get it fixed. I'm searching the forums and support but it's really odd to me that it seems to be directly related to connecting to the PE Server and disconnecting fixes it. I've also posted on the PE forum.  Is this a SimConnect problem? Just guessing?

 

I'm reasonably good with fsx.cfg, NVI and fsx file structures, etc. I can provide more complete DX10 controller settings (AA 32x) and NVI profile (8 SGSS), and fsx.cfg if helpful. I haven't found a complete & recent guide to the proper DX10 Fixer NVI settings yet.

Thanks,

Bruce

Specs:
FSX boxed with Acceleration, WIN 8.1 64bit, i7-4790K @4.32GHz, GTX 970 4GB, 16GB DDR3 SDRAM, 500GB SSD, 1TB HDD
Add-ons: REX4 TD w/SC, ASN, PE Client Carenado PA-28A, Carenado Phenom 100, Aerosoft F14X
Scenery: LatinVFR KSNA & KSAN, Sim720 KCRQ, MSE California South 2X, MSE KLAX / KSAN Ultra Res


Bruce Buckley | RW Commercial / Instrument / SEL / MEL

I9-9900K @5.0GHz, Maximus XI  Hero, GTX 1080ti, 32GB DDR4 3200 14, 1TB NVMe SSD, 500GB SSD, 1TB HDD, 40" Samsung 4K TV, Saitek/Logitech Pro Yoke, Throttle Q, Rudder Pedals, Switch Panel, WIN10, P3DV4.5, PTA, ASP4, REX TDSC Lots of ORBX stuff and some add on airports / aircraft

Share this post


Link to post
Share on other sites

I am not familiar with pilot edge - do they launch any tools.

 

I recall someone mentioning a full screen issue with Ivao

 

http://www.avsim.com/topic/468272-dx10-with-ivap/?hl=%2Bivao

 

If you search for the fixer guide on nzfsim that describes how to hide the Windows borders and create a pseudo full screen which might be a workaround?

Share this post


Link to post
Share on other sites

Thanks Steve!  I was able to work around in another way... It seems the issue is that the PE Client puts a window up "always on top" of fullcreen FSX as a PE transponder for Mode C / IDENT and some other indicators.  In DX9 that wasn't an issue, but apparently it is in DX10 (I'm on Win 8.1).  I suspect the IVAO issue is the same.  My workaround (for anyone who runs into the problem) was to uncheck that option in PE and program a button through FSUIPC4 to do the IDENT function. 

 

Thanks for your support and so far the DX10 and Fixer graphics and (performance on my machine) are awesome.

Bruce


Bruce Buckley | RW Commercial / Instrument / SEL / MEL

I9-9900K @5.0GHz, Maximus XI  Hero, GTX 1080ti, 32GB DDR4 3200 14, 1TB NVMe SSD, 500GB SSD, 1TB HDD, 40" Samsung 4K TV, Saitek/Logitech Pro Yoke, Throttle Q, Rudder Pedals, Switch Panel, WIN10, P3DV4.5, PTA, ASP4, REX TDSC Lots of ORBX stuff and some add on airports / aircraft

Share this post


Link to post
Share on other sites

Thanks Bruce, I think that you are correct that the IVAO issue is similar. In that case I believe the tool is for text comms. It seems that you have a good workaround, thanks for sharing.

Share this post


Link to post
Share on other sites

I see the best answer posted but not sure if it applies to me since I don't have a PE Client and can't find any option of putting a window "always on top"

 

Everytime I join up a server, the screen is always black, I have to alt-tab and run in window mode. I have a triple monitor setup and don't want to resort to using only one monitor, ruins the experience. How can I get it fixed?

 

Does the fact that I have skype open is an issue? 

Share this post


Link to post
Share on other sites

Why can you not use all 3 monitors in windowed mode?

 

As I mentioned above I have been told previously that there is an issue with ivao, to do with some tool that they autolaunch which sounds similar to the pilot edge case.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,170.00 of $25,000.00 Donate Now
×
×
  • Create New...