Sign in to follow this  
Bobsk8

Made the big mistake and installed 3.2

Recommended Posts

This is probably the worst advice I've ever seen.  

 

Exactly how do you expect LM to control what 3rd party add-ons do?  And more importantly would you want LM to control them? ... it can be done, but you'd have a considerably smaller world of add-ons to choose from.

 

There have been many threads on how to upgrade, some of which I know you participated in, that clearly outlined what 3rd party products will need updating for P3D V3.2.

 

Why do you insist on bashing LM almost every time YOU have a problem with a 3rd party product?  Shouldn't you be going to the add-on's web site and posting there?

 

I believe someone had provided you with a diagnostic process, disable all your DLL.XML and EXE.XML entries ... test P3D, enable each one back one at a time and you'll found the source.  But before doing that, check with the Add-on vendor first to see if they have udpates for v3.2 or if any updates are even required.  There are only a handful of 3rd party products that needed to update for V3.2, not bad out of 10,000's of available products.

 

This is not a market where everything you have installed (3rd party) will automatically be update, it will NEVER be that kind of market, ever.  Not Xplane, not DTG, not FSX, not FSX-SE, not even DCS.  The more complex YOU make your sim, the more you need to work to get all that complexity on the "same page".

 

So anyone, if you have an issue with 3rd party, take it to 3rd party and stop the LM bashing.

 

Cheers, Rob.

 

OK, first of all, your point is taken and I agree that LM can't control all the add ons. I did follow all the advice about exactly what had to be upgraded to make the change to 3.2 and I very carefully followed every recommendation and in fact, waited until I had each and every one installed before i moved to 3.2.  So I was rather upset, which I think anyone would be, when P3D crashed and would not load the first time I started it after updating.  It looks like it is turning out that the FSDT add on manager may be the problem. Two other people disabled it in the  DLL.XML file  and their crashes went away, so I have just done the same thing, and am hoping that this fixes the issue. I have also posted this on the FSDT GSX forum.   

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

OK, first of all, your point is taken and I agree that LM can't control all the add ons. I did follow all the advice about exactly what had to be upgraded to make the change to 3.2 and I very carefully followed every recommendation and in fact, waited until I had each and every one installed before i moved to 3.2.  So I was rather upset, which I think anyone would be, when P3D crashed and would not load the first time I started it after updating.  It looks like it is turning out that the FSDT add on manager may be the problem. Two other people disabled it in the  DLL.XML file  and their crashes went away, so I have just done the same thing, and am hoping that this fixes the issue. I have also posted this on the FSDT GSX forum.   

 

The bglmanx.dll has been your problem all along. Just install the latest GSX version. I mentioned this in another thread as the newest version of P3D had a menu issue with GSX and AiCarriers if your only updating the client and not the p3d content too.

At this point you would well advised to try deleting these exact files. Anytime I've had an issue from installing and testing addons the past two weeks I've lived with P3D- deleting these three files has always fixed the problem as P3D will rebuild them on next startup.

Prepar3D_Default.fxml & Prepar3D_Default.wx located in %LOCALAPPDATA%\Lockheed Martin\Prepar3D v3

Prepar3D.cfg located in %APPDATA%\Lockheed Martin\Prepar3D v3

Share this post


Link to post

I had a similar problem - disabling the dll.xml and exe.xml entries told me it as a 3rd party addon causing the crashes. 10 minutes later I discovered it as FSDT stuff. Just rerun the installer and it downloads the patched files. All better.

Share this post


Link to post

Nothing personal Bob - and please forgive the straight talk? You are one of a handful of people who have had problems Installing/Upgrading (not quite sure what you are attempting to do), and have had problems? Many thousands of Flight Simmers have followed the LM recommended path with no problems whatsoever - and yet you quote a couple of posts on the LM Forum as if to support your assertion that V3.2 is flawed?  Sorry Bob -  I am not trying to teach you how to suck eggs - but....... ?

  • Upvote 2

Share this post


Link to post

Thanks Bob for your help ..... unfortunately I have found that this is not the total solution ....

 

 

 

First of all say that two things I have done before and after apply your solution has been :

 

- disable all dll.xml and exe.xml entries, like Rob Ainscough has said in other part of the Forum, but .... Rob the problem persist and then I think that the problem perhaps is not due to other addons.

 

- deleting the three files that skully has also said and also the problem persist

 

Prepar3D_Default.fxml, Prepar3D_Default.wx and  Prepar3D.cfg 

 

 About the uninstall and reinstall client and content :

 

If the default flight has been saved  with one of the four aircrafts I have said in my initial note  .... no problem .... and at the Scenery Startup Screen  I can change the aircraft and/or the airport also without problem ( before your solution I could make that change but only after passing the Scenery Startup Screen  ) .... at those moment I can even change to another saved flight ( with any aircraft and airport ) different of the default, also without problem.

 

But ..... like before use your solution ..... if the default aircraft is other than those four, as soon as I push OK in the Scenery Startup Screen  the simulator crashes.

 

One new thing I have observed after use your solution :

 

- If I deselect the option  " Show Scenario Startup Screen " in Settings/General/Program I can use as default any flight saved .... with any aircraft and from any airport ...... but if I do so :

 

-  I can't change the aircraft ( the simulator crashes )

 

- I can change the airport without problem

 

- I can change the scenario to any other saved even with different  aircraft and .... curious .... after this last change I can also change the aircraft to any other.

 

As conclusion, I think that perhaps the problem may be in the area of the program respective to the initial aircraft/scenario/airport load in conjunction with any of my settings and this is something  that only LM can inform about and/or solution .... don't you think so ???

 

I hope that LM people can read my explanation and give a solution.

 

 

 

Thanks again Bob

 

J J Gómez Prieto

Share this post


Link to post

I think I may have found the root of my problem. In the GSX add on manager there is an updater that is supposed to check to make sure you have the latest add on manager update. I just found out that this is not quite true, or at least my understanding of it but I am not a computer programmer. Prior to installing P3D V3.2 I made of list of things that had to be updated such as ASN, etc. On the list was the add on manager for coutal. So while I was running P3D , I went to the Couatl Live Update menu, and had it check  auto updater and it said I had the latest update, which was 2 days ago, so i thought I was good to go. As it turns out, this is not what is needed for P3D V 3.2  The bglmanx.dll has to be updated and the only way that can be done is to install a new copy of the  add on manager, or reinstall GSX.  So thinking that I had made all the modifications needed, that is why I couldn't figure out what could be wrong. It was a few people on Facebook that pointed out that they had a similar problem, and when they disabled the Add on  Manager, the problem went away. What made it more difficult is V3.2 would work fine for maybe 10 flights, loading up with zero problem, and the next 5 times I would try and fly, it would crash each time on startup. Anyway, I just downloaded the Add on  Manager, and the bglmanx.dll was replaced with a new version. And I didn't have to reinstall P3D, or format my harddrive, or buy a new GPU and CPU.... :wink: 

 

 

And that's my story. 

Share this post


Link to post

So.Bob .....  because I was growling at your post - my fat cat has left home with a knapsack on its' back and is currently on its' way to London to make a Fortune, the expensive Wife has moved in with the Guy down the Avenue because he "Isn't a Flight Simmer", the 30 year old 'children' have finally Flown the Nest ......  and all that you can say is "...I think I may have found the root of my problem...." ????

 

My HERO!!!    :wink: 

 

You and Me at Mine! The Drinks are on Me!! :drinks:

Share this post


Link to post

So while I was running P3D , I went to the Couatl Live Update menu, and had it check  auto updater and it said I had the latest update, which was 2 days ago, so i thought I was good to go.

 

I know I singled you out Bob, but you are certainly not the only that has a problem and immediately says it's LM's fault ... what I took exception at is that because you were having a problem you advised others NOT to update.

 

Yes, the FSDT auto updater will indicate you have the latest version but that isn't the process to get it updated to support V3.2.  Virtuali's forums dated March 8th, instructions to get updated products for V3.2 are here: http://www.fsdreamteam.com/forum/index.php/topic,13227.0.html ... you don't need to re-download anything follow these instructions per Umberto:

 

 

 

The updated Addon Manager .dll, which supports P3D 3.2, is online now. 

 

To get it, run ANY FSDT installer, either a scenery, GSX, or the Stand-Alone Addon Manager, so the installer will be able to fetch the updated BGLMANX.DLL from our server. No need to re-download any installer, just run the installers you already have.

 

 

 

Heres a solution install a fresh copy 

 

That is an option but it certainly is NOT required, the purpose of the separate client, content, scenery installers is so that users don't have to do a "fresh install" and these separate installers work as they are supposed to work ... however, that doesn't mean users can ignore their current set of add-ons.

 

The easy update to v3.2 is to just do Client installer (uninstall Client 3.1, install Client 3.2) and nothing else.  If you have scenery add-ons then it's unlikely you'll be using any of LM's default scenery so no need to run it.  If you have content add-on (effects i.e. Precipitfx or other effects, autogen, etc.) then you probably don't want to run the V3.2 content installer either.

 

There are numerous threads on how to do a client and content install without doing a full re-install. But if one thinks they need a client, content, and scenery v3.2 (all 3), then in that situation I would recommend a wipe and fresh install of V3.2 and then re-add all your other add-ons.

 

Cheers, Rob.

Share this post


Link to post

I know I singled you out Bob, but you are certainly not the only that has a problem and immediately says it's LM's fault ... what I took exception at is that because you were having a problem you advised others NOT to update.

 

Yes, the FSDT auto updater will indicate you have the latest version but that isn't the process to get it updated to support V3.2.  Virtuali's forums dated March 8th, instructions to get updated products for V3.2 are here: http://www.fsdreamteam.com/forum/index.php/topic,13227.0.html ... you don't need to re-download anything follow these instructions per Umberto:

 

 

 

 

 

That is an option but it certainly is NOT required, the purpose of the separate client, content, scenery installers is so that users don't have to do a "fresh install" and these separate installers work as they are supposed to work ... however, that doesn't mean users can ignore their current set of add-ons.

 

The easy update to v3.2 is to just do Client installer (uninstall Client 3.1, install Client 3.2) and nothing else.  If you have scenery add-ons then it's unlikely you'll be using any of LM's default scenery so no need to run it.  If you have content add-on (effects i.e. Precipitfx or other effects, autogen, etc.) then you probably don't want to run the V3.2 content installer either.

 

There are numerous threads on how to do a client and content install without doing a full re-install. But if one thinks they need a client, content, and scenery v3.2 (all 3), then in that situation I would recommend a wipe and fresh install of V3.2 and then re-add all your other add-ons.

 

Cheers, Rob.

@Rob. Shush!!! I am trying to organise a Party here!!  :Tounge:

Share this post


Link to post

@Rob. Shush!!! I am trying to organise a Party here!!  :Tounge:

Count me in! :Clown:

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this