Sign in to follow this  
Hernan1

FS9 won't run.Log-in with administrator priviledges

Recommended Posts

I have FS9 and I've been running it with Windows XP for many years. I recently changed computers and reinstalled my FS9 using Windows 7 A few days ago I tested it and noticed that the gauges for all of my add-on aircraft have not been loaded. Payware sceneries did not transfer either. I was able to install my Quality Wings 757. The gauges for this aircraft work fine. Last night Windows loaded over 270 updates. When I tried to start Flight Simulator today I got this message: "Please log-in with administrator privileges and try again" I attempted to do that, but I still had the same problem. I read somewhere to restore to the time before the automatic updates were installed. I did that, but nothing happened. My desktop was empty, except for "My Computer and Recycle bin" icons. I had to "undo" and was able to see all of my previously installed programs. I attempted to start FS9 again and I continue getting the same warning to log-in with administrator privileges. I don't know what else to do at this time. I am not a computer genius at all. Any suggestions will be greatly appreciated. :Hmmmph: Thanks.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The first thing that comes to mind is have you installed the sim into the "Program Files" folder?  If so then uninstall and reinstall it to somewhere other than "Program Files" - e.g. "C:\FS9".  Unlike XP the "Program Files" folder in Windows 7 has restrictions which can cause all sorts of problems and is a known issue amongst simmers.

 

Dijvid

Share this post


Link to post
Share on other sites

Hi Hernan1, one of the 270 Windows Updates will stop Windows 7 from reading the FS2004 Disk 4, the 'Run' disk. Please read this thread which explains the issue and tells you how to fix it:

http://calclassic.proboards.com/thread/7470/fs2004-start-read

 

Or get the fix that eliminates the need for Disk 4.  I think the above link will give you more information about this.

 

Dijvid

 

Share this post


Link to post
Share on other sites

Thank you gentlemen for your response. I was able to run Flight Simulator by removing the Windows 7 update. I am now following your recommendations. I will advise.

Share this post


Link to post
Share on other sites

After several days of trying to set up my FS9 using Windows 7, I am becoming more frustrated with the way it runs. All payware aircraft gauges cannot load up. Payware sceneries dissapear after a few minutes as if I had demo ones. In many instances just a portion will appear, such as missing jetways or complete terminals. One example when trying to use Simflyer's Phoenix scenery, my aircraft just sinks below the ground and it starts to float in the air. Other programs such as FSPainter no longer shows any of my aircraft, specially when trying to start a repaint. EditVoicepack couldn't find the path to FS9 (I read that I should reinstall FS9 outside the Program Files (x86) folder) AFCAD requires for me to individually search and open a scenery file, rather than listing all of the sceneries. I also noticed that freeware sceneries work fine, but payware sceneries are different. Is the installation of them different when using windows 7?

Share this post


Link to post
Share on other sites

 

 


Is the installation of them different when using windows 7?

 

Hi Hernan, yes it is different - you must install everything using Administrator privileges: right-click on the install icon and select Install as Administrator. When the program is installed, right-click on the shortcut (if there is one) and select Options, Compatibility, then Run As Administrator and save. Then click on the icon as normal to run the program.

Share this post


Link to post
Share on other sites

Most proper installers should be prompting for elevated permissions already.

 

Cheers!

 

Luke

Share this post


Link to post
Share on other sites

Hi,

Where can I find the no-cd patch for FS9? The one that was provided no longer works.

Thanks,

Brent

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this