Jump to content

Sign in to follow this  
dogs53

P3Dv2 Mouse Freezes and Causes Computer Lockup

Recommended Posts

For the past several months, I have been having an issue with P3D in that occasionally when I move the mouse to the menu section to change location or vehicles, it freezes on the left side of the of screen, causing the computer to completely lock up.  

 

Even Pressing Control-Alt-Delete does nothing and the only option seems to be to do a hard shutdown and restart the computer.  I changed mouse devices, checked for driver updates and still no resolution.  I replaced the .cfg file, and no help.  

 

I am using w7, Saitek Hub and throttles, and multiple monitors.  This does not happen in FSX, and only began a few months ago, in-spite of the fact that I have been using p3D for a year or so with no problem.

 

Any ideas?  And thanks!

 

Dogs53

Share this post


Link to post
Share on other sites

For the past several months, I have been having an issue with P3D in that occasionally when I move the mouse to the menu section to change location or vehicles, it freezes on the left side of the of screen, causing the computer to completely lock up.  

 

Even Pressing Control-Alt-Delete does nothing and the only option seems to be to do a hard shutdown and restart the computer.  I changed mouse devices, checked for driver updates and still no resolution.  I replaced the .cfg file, and no help.  

 

I am using w7, Saitek Hub and throttles, and multiple monitors.  This does not happen in FSX, and only began a few months ago, in-spite of the fact that I have been using p3D for a year or so with no problem.

 

Any ideas?  And thanks!

 

Dogs53

 

Have you changed GPU drivers?


PF3 Beta Tester

Bob Cardone        P3D 3,4       FlyVirtual.net   Aivlasoft EFB2  /pf3-supporter.gif

 

 

 

Share this post


Link to post
Share on other sites

Yes on the USB mouse.  And I just downloaded and installed the new drivers.  I will try again and let you know.  However, it doesn't happen all of the time, but when it does (every few hours of flying), it is a pain... Fingers crossed.  Thanks  

Share this post


Link to post
Share on other sites

Hi--I had the exact same problem and solved it by getting a new mouse.  The old one had worn down contacts that made it behave as you have described.


Forever indebted to the late Michael Greenblatt of FSGS.

 

 

 

Share this post


Link to post
Share on other sites

The problem happened again on the next day after reinstalling the drivers. I will try as suggested above with the new mouse.  Hopefully this resolves it.

Share this post


Link to post
Share on other sites

I've actually been having this problem myself since installing P3DV3.3.  It's not the mouse, it's likely something to do with USB drivers. I've still troubleshooting this,and will certainly post back when I find something.  It doesn't happen on every flight, just enough to be a real pain.

 

 

I've removed power saving for all USB Hubs/Devices - it had no affect.


Dave-Aerosoft-Signature-Banner-2019.png

Share this post


Link to post
Share on other sites

I was having a similar issue where I would have a severe lock up followed by an odd beeping sound when trying to use the mouse, It turned out to be a problem between P3D & my Saitek Trim Wheel. Disconnecting the wheel whilst using P3D solved the issue.

 

I also at times was able to prevent it by activating the wheel prior to starting the sim.

 

Just a suggestion as you didn't mention which Saitek units you have.


Cheers, Ross

i7 7700K | ASUS ROG Maximus IX Hero Z270 | ASUS ROG STRIX GTX1080 OC 8Gb | 16Gb G.Skill  Ripjaws DDR4 3200 I  Thermaltake Water 3.0 Riing | Samsung SSD 840 500 GB HD | WIN 10 64 Bit

Share this post


Link to post
Share on other sites

You beat me to it.

 

The Saitek trim wheel driver does not work with P3D and will lock up P3D and can even lock up all USB inputs to Windows, though it appears the latter is caused by the P3D-Trim Wheel issue.

 

It looks like I also stumbled upon a problem where P3D will crash if USB controllers are unplugged while P3D is running. I'll check to see if this has already been reported. This does not occur with FSX.

 

I'm unable to find any problem with the mouse, and I monitored all USB inputs via USB buses.


Dave-Aerosoft-Signature-Banner-2019.png

Share this post


Link to post
Share on other sites

I don't think you need drivers for the trim wheel.  I just plugged mine in and it worked.


Forever indebted to the late Michael Greenblatt of FSGS.

 

 

 

Share this post


Link to post
Share on other sites

I have unplugged my Saitek Trim wheel and do not use it with P3D. The whole PC locks up


Manny

Beta tester for SIMStarter 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...