Jump to content

Archived

This topic is now archived and is closed to further replies.

CathayA340

Blurry Ground Texture Problem

Recommended Posts

Hello,

I'm running Prepar3D v3.2.3.16769 and I'm having problems with blurry ground textures. When I initially load up at an airport, the ground texture/mesh is clear : http://prntscr.com/c26k8d

As I fly around to other airports, or slew to another airport nearby, the ground mesh/texture becomes incredibly blurry. When I stop slewing or moving, and stop aircraft motion, I try to let the textures load to become clearer. Nothing happens, and the ground texture stays blurry, as shown here : http://prntscr.com/c26kzt

 

I have no idea what's causing the blurry textures. I have the latest NVIDIA graphics driver. I'm using Predrag's Realism Shader Pack, PTA 3.3, and ReShade w/ Eddie's ReShade profile.

Here is my prepar3d.cfg:

[JOBSCHEDULER]
AffinityMask=10
[GRAPHICS]
HDR_BRIGHTNESS=1.050000
HDR_BLOOM_THRESHOLD=3.000000
HDR_BLOOM_MAGNITUDE=0.850000
HDR_BLOOM_BLUR_SIGMA=0.800000
TONEMAP_DAY_EXPOSURE_KEY=0.280000
TONEMAP_NIGHT_EXPOSURE_KEY=0.130000
HDR_SATURATION=0.950000
MIPMAP_VC_PANELS=1
TESSELLATION=1
TEXTURE_MAX_LOAD=2048
NUM_LIGHTS=4
COCKPIT_HIGH_LOD=1
AIRCRAFT_REFLECTIONS=1
LANDING_LIGHTS=1
DAWN_DUSK_SMOOTHING=1
LENSFLARE=1
HDR=1
DYNAMIC_REFLECTIONS=0
SHADOW_QUALITY=2
TERRAIN_SHADOW_CAST_DISTANCE=0
CLOUD_SHADOW_CAST_DISTANCE=0
OBJECT_SHADOW_CAST_DISTANCE=2
CONTENT_NO_SHADOW=0
INTERIOR_SHADOWS_CAST=1
EXTERIOR_SHADOWS_CAST=1
SIMOBJECT_SHADOWS_CAST=0
TERRAIN_SHADOWS_CAST=0
VEGETATION_SHADOWS_CAST=0
BUILDING_SHADOWS_CAST=0
CLOUD_SHADOWS_CAST=0
INTERIOR_SHADOWS_RECEIVE=1
EXTERIOR_SHADOWS_RECEIVE=1
SIMOBJECT_SHADOWS_RECEIVE=0
TERRAIN_SHADOWS_RECEIVE=1
VEGETATION_SHADOWS_RECEIVE=0
BUILDING_SHADOWS_RECEIVE=0
SHADOW_NUM_CASCADES_LOW=4
SHADOW_NUM_CASCADES_MID=5
SHADOW_NUM_CASCADES_HIGH=7
SHADOW_NUM_CASCADES_ULTRA=12
GROUND_SHADOW_TEXTURE_SIZE=2048
CLOUD_SHADOW_TEXTURE_SIZE=512
SHADOW_LOG_PARTITION_LOW=0.850000
SHADOW_LOG_PARTITION_MID=0.850000
SHADOW_LOG_PARTITION_HIGH=0.850000
SHADOW_LOG_PARTITION_ULTRA=0.850000
EFFECTS_QUALITY=1
EFFECTS_DISTANCE=1
TEXTURE_QUALITY=3
IMAGE_QUALITY=0
See_Self=1
Text_Scroll=1
HIGHMEMFIX=1
[DISPLAY]
ChangeTime=1.0000
TransitionTime=1.0000
TEXTURE_FILTERING=4
MSAA=4
SSAA=0
VSYNC=0
FXAA=1
TRIPLE_BUFFER=0
ActiveWindowTitleTextColor=255,255,255
ActiveWindowTitleBackGroundColor=0,28,140,64
NonActiveWindowTitleTextColor=255,255,255
NonActiveWindowTitleBackGroundColor=24,33,87,64
InfoUpperLeftTextColorUser=255,0,0
InfoUpperLeftTextColorNonUser=255,127,0
InfoUpperLeftBackGroundColor=0,0,0,0
InfoUpperRightTextColor=255,0,0
InfoUpperRightBackGroundColor=0,0,0,0
InfoLowerLeftTextColor=255,255,255
InfoLowerLeftBackGroundColor=255,0,0,128
InfoLowerRightTextColor=255,255,255
InfoLowerRightBackGroundColor=255,0,0,128
InfoBrakesEnable=False
InfoParkingBrakesEnable=False
InfoPauseEnable=False
InfoSlewEnable=False
InfoStallEnable=False
InfoOverspeedEnable=False
InfoWeaponSystemEnable=False
InfoCountermeasureEnable=False
InfoUpperRightTextEnable=True
SKINNED_ANIMATIONS=1
TEXTURE_BANDWIDTH_MULT=30
UPPER_FRAMERATE_LIMIT=0
WideViewAspect=True
FullScreenBackground=False
FullScreenAutoFill=True
Fullscreen=False
[sCENERY]
MaxRegionsPurgePerFrame=16
POP_FREE_AUTOGEN=1
AUTOGEN_BATCH_LOD=2
AUTOGEN_TREE_MAX_DRAW_DISTANCE=9500.000000
AUTOGEN_TREE_MIN_DISTANCE_TO_LOD=2500.000000
IMAGE_COMPLEXITY=3
[MAIN]
User Objects=Airplane, Helicopter, Submersible, ExternalSim, Avatar
LabelsSupported=Airplane, Helicopter
Location=364,85,1404,864,\\.\DISPLAY1
Maximized=2
ShowInfoText=1
HideMenuNormal=0
HideMenuFullscreen=1

[PANELS]
IMAGE_QUALITY=1
SAVE_AND_LOAD_PANEL_STATE=0
PANEL_OPACITY=100
QUICKTIPS=0
PANEL_MASKING=1
PANEL_STRETCHING=1
UNITS_OF_MEASURE=0
[WEATHER]
WindshieldPrecipitationEffects=1
MinGustTime=10
MaxGustTime=500
MinGustRampSpeed=1
MaxGustRampSpeed=200
MinVarTime=5
MaxVarTime=50
MinVarRampSpeed=10
MaxVarRampSpeed=75
TurbulenceScale=1.000000
WeatherGraphDataInDialog=0
AdjustForMagVarInDialog=1
DynamicWeather=0
DownloadWindsAloft=0
DisableTurbulence=0
CLOUD_DRAW_DISTANCE=6
DETAILED_CLOUDS=1
OPTIMIZE_DENSE_CLOUDS=1
CLOUD_COVERAGE_DENSITY=7
THERMAL_VISUALS=0
VolumetricFog=1
[CONTROLS]
Controls_Default=Standard
Controls_Current=Standard
KBDAIL=64
KBDELEV=64
KBDRUD=64
force_master_gain=10000
force_stick_force_enabled=1
force_stick_shaker_enabled=1
force_gear_bump_enabled=1
force_crash_enabled=1
force_ground_bumps_enabled=1
force_machinegun_enab led=1
[TextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
[TextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
GForce=1,3
FuelPercentage=1,4
[TextInfo.3]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
FrameRate=2,1
LockedFrameRate=2,2
GForce=2,3
FuelPercentage=2,4
[slewTextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
[slewTextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
[slewTextInfo.3]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
FrameRate=2,1
LockedFrameRate=2,2
[Avatar]
DefaultAvatar=Civilian Male White Shirt Blue Jeans
AvatarModeEnabled=0
[DynamicHeadMovement]
LonAccelOnHeadLon=-0.020000
LonAccelOnHeadPitch=-0.010000
RollAccelOnHeadLat=0.010000
YawAccelOnHeadLat=-0.100000
RollAccelOnHeadRoll=0.100000
MaxHeadAngle=5.000000
MaxHeadOffset=0.300000
HeadMoveTimeConstant=1.000000
[VirtualCopilot]
VirtualCopilotActive=0
[DISPLAY.Device.NVIDIA GeForce GTX 750 Ti.0.0]
Mode=1920x1080x32
[DISPLAY.Device.NVIDIA GeForce GTX 750 Ti.0.1]
Mode=1600x900x32
[DISPLAY.Device.NVIDIA GeForce GTX 750 Ti.0.2]
Mode=1920x1080x32
[uSERINTERFACE]
SHOW_SCENARIO_WINDOW=1
SHOW_MISSION_CAPTIONS=0
PAUSE_ON_LOST_FOCUS=0
PROMPT_ON_EXIT=1
RestoreTimeOnMove=0
Map_Orientation=2
MUTE_ON_LOST_FOCUS=0
SITUATION=C:\Users\Wesley\Documents\Prepar3D v3 Files\DefaultFlight
[PointOfInterestSystem]
CycleSetting=1
[sOUND]
PrimaryPlaybackDevice={DEF00000-9C6D-47ED-AAF1-4DDA8F2B5C03}
VoicePlaybackDevice={DEF00002-9C6D-47ED-AAF1-4DDA8F2B5C03}
VoiceCaptureDevice={DEF00003-9C6D-47ED-AAF1-4DDA8F2B5C03}
SOUND=1
SOUND_QUALITY=2
SOUND_LOD=0
SOUND_FADER1=0.870000
SOUND_FADER2=0.490000
SOUND_FADER3=0.300000
SOUND_FADER4=-0.500000
[TrafficManager]
AirlineDensity=0
GADensity=0
FreewayDensity=25
ShipsAndFerriesDensity=5
LeisureBoatsDensity=5
IFROnly=0
AIRPORT_SCENERY_DENSITY=0
[AContain]
ShowLabels=0
ShowUserLabel=0
ShowLabelManufacturer=1
ShowLabelModel=1
ShowLabelTailNumber=0
ShowLabelDistance=1
ShowLabelAltitude=1
ShowLabelAirline=0
ShowLabelAirlineAndFlightNumber=0
ShowLabelFlightPlan=0
ShowLabelContainerId=0
ShowLabelAirspeed=0
ShowLabelHeading=0
LabelDelay=1000
LabelColor=FFFF0000
[TERRAIN]
TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=2500
LOD_RADIUS=4.500000
TESSELLATION_FACTOR=85
MESH_RESOLUTION=22
TEXTURE_RESOLUTION=26
AUTOGEN_VEGETATION_DENSITY=2
AUTOGEN_BUILDING_DENSITY=3
DETAIL_TEXTURE=1
WATER_REFLECT_CLOUDS=1
WATER_REFLECT_USERAIRCRAFT=1
WATER_REFLECT_SIMOBJECTS=0
WATER_REFLECT_TERRAIN=0
WATER_REFLECT_AUTOGEN_VEGETATION=0
WATER_REFLECT_AUTOGEN_BUILDINGS=0
WATER_REFRACT_CLOUDS=0
WATER_REFRACT_USERAIRCRAFT=0
WATER_REFRACT_SIMOBJECTS=0
WATER_REFRACT_TERRAIN=0
WATER_REFRACT_AUTOGEN_VEGETATION=0
WATER_REFRACT_AUTOGEN_BUILDINGS=0
ENABLE_BATHYMETRY=0
WATER_CLARITY=30
WATER_DETAIL=2
UseGlobalTerrainView=False
[ATC]
AutoOpenAirTrafficWindow=0
UsePilotVoice=0
ShowATCText=0
PilotVoice=0
COMM_MSG_AI_ATC_COLOR=0XFF8C00
COMM_MSG_ATC_AI_COLOR=0X00008B
COMM_MSG_ATC_USER_COLOR=0X006400
COMM_MSG_USER_ATC_COLOR=0XA52A2A
COMM_MSG_ATIS_COLOR=00000000
[iNTERNATIONAL]
ASLAT=2
ASLON=1
MEASURE=0
[REALISM]
PFactor=1.000000
Torque=1.000000
GyroEffect=1.000000
CrashTolerance=1.000000
General=1.000000
UnlimitedFuel=False
AllowEngineDamage=True
TrueAirspeed=False
AutoCoord=False
RealMixture=True
StressDamage=True
GEffect=True
ManualLights=True
GyroDrift=True
CrashWithDyn=True
CrashDetection=False
OnCrashAction=0
[ATTACHMENTS]
WeaponHighlight=False
HighlightDuration=1.000000
AutoWeaponSwitching=False
UnlimitedWeapons=False
UnlimitedCountermeasures=False
IgnoreAttachmentWeight=True
IgnoreAttachmentForces=True
[RECORDER]
RecordAITraffic=True
RecordAirportVehicles=True
RecordLeisureBoats=True
[sIM]
SYSCLOCK=1
OPTIMIZE_PARTS=1
[sTARTUP]
DEMO=0
STARTUP_DEMO=
LOAD_SCENARIO_TOOLS=1
LoadCorePlugins=1
LoadWindow=1
[FACILITIES]
COUNTRY=
STATE=
CITY=
GTL_BUTTON=4096
[MISC]
Com_Rate=7
[DEBUG]
ReportLoadErrors=0
[MOUSE]
EnableGestures=False
[MULTIPLAYER]
condAccountPassword=0
VoiceVolume=-1.000000

 

Running Windows 10 64 bit, i5-4670k, GTX750ti, 8GB RAM.

 

Can anyone shed some light on this problem? It would be greatly appreciated. Thank you!

Share this post


Link to post

Hello,

I'm running Prepar3D v3.2.3.16769 and I'm having problems with blurry ground textures. When I initially load up at an airport, the ground texture/mesh is clear : http://prntscr.com/c26k8d

 

 

Oh Oh I know this one lol hyperthreading on in bios   :wink:

 

AffinityMask=85

 

================

 

What do you mean your using Predrag's Realism Shader Pack, and PTA - You can only use one or the other at the same time ?


Rich Sennett

               

Share this post


Link to post

I've been battling this same problem over the last week in that same version of P3D. I've tried everything from lowering settings to next to nothing, affinity mask and hyperthreading as mentioned by Richard and nothing has worked. I was beginning to think it is an actual bug rather than a hardware or settings issue. So this evening I actually trashed the whole install and am currently sitting through a clean install of 3.3.5.

 

Do you have any terrain addons installed like ORBX Global?


Is it done yet? When will it be released? Will it be freeware or payware? How much will it cost? Any updates on the progress? Will it work for Xbox? Can I be a beta tester? How's the performance in VR?

Share this post


Link to post

I've been battling this same problem over the last week in that same version of P3D. I've tried everything from lowering settings to next to nothing, affinity mask and hyperthreading as 

 

Sorry to hear this guys if you just installed orbx na lc or even if you didnt try this delete these files and let them rebuild like you would do with your shaders folder - delete the SceneryIndexes located below

 

C:\ProgramData\Lockheed Martin\Prepar3D v3\SceneryIndexes


Rich Sennett

               

Share this post


Link to post

 

 


Here is my prepar3d.cfg:
[JOBSCHEDULER]
AffinityMask=10

 

Your mask is 10. That will cause blurries for sure. 10 means you only have two cores turned on! If you have blurries suggest removing the affinity mask entry or commenting it out.

Share this post


Link to post

Sorry to hear this guys if you just installed orbx na lc or even if you didnt try this delete these files and let them rebuild like you would do with your shaders folder - delete the SceneryIndexes located below

 

C:\ProgramData\Lockheed Martin\Prepar3D v3\SceneryIndexes

I did in fact just install OpenLC NA and that's when the ground textures stopped loading after I would leave the initial area. Like I said I needed to update my P3D anyways and I wanted to try to install my sceneries outside of the root folder as it seems that is recommended.


Is it done yet? When will it be released? Will it be freeware or payware? How much will it cost? Any updates on the progress? Will it work for Xbox? Can I be a beta tester? How's the performance in VR?

Share this post


Link to post

Just to add on this topic, if it helps at all:

 

I noticed that I was getting persistent blurries in P3D as well, with any sort of FTX scenery (regions or OLC/Global). I didn't recall seeing them before, but I hadn't really spent any time in the sim since I installed P3D, so I can't really be sure they didn't exist before. But it was just as described above - any sort of distance away from my initial starting point, whether by flight or slewing, would result in the ground textures being blurry, and not 'catching up' at all - they just stay blurry.

 

I had:

[JOBSCHEDULER]
AffinityMask=14

in place, as I've always done. I've been using this setting for quite awhile on both FSX and P3D. I'm uncertain whether it was needed on P3D, or whether I was just seeing a placebo effect previously, but it sure wasn't causing any ill effects on my CPU.

 

However, the difference now is that I've recently upgraded to Win10. I'm not sure why that would have an effect, but after reading the tips in this thread I decided to delete my AffinityMask altogether, and presto... No More Blurries

 

In fact, I had a good flight in the A2A Cherokee last night around Vancouver Island (covered with the FTX region), flying in and out of a really decent freeware CYBL (by Don Grovestine, in the library here), smooth as silk, with frames sitting steady right around 60. Pretty darn happy with the sim once again.


Jim Stewart

Milviz Person.

 

Share this post


Link to post
If the latter is true, I had never had burriers with affinitymask = 14, but since 3.3.5, stunning, was removed affinitymask. and not burries 

and if limited frames to 33 true best.

Greetings.


Saludos:

José Luis Orte Gracia

Boeing777_Banner_Pilot.jpg

yeEIP.gif

Share this post


Link to post

I've tried 14 - 85 and no AM     ------------   not much difference between all of them here but should revisit no AM again


Rich Sennett

               

Share this post


Link to post

I did a clean install of P3D and installed Global, Vector and then OpenLC USA. Went into the sim and took off to some wonderful looking textures but again, left the area of the initial LOD and flew into blurry ground textures. I paused the sim and went into my scenery library and unchecked the OpenLC NA entries to disable it, returned to the sim and it reloaded my ground textures and I went flying away from the initial LOD area and sure enough my textures stayed sharp. So it appears to have been narrowed down to OpenLC NA. I submitted a thread at the ORBX support forums so I guess I won't be able to use OpenLC NA for now.


Is it done yet? When will it be released? Will it be freeware or payware? How much will it cost? Any updates on the progress? Will it work for Xbox? Can I be a beta tester? How's the performance in VR?

Share this post


Link to post

I did a clean install of P3D and installed Global, Vector and then OpenLC USA. Went into the sim and took off to some wonderful looking textures but again, left the area of the initial LOD and flew into blurry ground textures. I paused the sim and went into my scenery library and unchecked the OpenLC NA entries to disable it, returned to the sim and it reloaded my ground textures and I went flying away from the initial LOD area and sure enough my textures stayed sharp. So it appears to have been narrowed down to OpenLC NA. I submitted a thread at the ORBX support forums so I guess I won't be able to use OpenLC NA for now.

 

Wow strange wonder if its a library order thing shouldnt be if your using P3D - are you using P3D - good you asked them - they will sort it out


Rich Sennett

               

Share this post


Link to post

I got it all sorted it seems. I was told to try forcing a new migration in the troubleshooting tab of FTX Central. I did that and re-checked OpenLC NA in the scenery library and did a quick test flight with no more blurred out ground textures past the initial LOD load. So to the original poster, give that a try if you have some ORBX landclass addons installed.


Is it done yet? When will it be released? Will it be freeware or payware? How much will it cost? Any updates on the progress? Will it work for Xbox? Can I be a beta tester? How's the performance in VR?

Share this post


Link to post

I got it all sorted it seems. I was told to try forcing a new migration in the troubleshooting tab of FTX Central. I did that and re-checked OpenLC NA in the scenery library and did a quick test flight with no more blurred out ground textures past the initial LOD load. So to the original poster, give that a try if you have some ORBX landclass addons installed.

As the other members suggest, you still need to set up the correct AM.....do a search for posts from "SteveW"....the AM you set depends upon a lot of variables and helps tremendously with texture loading. Can also impact it negatively if set incorrectly....I use 249 with 4 core HT on....


Peter Webber

Prepar3D v5 & MSFS / Windows 10 Home Edition / CPU i7-7700K / MSI Z270 XPower Gaming Titanium / Samsung 970 EVO PLUS M.2 500GB / Corsair Vengeance DDR4 32GB 3000MHz / MSI Geforce GTX 1080Ti Gaming X

Share this post


Link to post

I was using AM 84. I commented the AM out in the cfg and got normal texture loading and smooth FPS.


"I am the Master of the Fist!" -Akuma
 

Share this post


Link to post

I was using AM 84. I commented the AM out in the cfg and got normal texture loading and smooth FPS.

Maybe your setting was incorrect...what processor and do you have HT enabled?


Peter Webber

Prepar3D v5 & MSFS / Windows 10 Home Edition / CPU i7-7700K / MSI Z270 XPower Gaming Titanium / Samsung 970 EVO PLUS M.2 500GB / Corsair Vengeance DDR4 32GB 3000MHz / MSI Geforce GTX 1080Ti Gaming X

Share this post


Link to post
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...