Jump to content
Sign in to follow this  

Recommended Posts

I'm using beta version 5, and I get the error message at the top of my screen: "Resources/plugins/FlyWithLua/Scripts/Ventury_sky_beta_5.lua:178:attempted to compare number with nil" and "lua stopped!". To install all I did was place the Ventura script in the Lua/Scripts folder. I have the latest version of Skymaxx and NOAA, and both are running properly. This happened to me with beta 3 as well. 

 

Edit: Also, I like the sky colors, especially the subtle sunrise/sunset (most other sets overdo this). However, could you edit them so that there's less 'white', at least when sitting at ground level? In real life, the blue extends almost all the way down to the horizon. The first shot is your set, and the second is a set that, IMO, looks much closer to reality (I'm having other problems with my set so I'm looking for a good replacement) 

 

8cbDHBR.png

 

Nw3UnRE.png

Share this post


Link to post
Share on other sites

Strange I get no upper winds using the latest NOAA version clean installation. I know this is not Ventura Sky's fault, but is anyone else experiencing this.


ASUS Maximus VIII Hero Alpha

Intel Core i7 6700K 4.5GHz

Corsair Vengeance Black LPX 32GB

Asus STRIX GTX 1080

Samsung 850 EVO 500GB SSD

Share this post


Link to post
Share on other sites

 

Thank you I will try this later tonight.

 

With this version do I need to make any edits to the pi_noaaweather.py file as per the original Beta 3 version I am currently running or is it a case of somply replaceing my current NOAA plugin with the new version and adding the Beta 5 lua script?

 

Regards

 

Richard


 

 

My Rig: i5 9600K @ 5.0 Ghz Air Cooled (Noctua NH-D15S) | Asus Prime Z390 - A | 32 GB DDR4 3000 | ZOTAC GTX 1080 TI AMP Edition With Double Noctua NF-12 Mod | 1TB WD Blue NMVE (X-Plane 11 & MSFS 2020) | 2 X 250GB SSD | 4TB WD Black Conventional | TCL 43" 4K TV |

 

Share this post


Link to post
Share on other sites

Hi,

have installed  the  pythonscriptsnetinstaller_1.10

copied the PythonInterface

copied the joanpc-XplaneNoaaWeather-2.3-0-g6e812ca

copied the Ventura_Sky_Beta_5.lua

 

.after 5 minutes  my IXEG 737 does,not function anymore :sad:


regards

Jürgen

Boeing777_Banner_Pilot.jpg

Share this post


Link to post
Share on other sites

 

 


The first shot is your set, and the second is a set that, IMO, looks much closer to reality (I'm having other problems with my set so I'm looking for a good replacement) 

 

It looks as you have massively overdone your Maxx XP settings - that sky color set looks nothing like the Ventura Sky set (or any other set). Reset your Maxx FX!

 

Your Lua bug is related to NOAA. What does the status report in the dev console say?


Strange I get no upper winds using the latest NOAA version clean installation. I know this is not Ventura Sky's fault, but is anyone else experiencing this.

 

Any chance that there aren't any upper winds? 


Thank you I will try this later tonight.

 

With this version do I need to make any edits to the pi_noaaweather.py file as per the original Beta 3 version I am currently running or is it a case of somply replaceing my current NOAA plugin with the new version and adding the Beta 5 lua script?

 

Regards

 

Richard

 

No edits required.


Thank you I will try this later tonight.

 

With this version do I need to make any edits to the pi_noaaweather.py file as per the original Beta 3 version I am currently running or is it a case of somply replaceing my current NOAA plugin with the new version and adding the Beta 5 lua script?

 

Regards

 

Richard

 

No edits required.

Share this post


Link to post
Share on other sites

It looks as you have massively overdone your Maxx XP settings - that sky color set looks nothing like the Ventura Sky set (or any other set). Reset your Maxx FX!

 

Your Lua bug is related to NOAA. What does the status report in the dev console say?

 

Any chance that there aren't any upper winds? 

 

No edits required.

 

No edits required.

 

Thank you,

 

Sorry for asking twice. I just want to be sure I do the install correctly :)


 

 

My Rig: i5 9600K @ 5.0 Ghz Air Cooled (Noctua NH-D15S) | Asus Prime Z390 - A | 32 GB DDR4 3000 | ZOTAC GTX 1080 TI AMP Edition With Double Noctua NF-12 Mod | 1TB WD Blue NMVE (X-Plane 11 & MSFS 2020) | 2 X 250GB SSD | 4TB WD Black Conventional | TCL 43" 4K TV |

 

Share this post


Link to post
Share on other sites

It looks as you have massively overdone your Maxx XP settings - that sky color set looks nothing like the Ventura Sky set (or any other set). Reset your Maxx FX!

 

Your Lua bug is related to NOAA. What does the status report in the dev console say?

Yep, I removed my Maxx FX effects and it seems that they were overdone for your sky set- IMO my Maxx FX settings look quite natural, so I'll just continue to use them with my sky. Thanks anyway! :)

 

So, here is the dev console.

 

NYjwp2P.png

 

Keep in mind that I have made 2 edits to NOAA- one to change the URL it gets weather from after the NOAA service shut down, and another to stop crashes I was getting when using the METAR Query box. Could this be the cause? Here is the edit I followed:

 

The mods in bold below fixed the metar window input handler crash for me. Python is not my thing at all, use at your own risk smile.png

 

PI_noaaWeather.py

 

 

import ctypes
import cPickle
import socket
.
.
.
    def metarQueryInputHandler(self, inMessage, inWidget, inParam1, inParam2):
        ''' Override texfield keyboard input to be more friendly'''
        if inMessage == xpMsg_KeyPress:
            key, flags, vkey = PI_GetKeyState(ctypes.c_uint32(inParam1).value)
            if flags == 8:
 

 

Quick Edit: I just tried installing a fresh, unedited version of the NOAA plugin and got a different error. Here is the error+the dev console. Is there any way to use Ventura Sky with my fixed NOAA plugin?

 

PT23JZX.png

Share this post


Link to post
Share on other sites

Any chance that there aren't any upper winds? 

 

I think this must be a bug with NOAA plugin or the METAR source. There was an instance today when I loaded and had no winds at all. I reported this on the official forum and I'm waiting for a response from the developer.


ASUS Maximus VIII Hero Alpha

Intel Core i7 6700K 4.5GHz

Corsair Vengeance Black LPX 32GB

Asus STRIX GTX 1080

Samsung 850 EVO 500GB SSD

Share this post


Link to post
Share on other sites

Just made a flight from LEBL to LEMD with VS beta 5 + NOAA 2.3 ....amazing plugin , great work Robert !

the combo between Ventura Sky + SMP + RWC +NOAA reach a new level to x-plane realism.

it will be great if Ventura Sky will work with FS Global Real Weather ( soon to be updated with turbulence etc)


i9-11900K •  ASUS ROG-STRIX 3090 OC • Asus ROG-Maximus Hero XIII • G.Skill Ripjaws V 64GB DDR4 3600 CL16 • Asus ROG Swift PG279Q 27" Gaming Monitor  • VKB-Sim Gladiator Mk.II • Thrustmaster TCA Quadrant Airbus Edition

Share this post


Link to post
Share on other sites
Guest jlindbe

Looking for some help. Using a MAc when I download beta 5 it ends in .txt. It won't let me delete the .txt to save as a .lua. Any suggestions?

Share this post


Link to post
Share on other sites

Yep, I removed my Maxx FX effects and it seems that they were overdone for your sky set- IMO my Maxx FX settings look quite natural, so I'll just continue to use them with my sky. Thanks anyway! :)

 

So, here is the dev console.

 

NYjwp2P.png

 

Keep in mind that I have made 2 edits to NOAA- one to change the URL it gets weather from after the NOAA service shut down, and another to stop crashes I was getting when using the METAR Query box. Could this be the cause? Here is the edit I followed:

 

The mods in bold below fixed the metar window input handler crash for me. Python is not my thing at all, use at your own risk smile.png

 

PI_noaaWeather.py

 

 

import ctypes
import cPickle
import socket
.
.
.
    def metarQueryInputHandler(self, inMessage, inWidget, inParam1, inParam2):
        ''' Override texfield keyboard input to be more friendly'''
        if inMessage == xpMsg_KeyPress:
            key, flags, vkey = PI_GetKeyState(ctypes.c_uint32(inParam1).value)
            if flags == 8:
 

 

Quick Edit: I just tried installing a fresh, unedited version of the NOAA plugin and got a different error. Here is the error+the dev console. Is there any way to use Ventura Sky with my fixed NOAA plugin?

 

PT23JZX.png

 

Well obviously your bug was caused by not using the latest NOAA version (2.3.0).

 

Your new bug is not related to Ventura Sky, as you can read, it's caused by dazzle.lua, I suspect you have RTH installed, which is incompatible to Ventura Sky. Remove all scripts except Ventura Sky and you will be fine.

 

It makes no sense to use it with a different set of sky colors though, as the atmospheric effects have been aligned with the sky color set. Why don't you use the Maxx FX setting that's in the Beta 3 package?

Share this post


Link to post
Share on other sites
The shadow of clouds at dawn and/or sunsets, cut with lod. Can you solve in any way?

You can see a video: 

Share this post


Link to post
Share on other sites

 

The shadow of clouds at dawn and/or sunsets, cut with lod. Can you solve in any way?
You can see a video: 

 

 

Unfortunately, SMP cloud shadows don't play well with X-Plane's own haze, as they are currently drawn "onto" the haze, while they should be below it, i.e. affected by it. Anomalies will already appear at low altitudes. Frank of Sundog software knows this and I hope they will find a solution in the future - it's not a problem with Ventura Sky, if you use SMP with low visibilities in standard X-Plane, you will get the same result. Therefor I recommend turning off SMP shadows for now - it is a compromise, hopefully it's only temporary.

Share this post


Link to post
Share on other sites

Is there an easy way to toggle this script on and off?  I temporarily disabled NOAA weather (wanted to fly CAVOK), but every time I change the weather settings in the XP menu, they're automatically put back to the real-world weather.  All the tabs in the weather menu seem to be disabled also.  Most of the time, I LOVE this addon, but sometimes I'd still like to be able to set my own weather.  Is this possible?

 

Thanks!


Evan Purcell

Share this post


Link to post
Share on other sites

Is there an easy way to toggle this script on and off?  I temporarily disabled NOAA weather (wanted to fly CAVOK), but every time I change the weather settings in the XP menu, they're automatically put back to the real-world weather.  All the tabs in the weather menu seem to be disabled also.  Most of the time, I LOVE this addon, but sometimes I'd still like to be able to set my own weather.  Is this possible?

 

Thanks!

 

I am afraid that currently, you'll have to remove it from the folder. I'll look into this though.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...