Jump to content

Sign in to follow this  
PaulFWatts

Sound pausing when using 2nd Monitor in P3D

Recommended Posts

Hi,

 

I've done an extensive search but can't find a solution to this problem.

 

How do I stop the sound from pausing when clicking a window on a 2nd monitor with P3D running on the primary display. When I click back on the primary monitor the sounds starts again.

 

I've stoping the simulator pausing on a task switch which is working fine but can't find an option to stop the sound pausing.

 

 


Paul Watts - St Helens, Tasmania, Australia

(i7 6700K, 16Gb, GTX 1080, 50" 4K Monitor, 21" Acer touch screen, Windows 10, Prepar3d, X-Plane, ORBX, Rex (All), ActiveSky)

 

Share this post


Link to post

Have you tried going to Full Screen ?  I have not noticed this issue but I run Full Screen.  

 

Also, make sure you have VSync OFF or your framerates will be cut in half when you undock windows.


Mark W   CYYZ      

My Simhttps://goo.gl/photos/oic45LSoaHKEgU8E9

My Concorde Tutorial Videos available here:  https://www.youtube.com/user/UPS1000
 

 

Share this post


Link to post

Hi MarkW,

 

Thanks for the tip re VSYNC.

 

Unfortunately the sounds pauses in full screen mode as well as in windowed mode when I touch anything on the 2nd display. The simulator is definately not paused just no sound.


I ended up solving this myself.

 

There is a setting under "sound" in settings called "mute sound when losing focus" or something similar which is turned on by default.

 

Unchecking this and restarting P3D solved the problem.


Paul Watts - St Helens, Tasmania, Australia

(i7 6700K, 16Gb, GTX 1080, 50" 4K Monitor, 21" Acer touch screen, Windows 10, Prepar3d, X-Plane, ORBX, Rex (All), ActiveSky)

 

Share this post


Link to post

When the application loses focus, sound is muted by default. Disabling this setting requires editing the Prepar3D.cfg file.

  1. Locate the Prepar3D.cfg file which can be found in the %APPDATA%\Lockheed Martin\Prepar3D v2 folder.
  2. Right click file and click "Open", "Edit", or if prompted choose notepad or your other favorite text editor
  3. In the [uSERINTERFACE] section, add MUTE_ON_LOST_FOCUS=0
  4. To enable muting on lost focus, change it to MUTE_ON_LOST_FOCUS=1
  5. Save the newly updated Prepar3D.cfg

Share this post


Link to post

Thanks jfmitch, appreciated.


Paul Watts - St Helens, Tasmania, Australia

(i7 6700K, 16Gb, GTX 1080, 50" 4K Monitor, 21" Acer touch screen, Windows 10, Prepar3d, X-Plane, ORBX, Rex (All), ActiveSky)

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    22%
    $5,610.00 of $25,000.00 Donate Now
×
×
  • Create New...