Sign in to follow this  
wrightt80

No AI traffic in P3d v2.5 with my traffic 6

Recommended Posts

Hello all,

  I followed Lifetimes post on how to install my traffic 6 for beginners and no AI traffic is showing up.  I have went over the instructions and cant figure out the issue.  I am getting a scenery.cfg file error that Area 120 not found.  Also in My Traffic 6.0 communicator the Traffic data base builder not yet copied is in red.  Not sure if these two are causing the issues?  Any suggestions would help.

 

Thanks,

Matt

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hello Matt.

 

Leave the Communicator "Control Panel" closed.  There is only 2 steps to take when getting MyTraffic 6 set up,  And you can do these 2 steps Manually 

 

===================

 

For Prepar3D V2 

 

Step 1 Simobjects.cfg 

 

Did you Install MyTraffic 6 to the Default Install location of of  C:\MyTraffic Professional ?

 

If you did,  Go to ProgramData \ Lockheed Martin \ Prepar3D V2   Right Click on  simobjects.cfg  Open with <  Notepad

 

Copy and Paste this into your simobjects.cfg.  Notice my last Entry is 8,  So my new with MyTraffic 6 is now  [Entry.9]  You have to adjust this to suit your last Number 

[Entry.9]
Path=C:\MyTraffic Professional\MyTraffic\Aircraft

This is what a Default simobjects.cfg looks like With MyTraffic 6 as well.  Be sure you adjust the Numbering correct going down, 0,1,2,3,4,5,6,7,8,9 and so on  

[Entry.0]
Path=SimObjects\Airplanes
[Entry.1]
Path=SimObjects\Rotorcraft
[Entry.2]
Path=SimObjects\GroundVehicles
[Entry.3]
Path=SimObjects\Boats
[Entry.4]
Path=SimObjects\Animals
[Entry.5]
Path=SimObjects\Misc
[Entry.6]
Path=SimObjects\Submersible
[Entry.7]
Path=SimObjects\Weapons
[Entry.8]
Path=SimObjects\Countermeasures
[Entry.9]
Path=C:\MyTraffic Professional\MyTraffic\Aircraft

You will know if this first Step is done correctly as Prepar3D will take a lot longer to get to the Splash Screen when you Launch it 

 

=================================

 

Step 2  Adding the MyTraffic 6 folder to your scenery library 

 

Start Prepar3D.  Click world (Top Left)  Click Scenery Library.    1 Add Area.  2 and 3 Browse through your Drives and Click MyTraffic,  this is the exact folder that you should add.  4 and Click ok. 

https://farm2.staticflickr.com/1585/24511000569_46c1b6a807_o.png

 

 

Check this -----) The correct folder to add is.............

https://farm2.staticflickr.com/1654/24760907562_6068794c9e_o.png

 

 

Be sure to adjust up your Traffic settings to see Traffic to at least this ,  The more you turn it up the more traffic you will see, Also the heaver it will be on your system

https://farm2.staticflickr.com/1596/24251929793_33620c2b9e_o.png

 

 

Don't forget to Turn Off Default Prepar3D traffic

 

Follow the path of  ►  Your Install Location  ►  Prepar3D v2 ► Scenery  ► World  ►  scenery 

 

Share this post


Link to post

This worked I have AI traffic!

However, I still get the scenery.cfg error

 

SCENERY.CFG file error. Local scenery directory (C:\MyTraffic Professional\SCENERY) in scenery Area. 121 not found. Click OK to continue

 

Thanks,

Matt 

  • Upvote 1

Share this post


Link to post

Good stuff  :smile:

 

Ok 2 things  (Try in this order) 

 

(1) Start Prepar3D.  Click world (Top Left)  Click Scenery Library  Make sure you have Not got another MyTraffic 6 Scenery folder in there,  Identify the correct one and remove the wrong one.  Start Prepar3D,  Message gone ?  If Not..............

 

Or

 

(2)  Go to ProgramData \ Lockheed Martin \ Prepar3D V2   Right Click on  scenery.cfg   Open with <  Notepad    Navigate to  [Area.121] and..............

 

Your corrupt [Area] "might"  look something like this,  Basically Prepar3D is looking for something that's not there,  Its calling on a Path= that's missing

 

As you can this is the Wrong folder you added to your Scenery Library,  You Need to remove this Complete [Area]

 

Carefully remove this Complete [Area]  Leaving the same amount of space between the [Area] over and below

 

(Important) After you do this, Start Prepar3D.  Click world (Top Left)  Click Scenery Library    Just Click Ok  By doing this It will Automatically Renumber your [Area.xxx] in your scenery.cfg correctly 

[Area.121]
Title=MyTraffic
Local=C:\MyTraffic Professional\SCENERY
Layer=121
Active=TRUE
Required=FALSE

Share this post


Link to post

Problem Solved!!  Step 1 did it. I had another version of my traffic 6. 

 

Thanks for your help

 

Matt

  • Upvote 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this