Sign in to follow this  
Paul_

Milviz F-4J/S Phantom II & F-4E Phantom II Not working in P3D

Recommended Posts

Hi everyone

 

I have just installed both the F-4J/S Phantom II & F-4E Phantom II into Prepar3D version 3.4 and as soon as I load either aircraft and get into the cockpit 'Boom' ... the sim crashes straight back to the desktop without any word or warning ... If I load any other aircraft Prepar3D operates absolutely fine so I know it's an issue with the Milviz aircraft

On their website it says it is compatible with Windows 10 and P3D all versions ...

 

Has anyone else experienced this problem and if so is there a fix?

 

Thanking you in advance

 

Paul

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Paul, you need to install the latest versions of the Phantom (1.161007 released yesterday) for it to work. Download it via your sales e-mail. 

 

 

Ian

Share this post


Link to post

Ahhhhh ... a huge thank you Ian ....

 

I'll try that today and let you know

 

Cheers

 

Paul

Share this post


Link to post

Also, asking here isn't really going to get you the "proper" assistance (no offense towards you Ian)...

 

Please read the manual (page ONE) to get info on how to get help.

 

As well, it's critical to make sure you've disabled your AV during download and install of this product.  Also, do make sure to uninstall the previous package.  Also and finally, do make sure you're running the sim as an admin.

 

Thanks

 

C

Share this post


Link to post

Well ... I downloaded the latest version but sadly there are still issues with both aircraft

 

The Phantom F-4JS still crashes the sim back to the desktop so it's unusable....

 

The F4 -E is stable but both ailerons and elevators do not operate

 

Anyone else having this problem?

Share this post


Link to post

You'll need to get on the forums.

 

If you don't do that, you won't get any help.

 

Sorry.

 

C

Share this post


Link to post

Well why can't you help me here?

 

Does it really matter where I ask for help?

 

The Avsim community are a great bunch of very informative people and it's a shame you can't help me out!

Share this post


Link to post

The reason is that we don't support products outside of our forums.  This allows us to avoid having to support people who didn't buy the product.

 

Page one of the manual covers how to go about registering and getting on the support forums.  

 

Response time, even on the weekend(s), is less than 12 hours (usually).

 

Please avail yourself of this.

 

Thanks.

C

Share this post


Link to post

Hi Paul,

 

Email me with your proof of purchase (email or screencap) and preferred forum username and I will get you registered!

 

Best wishes - Kat

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this