Jump to content

Sign in to follow this  
SteveFx

DX10 Cloud Shadows v1.3 and now v1.4

Recommended Posts

I have made a new version of Cloud Shadows available for download - version 1.3.

To Update simply use the URL that you were sent when you purchased to get the new version. Note that this version is delivered as a zip containing the installer, manual and installation notes.

It addresses the two outstanding issues:

  • Shadows on water will move if you change altitude at dusk.
     
  • Hard edged shadowline on hillsides

It also adds a new features

 

  • METAR Option - when shadows cannot be shown (e.g below 1000ft) then the cloud coverage is used for lighting to avoid for example a transition when landing from overcast to full sunlight.   (This is optional and disabled by default)

Autogen was meant to be shaded  but it didn't work in 1.3.  However I have now created  a new build 1.4 in which it does work, so please download it.

  • Upvote 2

Share this post


Link to post
Share on other sites

Dear Steve,

I just purchased your Cloud Shadows utility and FSX ALWAYS crashes at the flight loading screen.

The white loading window with the exclamation mark comes up but the progress bar doesn't show, and FSX crashes with an 'app not responding' message.

I removed all ReShade dll's and files, cleared shader cache, but the only way to load the flight is choosing NOT TO LET dx10SimC.dll run upon sim startup.

 

Unfortunately what the dx10SimC.dll is conflicting with is beyond me.

 

I do own version 3.2 of the Fixer and succesfully followed instructions to install Cloud Shadows.

 

Happy to give you more info on my setup and FSX installation, hoping you can look into this.

 

EDIT: I just completely uninstalled DX10Fixer and Cloud Shadows and will try too see what happens if I re-install them.

So far the presence of the dx10SimC.dll seems to be what is preventing my sim from running.

At my last attempt, even choosing not to run the .dll wouldn't let me start a flight. Had to uninstall the Fixer's library to get in an aircraft. I'm quite puzzled.

Share this post


Link to post
Share on other sites

EDIT: after fully uninstalling both Cloud Shadows and the Fixer and re-installing them back anew, I was finally able to load the sim properly and have cloud shadows display correctly.

 

Sorry for having brought this up in the new version thread.

 

I have a feeling the initial conflict might have been related to ASN16, since the program was giving me strange module messages I had never seen before.

But alas, right now the issue seems solved.Will test a few flights in the next days.

 

p.s the shadows do look excellent, especially over water! Pls keep up the good and essential work, Steve, for us stubborn FSX flyers!

Share this post


Link to post
Share on other sites

Update was easy peasy and the shadows look great!  Thanks Steve! :drinks:

 

Greg

Share this post


Link to post
Share on other sites

Hi Steve,

 

thanks for the update, autogen shading looks great. one thing though, the autogen trees don't seem to shade as well as the buildings, this is expected, right?

 

ag_shadows.jpg

  • Upvote 1

i7-6700k @4.5GHz 16G XMP-3200 | GTX1080ti | 1TSDD | Win10 | TIR | TMCougar | CHyoke/TQ/peds | 55" 4k UHDTV | OR cv1 (HP R-G2) | P3Dv5 MSFS20

 

 

 

Share this post


Link to post
Share on other sites

Oh dear, you are correct.  Indeed its worse than that - the autogen logic isn't working at all!    I have stared at it numerous times and convinced myself that it was working - when it never can have been.

 

Oh well will be fixed in 1.4 then (sorry)

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Steve,

 

thanks for the update, autogen shading looks great. one thing though, the autogen trees don't seem to shade as well as the buildings, this is expected, right?

 

ag_shadows.jpg

 

Curious, what altitude were you at and were you zoomed for this shot?

 

Thanks

 

Greg

 

Share this post


Link to post
Share on other sites

a=2k agl

z=1.5x


i7-6700k @4.5GHz 16G XMP-3200 | GTX1080ti | 1TSDD | Win10 | TIR | TMCougar | CHyoke/TQ/peds | 55" 4k UHDTV | OR cv1 (HP R-G2) | P3Dv5 MSFS20

 

 

 

Share this post


Link to post
Share on other sites

SteveFx, thanks for confirming the autogen shadow issue.  I noticed this too and spent a little time trying to figure out what I did wrong...glad to know it was not something I oops doing.


Rod O.

i7 10700k @5.0, Asus ROG Maximus XII Hero, G.Skill 2x16GB DDR4 3600 cas 14, EVGA GTX 1070 SC, Noctua NH-D15S, Thermaltake GF1 850W PSU, WD Black SN750 M.2 1T (x2), Fractal Design Focus G Case

Win 10 Pro 64, Asus 25" IPS 2K 60Hz monitor

Share this post


Link to post
Share on other sites

Steve, thanks again for a wonderful, revolutionary product for FSX.  I just purchased Shadows this evening.

 

I'm still not quite clear what the METAR option is used for.  It uses local station cloud coverage to determine if the ground should be darker or lighter?


Kyle Weber (Private Pilot, ASEL; Flight Test Engineer)
Check out my repaints and downloads, all right here on AVSIM

Share this post


Link to post
Share on other sites

Kyle, cloud shadows cannot always accurately be generated

e.g. when

a) the aircraft is below 1000 ft or

b) distant mountains,

c) terrain above the aircraft.

 

Without the metars option these areas or scenarios will appear as sunlit.

 

The metars option shades them based on the average cloud coverage.

 

In overcast or broken conditions this will hopefully improve the overall appearance

Share this post


Link to post
Share on other sites

It certainly does Steve and it works like a dream!

 

Now if you could manage tool tips too...ha ha only joking :-)


SOH Staff

Share this post


Link to post
Share on other sites

perfect.

 

ag_shadows.jpg

 

didn't know what i was missing without the ground shadows.

 

 

ag_shadows2.jpg


i7-6700k @4.5GHz 16G XMP-3200 | GTX1080ti | 1TSDD | Win10 | TIR | TMCougar | CHyoke/TQ/peds | 55" 4k UHDTV | OR cv1 (HP R-G2) | P3Dv5 MSFS20

 

 

 

Share this post


Link to post
Share on other sites

Hello Steve,

 

It seems to me that Cloud Shadows version 1.4 breaks the Orbx lights fix, I see no cloud shadows and the lights are back to

black squares.

I have uninstalled version 1.4 but left the Fixer version 3.2 and the black squares are gone again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,170.00 of $25,000.00 Donate Now
×
×
  • Create New...