Recommended Posts

Hello,

 

I have installed the X-plane 11 demo to see if this is a package I want to use besides my Prepar3d. So I'm new to the simulator.

I notice a very low frame rate (around 14 fps) and it tried to lower the settings but actually it does not seem to have any influence (it Always rewmains around the same fps).

 

I think my PC is up to spec (i7 5820K, 16GB memory, GTX980).

 

Am I overlooking something. I'm puzzled because none of the changes I make seem to have any problem. I want to make sure I can fly properly before I purchase the package.

 

Thanks,

 

Paul.

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

As more and more complex addons are loaded on top of any sim, the performance is going to decline.  Enviro-X and related cloud/weather injectors impact XP11 in the same fashion that those types of apps affect FSX and P3d. It's just a matter of time ...

 

Even with a 4 year old system, I always had good performance with XP10, but now with a brand new i7 6700, a GTX 1080 and 32 GB RAM, I can barely pull 25-30 fps. Take away all the addon scenery, the RXP GTN 750, the RWD Turbine Duke, FSGRW and SMP 4 and everything perks right up.

 

It's the user, not the sim.

Share this post


Link to post
Share on other sites

Thanks for the feedback. I changed the setting but it does not make a difference. The FPS Always is around the 15 fps regardless of the settings (like it is limited to this number).

I think my specs are OK so I do not understand why I do not see any change in FPS when making changes to thesettings (not for better and not for worse).

 

CU,

 

Paul.

Share this post


Link to post
Share on other sites

 The simple version is to set everything to minimum and proceed to adjust one setting at a time until you see the framerates dip, then dial it back one notch and move on to the next setting.

LOL That's the best performance guide ever... ;)

Share this post


Link to post
Share on other sites

Are you flying with clouds present? They're 100% density right now and will kill your performance. I guess I should say they could kill your performance. Some people are reporting good performance in clouds. Not me.

 

If we get a cloud density slider like XP10 then we'll be ok.

Share this post


Link to post
Share on other sites

Hello, thanks for the feedback.

 

The issue is that I can make changes in the settings but it seems to have no effect at all. It is Always around 15 fps (give an take 2 frames) like there is a setting which holds the fps back :-). Currently after the last update I can not start X-plane so I can not further check till that is fixed.

Share this post


Link to post
Share on other sites

I would probably put a bug report into laminar with that, as said some users are experiencing low frames regardless of settings, maybe holding off for a few more releases until it's resolved, your hardware shouldn't be giving 15fps

Share this post


Link to post
Share on other sites

i have been an x-plane user for over a year now. in x-plane 10 i get my normal 60 fps on the ground and 90+ in the air with payware planes. x-plane 11 on the other hand i can't get my fps over 30 unless i turn half my sliders down. i keep in mind that this is beta, but each beta that comes out,it does seem to get worse.

Share this post


Link to post
Share on other sites

I find my FPS has plummeted in just a month. I shall wait to see if things improve. VR seems to be getting all the love at this time, so maybe later.

Share this post


Link to post
Share on other sites

hm, can you check if you have "Use Vsync" under Graphics disabled.

It would lock your framerate to the screen frequency. I have never heard it locking to 15, but it is worth checking.

X-plane is both CPU and GPU limited. Can you provide the output of the fps counters ? Press CTRL-Shift-F in flight, it will show up in the left upper corner. It has several outputs, please give them all, then we can see what is holding you back, CPU or GPU.

What is impacting my framerate: 

GPU side:  draw shadows on scenery, Visual Effects (keep it one down from max), Antilalising

CPU side: Reflection Detail: lower reflection, then lower it, then lower it. Reflection has the biggest impact known to me, I think a water cooled hyper overclocked latest gen CPU is still not pulling it.

Good luck.

 

Share this post


Link to post
Share on other sites
3 hours ago, acenickells said:

I find my FPS has plummeted in just a month. I shall wait to see if things improve. VR seems to be getting all the love at this time, so maybe later.

Apart from other suggestions made, you might also just want to try and delete (i.e. move elsewhere/backup and delete) your preferences folder and see if that improves your issues.

  • Upvote 1

Share this post


Link to post
Share on other sites
4 hours ago, acenickells said:

I find my FPS has plummeted in just a month. I shall wait to see if things improve. VR seems to be getting all the love at this time, so maybe later.

So many seem to miss teh point, for VR to work, Laminar have to improve frame rates, its not Just a bout VR. All the improvements to get VR to work improve teh sim for everyone. Thats why so many have reported better frame rates and now AMD cards appear to have got a fix.

  • Like 1
  • Upvote 2

Share this post


Link to post
Share on other sites
On 5/3/2018 at 7:51 PM, jh71 said:

hm, can you check if you have "Use Vsync" under Graphics disabled.

It would lock your framerate to the screen frequency. I have never heard it locking to 15, but it is worth checking.

If you use the standard vsync, it "locks" (synchronises) your framerates to the monitor refresh rate. However, using a 60Hz monitor as an example, if your framerates drop below 60, vsync then "locks" them to 30. If your framerates fall below 30, vsync continues to drop them using fractions of the monitor's refresh rate (30, 20, 15 and so on).

Share this post


Link to post
Share on other sites
12 hours ago, vortex681 said:

If you use the standard vsync, it "locks" (synchronises) your framerates to the monitor refresh rate. However, using a 60Hz monitor as an example, if your framerates drop below 60, vsync then "locks" them to 30. If your framerates fall below 30, vsync continues to drop them using fractions of the monitor's refresh rate (30, 20, 15 and so on).

Well there you go.   Nicely explained.  Lots of folks see this phenomena.

Share this post


Link to post
Share on other sites
Posted (edited)
On 1/6/2017 at 11:27 PM, Mountain Man said:

The online manual has instructions on how to optimize performance:

 

http://x-plane.com/manuals/desktop/#configuringtherenderingoptions

 

The simple version is to set everything to minimum and proceed to adjust one setting at a time until you see the framerates dip, then dial it back one notch and move on to the next setting.

Yep I went from 20-23 fps and tried everything and then methodical followed the guide and am 30-35fps testing using default 747

Edited by zmak

Share this post


Link to post
Share on other sites
14 hours ago, vortex681 said:

If you use the standard vsync, it "locks" (synchronises) your framerates to the monitor refresh rate. However, using a 60Hz monitor as an example, if your framerates drop below 60, vsync then "locks" them to 30. If your framerates fall below 30, vsync continues to drop them using fractions of the monitor's refresh rate (30, 20, 15 and so on).

Is it best not to use V sync if frames are at 30 or below?

Share this post


Link to post
Share on other sites
2 hours ago, zmak said:

Is it best not to use V sync if frames are at 30 or below?

v sync helps with screen tearing, but not much else. I think most people leave it unchecked.

  • Upvote 1

Share this post


Link to post
Share on other sites

I use vsync locked at 1/2 refresh rate through the nvidia options. This locks my frame rate to 30 (on a 60hz monitor). As I don't care about VR or TrackIR, I hardly see any advantages of going above 30fps and this option leads to very smooth visuals on my system.

Share this post


Link to post
Share on other sites
36 minutes ago, mgeiss said:

I use vsync locked at 1/2 refresh rate through the nvidia options. This locks my frame rate to 30 (on a 60hz monitor). As I don't care about VR or TrackIR, I hardly see any advantages of going above 30fps and this option leads to very smooth visuals on my system.

The problem is if you go below 30, then it halves your framerate to 15. If you overload, then it becomes unplayable. If you can not maintain 30 or higher, then it is best to disable this option.

Share this post


Link to post
Share on other sites

If you set vsync within the driver to "adaptive", it will automatically disable vsync if you drop below the intended value (at least that's how I understand the option). However, I'd rather lower all eye candy options before allowing the sim to go below 30 fps.

Share this post


Link to post
Share on other sites

I have the latest X-Plane 11 Update. I run XEnviro on easy mode. I have ReShade latest version which I have the preset "Sharpness Clear Technicolor standard HDR.ini and ColournessFull ticked. The X-Plane sliders Visual effects on Minimal. Texture Quality on  Minimal and Antaliasing  on 8X. My frame rate was very poor between 15 to 20 max. When I installed the above listed and made the adjustments as set out my frame rate jumped to between 30 to 35 with awesome quality in the picture. i hope this is of some help as I was totally frustrated with the frame rate on installing XEnviro. 

Share this post


Link to post
Share on other sites
On 5/8/2018 at 1:41 PM, mgeiss said:

I use vsync locked at 1/2 refresh rate through the nvidia options. This locks my frame rate to 30 (on a 60hz monitor). As I don't care about VR or TrackIR, I hardly see any advantages of going above 30fps and this option leads to very smooth visuals on my system.

2

For years now, this has been THE setting to run X-Plane with. Sad it's not the officially promoted mode by Laminar (I think they could add it to the settings if they wanted to). So many inexperienced uses struggle with stutters (sync related, not performance). There's simply no other way to achieve the smoothness this mode offers - if your settings allow you to run the simulator at or above 30fps.

 

On 5/8/2018 at 2:19 PM, jh71 said:

The problem is if you go below 30, then it halves your framerate to 15. If you overload, then it becomes unplayable. If you can not maintain 30 or higher, then it is best to disable this option.

That is false information. Using "vsync locked at 1/2 refresh rate" setting, frames will drop below 30 to whatever you're capable of running, there is no "switch" to 15 FPS. Check your settings. But of course yes, the setting becomes useless if you can't maintain 30 FPS.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now