Sign in to follow this  
Mephic

Performance hit with one of the tweaks

Recommended Posts

HI 

 

Not sure which tweak causes it, but I get significant performance drop (FPS) when using PTA in overcast conditions when it's sunrise or sunset. (must be something related to cloud shadows). It causes even 50% FPS hit, not sure why. Which tweak might it be? 

  • Upvote 1

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It causes even 50% FPS hit, not sure why. Which tweak might it be?

Hi Tomasz

I've tested the overcast conditions and found that FPS drops caused by "Clouds shadows Extended size" tweak. I'll add a notice to the tweak description.

Thanks a lot for the feedback!

 

Here some screenshots (4K resolution monitor, i6700K@4.5GHz, DDR4 3200 16GB, GTX1080 OC, P3D on Samsung 850 Pro SSD):

 

my PTA preset is active (with "Clouds shadows Extended size" tweak is ON) :

 

 

Tweakedday_5488215_24765065.jpg

Tweakedtwi_9170641_24765064.jpg

 

 

 

my PTA preset is active (WITHOUT "Clouds shadows Extended size" tweak) :

 

 

Tweakedday_3751374_24765179.jpg

Tweakedtwi_5162452_24765066.jpg

 

 

 

Please note also that removing this adjustment from your preset does not mean that you get the same FPS at noon and twilight (when the shadows become huge due to low sun altitude).

The significant FPS drop in overcast conditions when it's sunrise or sunset and "Enable terrain receive shadows" setting is ON is a P3D feature by design.

 

Here is the default P3D (no PTA or another tweaks):

 

 

Defaultday_3306130_24765068.jpg

Defaulttwi_8517582_24765069.jpg

 

 

 

regards,

Share this post


Link to post
Share on other sites

I forgot about it as I rebuilt my cfg. It's easy to be fixed. All that needs to be modified is ground shadow texture size in p3d cfg (I think default is 512 or 1024, after changing it to 256 performance goes up! )

Share this post


Link to post
Share on other sites

Great!

After altering CLOUD_SHADOW_TEXTURE_SIZE to 256 instead of 512 I got FPS boost from 23 to 37 at the same conditions (overcast + twilight) with tweak "Clouds shadows Extended size" is ON.

Degradation in the shadows rendering with 256 is not noticed so far.

Thanks for the tip!

Share this post


Link to post
Share on other sites

Yes, I remember I found this fix on HiFi (AS16) forum. They were really helpful back then, glad it helped you too! 

Share this post


Link to post
Share on other sites

Great!

After altering CLOUD_SHADOW_TEXTURE_SIZE to 256 instead of 512 I got FPS boost from 23 to 37 at the same conditions (overcast + twilight) with tweak "Clouds shadows Extended size" is ON.

Degradation in the shadows rendering with 256 is not noticed so far.

Thanks for the tip!

Hi Yuri,

 

is this found in the P3D.cfg file? I'm having similar problems with overcast conditions and this could be the answer to my problems lol. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this