Sign in to follow this  
bonchie

Prepar3D lagging, freezing my computer after a few minutes

Recommended Posts

Never had this issue before. Went to install P3D 3.4 (complete install) and now no matter what I do, after a few minutes in-game the whole computer starts to lag, eventually all but freezes (not totally, but it's unusable) and the symptoms last even after P3D is closed or crashes. I have to hard reset to make the computer usable again.

 

I can confirm no other application, including stress testing of the various components causes this so it has to be something with P3D interacting with the OS or a driver.

 

Things I've tried and confirmed aren't the issue:

 

1) Different versions of P3D all do it

2) Multiple reinstalls do not fix it

3) Having zero addons installed does not fix it

4) It's not a hardware issue and only P3D elicits this issue

5) Updated display driver and nothing

6) Turned off NI completely and no difference

7) Deleting shaders, cfgs, etc. does not fix it

 

I've tried everything that's obvious. I need to know if someone else has had this issue before and whether they were able to rectify it.

 

My suspicion is that it has something to do with the GPU and P3D. So my next step is to try some legacy drivers. The last variable here, and probably the most likely culprit, is that I've upgraded to Windows 10 since I last installed P3D. But, the migrated former install of P3D 3.2 worked fine until I went to try to do a full install of 3.4.


Other things I've found. Event Viewer shows a bunch of search service and gatherer errors all in a row after I start P3D. 

I'm trying to ascertain exactly what that means, but it's possible P3D is causing the indexing to go nuts and freeze the computer. What the solution would be (besides just turning the Windows Search service off), I'm not sure, yet.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi,

 

I know you've said it's not a hardware issue, but have you tried eliminating USB connection problems as well? I had a very similar issue once, and it turned out it was my Saitek Trim Wheel not being recognized properly. The moment I started trimming after takeoff, P3D and the OS would become unresponsive, requiring a hard reset. Probably a long shot, but it's another angle you might explore...

 

Tym

Share this post


Link to post

I've only got a joystick and a mouse going USB, but I'll check the joystick. Your suggestion seems possible.

 

What did you do to fix your trim wheel? Just re-plug in it?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this