Jump to content
Sign in to follow this  

VSync not working in FSX only

Recommended Posts

Hello people,


I already asked this question in the MS FSX forum, but nobody seems to be able to help me.


Remember the VSync 1/2 refresh rate discovery a few years ago, with the new levels of smoothness it would get us? A topic about this was posted here a few years ago. Basically this option would allow us to run FSX smoothly and fluidly, and of course eliminate the tearing. It's simple: if you can maintain 30 FPS at least, you can enable VSync 1/2 refresh rate in NVIDIA Inspector (for 60 Hz monitors), and get a super smooth FSX.


Without it, FSX should run pretty smoothly too (it does on my system), but it's just not the same smoothness as VSync 1/2 refresh rate)


Anyway, the problem: I always used to run this VSync 1/2 configuration a few years ago. It always worked fine and would make FSX that extra bit smoother. Back in 2014 I left this hobby on the back-burner for a while. But recently I started flying again, and updated all my add-ons and drivers. The only thing that changed in the mean time was my upgrade to Windows 10. I did a few flights, and FSX worked just fine, no crashes, no glitches. But due to new driver installs, I lost my NVIDIA Inspector settings. Of course, I wanted to reconfigure NVIDIA Inspector and the AA settings. So there I went, I re-configured it, fired up FSX, and noticed my AA settings were just fine, just like a few years ago. But I noticed my frames were running unlimited, and not at 30. Yes, I know, this VSync 1/2 tweak works best with the FSX internal FPS limiter, but without it FSX shouldn't be running at random FPS. It should rather hop between 30 and a random FPS number all the time. It should at least make an attempt to maintain 30 FPS, but it clearly wasn't. Tried with 30 FPS internal limiter, and the smoothness I was used to wasn't really there. I also saw no input lag, and some tearing. So VSync wasn't working.


Re-checked my settings:



I don't see what I did wrong.


Then I tried to apply similar settings to GTA V, and guess what? VSync 1/2 works perfectly fine there! I don't normally use these settings in GTA V, but it was just a test to see if it was exclusive to FSX. And it is. 


So I started troubleshooting:

- Disabled NVIDIA Inspector and tried via the regular NVIDIA Control Panel (Adaptive VSync (half refresh rate)

- Deleted the NVIDIA driver and deleted all folders and registry entries, then reinstalled the newest driver

- Updated Windows

- Deleted fsx.CFG and let FSX rebuilt the default one

- Checked if FSX was running as administrator

- Tried standard VSync, Adaptive VSync, normal refresh rate, half refresh rate, 1/4 refresh rate. VSync just won't apply.

- Re-added the fsx.exe executable to the NVIDIA Inspector software and NVIDIA Control Panel

- Tried Flight1 registry fixer tool

- Did a virus scan

- Tried older drivers from 2013 and 2014, of which I knew they used to work with FSX and VSync 1/2.


Everything to no avail.


Are any settings in FSX, or outside FSX, that could possibly prevent VSync from applying?


System specs:

Windows 10
Asus P8Z68-V Pro

i5 2500K @ 4.6

Asus GTX 670 2 GB
Corsair 8 GB DDR3 2133 MHz
Crucial m4 128 GB (Windows)
OCZ Vertex 4 128 GB (FSX)

WD Caviar Black 1 TB
OCZ 700W

Monitor: Asus VS278Q 27" 60 Hz 1080p

Arjen Vandervelde

Share this post

Link to post
Share on other sites

I had this exact same thing happen to me, with the exception I was using windows 7. 


It is not the nvidia or fsx settings...  Its some strange issue with windows aero if you can re-enable it, the screen tearing should go away.

Flight Simulator's - Prepar3d V5.3/MSFS2020 | Operating System - WIN 10 | Main Board - GIGABYTE Z390 AORUS PRO | CPU - INTEL 9700k (5.0Ghz) | RAM - VIPER 32Gig DDR4 4000Mhz | Video Card - EVGA RTX3090 FTW3 ULTRA Monitor - DELL 38" ULTRAWIDE | Case - CORSAIR 750D FULL TOWER | CPU Cooling - CORSAIR H150i Elite Push/Pull | Power Supply - EVGA 1000 G+ 

Share this post

Link to post
Share on other sites

Why do you have frame rate limiter off? I have @ 30 even if you use in sim.

Asus Rampage VI Extreme Encore(water Cooled) EVGA RTX 3090 FTW3 Hybrid, 64 DD4 @ 2800 2 x 2x M.2 in raid 0.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online

  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Create New...