Sign in to follow this  
macpilot

Why Is It So Hard To Get simconnect to work with ASN & Others

Recommended Posts

Before I'm told to post this in the Simconnect forum.

 

I have referenced the ASN manual. Followed all the steps. Sharing of proper folders on Server. Made all the changes to the simconnect files. Made changes to those files based on information from AVSIM's P3d document. The weather gets downloaded to ASN on the client. But still get the message "waiting for simulator" I have obviously missed something. But I get no errors to give me a clue. Just the "Waiting for Simulator".

 

I know my IP address is correct as WideFS works fine on client.

 

I would appreciate any suggestions on how to make this work.

 

Windows 10

ASN with SP 5 for P3d build 6197

Current version of P3d 3.4.18.19475

 

Thank You.

 

Bill McCracken

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Restart both machines after making any changes and check that the shares and mappings are connected which should be the case if the ASN machine is booted second

 

Checklist:

 

Same login on both computers

Same work group on both computers Win7 defaults to MShome Win10 uses a different name, a common thing that catches folk out

Folders shared on the P3D machine and mapped to them from the ASN machine

Running P3D and ASN as Administrator

All simconnect.msi's installed on the P3D machine from \Prepar3D v3\redist\Interface\

ASConnect_P3D_Install.exe copied across to the P3D root directory and run therefore adding the following to the end of your dll.xml

 

 

<Launch.Addon>
    <Name>as_connect</Name>
    <Disabled>False</Disabled>
    <ManualLoad>False</ManualLoad>
    <Path>as_srv\as_btstrp.dll</Path>
  </Launch.Addon>

 

And the following to your exe.xml

 

<Launch.Addon>
    <Name>as_btstrp_config_manager</Name>
    <Disabled>False</Disabled>
    <Path>as_srv\as_btstrp_config_manager.exe</Path>
  </Launch.Addon>

 

P3D machine:

 

C:\Users\yourname\AppData\Roaming\Lockheed Martin\Prepar3D v3\SimConnect.xml

 

Notice I use the machine name rather than the IP address, saves having to set a permanent IP address  on the P3D machine much easier and DHCP can still work normally

 

<SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <Address>desktop</Address>
    <MaxClients>64</MaxClients>
    <Port>6811</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>Auto</Protocol>
    <Scope>Global</Scope>
  </SimConnect.Comm>

<SimConnect.Comm>
<Disabled>False</Disabled>
<Protocol>Auto</Protocol>
<Scope>local</Scope>
</SimConnect.Comm>
</SimBase.Document

 

 

ASN machine:

 

C:\USERS\yourname\Documents\SimConnect.cfg

 

[simConnect]
Protocol=IPv4
Address=desktop
Port=6811
MaxReceiveSize=4096
DisableNagle=0

Share this post


Link to post
Share on other sites

Hello Bill,

 

If you are still having issues after going through Glynn's checklist please open a support ticket at the link below and provide a copy fo your AS_Log from the machine running AS as well as your SimConnect config files from both the P3D and AS computer. 

 

http://hifisupport.kayako.com/Tickets/Submit

 

Thanks! 

Share this post


Link to post
Share on other sites

On another note try this also after a failed connection is you are 100% sure your config is cirrect.

 

From Windows Control Panel on your Server Machine under Homegroup, please make sure you are logged onto your Homegroup from your Server machine and your Client Machine and run the Homegroup Network Troubleshooter from the server.
This will refresh your Windows Network settings information if anything has changed or has become corrupt.

Share this post


Link to post
Share on other sites

Thanks everyone. I'll try all your suggestions and let you know the results.

 

I appreciate the quick replies.

 

Bill McCracken 

Share this post


Link to post
Share on other sites

McLaren,

 

I have tried some of Glynn's suggestions but my dll.xml file did not contain the ManualLoad line as he showed. It allowed me to insert the line but would not let me save it. What I would like to do is open a ticket and send you the files. But, I can't find the AS_Log on either the server or client.

 

Can you please advise.

 

Thank You.

 

Bill McCracken

Share this post


Link to post
Share on other sites

The Log file(s) can be found on the ASN PC at:

 

C:\Users\YOUR USER NAME\AppData\Roaming\Hifi\ASNP3D

 

Thanks! 

Share this post


Link to post
Share on other sites

McLaren,

 

I created a ticket as you suggested. With files attached. Log files from both Server and Client. Plus others.

 

Thank You.

 

Bill McCracken

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this