Sign in to follow this  
abdelsa

Error with P3D 3.4.22.19868

Recommended Posts

Hi,

 

I've a problem with RAAS and the updated P3D 3.4.22.19868

 

This is the report:

 

Log Name:      Application
Source:        SideBySide
Date:          02/02/2017 14:39:53
Event ID:      33
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      ARSotolongoDell
Description:
Activation context generation failed for "C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\RAASPRO\RAASPRO.dll". Dependent Assembly Microsoft.FlightSimulator.SimConnect ,processorArchitecture="x86",publicKeyToken="67c7c14424d61b5b",type="win32",version="10.0.60905.0" could not be found. Please use sxstrace.exe for detailed diagnosis.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="SideBySide" />
    <EventID Qualifiers="49409">33</EventID>
    <Level>2</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2017-02-02T13:39:53.196734200Z" />
    <EventRecordID>28576</EventRecordID>
    <Channel>Application</Channel>
    <Computer>ARSotolongoDell</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Microsoft.FlightSimulator.SimConnect&#x20;,processorArchitecture="x86",publicKeyToken="67c7c14424d61b5b",type="win32",version="10.0.60905.0"</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\RAASPRO\RAASPRO.dll</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

 

 

 

This problem seems to produce an error with FSUIPC (I'm in contact with Pete Dowson on his forum because of this) and the cause is that RAAS through SimConnect appears to be trying to call it (FSUIPC) before it is loaded properly, wich provoque a Fatal Error at P3D start up.

I unninstalled RAASPRO and the problem disappeared.

 

Any idea to fix it?

 

Thanks Bryan, I'm waiting impatiently your new FS2Crew 747 QOTS II.

 

AR Sotolongo Abella

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi AR,

 

Never seen that one before.  

 

Try re-installing RAAS, but ensure your anti-virus is off and excluding the P3D folder.

 

Did you install the legacy Simconnet SDKs?

Share this post


Link to post
Share on other sites

Hi AR,

 

Never seen that one before.  

 

Try re-installing RAAS, but ensure your anti-virus is off and excluding the P3D folder.

 

Did you install the legacy Simconnet SDKs?

Hi Bryan,

I have no other Simconnect installed but the default one, no even SDKs.

 

I've to say that I thought it was an FSUIPC problem, and posted in Pete Dowson forum, and something he wrote forced me to look an error before the crash, and I saw the RAAS doble error there.

 

I did a fresh installation yesterday noon with RAAS 2.6.10.2 version, and the the error came again, after uninstall RAAS the error was gone.

This is the report with the new install:

 

Activation context generation failed for "C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\RAASPRO\RAASPRO.dll". Dependent Assembly Microsoft.FlightSimulator.SimConnect ,processorArchitecture="x86",publicKeyToken="67c7c14424d61b5b",type="win32",version="10.0.61242.0" could not be found. Please use sxstrace.exe for detailed diagnosis.

 

My simconnect version is 10.0.61242.0, is that a correct one?

 

Any idea on how to fix it?

 

Thanks.

Share this post


Link to post
Share on other sites

Try running the legacy SDKs found here:

 

C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\redist\Interface

 

 

Let me know.

 

Best,

Share this post


Link to post
Share on other sites

Hi,

 

with the Legacy installed, fresh install of RAAS the problem is back:

 

Activation context generation failed for "C:\Program Files (x86)\Lockheed Martin\Prepar3D v3\RAASPRO\RAASPRO.dll". Dependent Assembly Microsoft.FlightSimulator.SimConnect ,processorArchitecture="x86",publicKeyToken="67c7c14424d61b5b",type="win32",version="10.0.61242.0" could not be found. Please use sxstrace.exe for detailed diagnosis.

 

is any new version of simconnect than the 10.061242.0? Is it updated?

Share this post


Link to post
Share on other sites

Hi,

 

It's solved now. After reinstall simconnect 10.0.61259 the problem is gone.

 

Thank you.

 

Bests,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this