YoYo

PTA with HDR=off, dark outside question

Recommended Posts

Hello Yuri (and the others),

I'm working on preset with HDR=off ( hdr on costs me few fps always and Id like to have stable 60 :] ) but when is dark outside I still have a problem, too colorful. Please see this screenies.

I use Post Processing effects BUT for all I set up = 1 (so day only in DayNightUse option). It looks like they are working still.

Nowy-3JPG_awqqwra.jpg

Time 00:00. 

Post processing effect with DayNightUse=1

Prepar3D-_awqqwnx.jpg

But here is better, Post processing effects off by Scroll Lock key (default ReShade key to turn on/off post processing).

Prepar3D-_awqqwne.jpg

A lot of better. So is it work again (DayNightUse=1)?

 

My preset: https://www.sendspace.com/file/9x4a21 .

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

47 minutes ago, YoYo said:

So is it work again (DayNightUse=1)?

Hi

Yes, DayNightUse parameter works as described. Thanks for preset, I've tested it:

screenshot with your preset:

Spoiler

day4jpg_9511714_25347106.jpg

Then I change DayNightUse for Curves to 0 (effect is active all the time) :

 

Spoiler

day0jpg_4062505_25347107.jpg

 

And I'm not sure that I understood about Reshade. Are you using Reshade and PTA at the same time and the same post-processing effects?

Share this post


Link to post
Share on other sites
2 hours ago, KNOSSOS said:

Hi

 

  Hide contents

 

Then I change DayNightUse for Curves to 0 (effect is active all the time) :

 

  Hide contents

 

And I'm not sure that I understood about Reshade. Are you using Reshade and PTA at the same time and the same post-processing effects?

No, only PTA, but Your post processing effect (HDR=off) use ReShade, Im right?

I have d3d9.dll in main folder of P3D.

Just do a little different test if You have time ;).

Settings, all in this middle window Day night use=1 (so use day only), use option Custom post processing only like this:

Beztytulu_asppeah.jpg

Take a night and use Scroll Lock key to turn on/off to see difference (clouds must be present also). If the difference it presents, post processing still work.

HDR off in P3D.

Share this post


Link to post
Share on other sites
19 minutes ago, YoYo said:

No, only PTA, but Your post processing effect (HDR=off) use ReShade, Im right?

I have d3d9.dll in main folder of P3D.

No, PTA contains post-effects shaders converted from Reshade to native P3D rendering pipeline (they added to HDR shader). It doesn't require Reshade (or hacked d3d9.dll / dxgi.dll) at all.

So it seems you're using post-processing twice: PTA + Reshade. 

Share this post


Link to post
Share on other sites

Hmmm, I'm confused :D :

Nowy-2JPG_asppwqa.jpg

Before Your PTA I had Reshade but I was thinking I removed all reshade files. So maybe not. Ok, I'll check it again what's going on.

Thank You.

 

 

Share this post


Link to post
Share on other sites

I checked few options. It dosen't work now (post processing like sharpen textures, boost of colours ect.).

I see changes when I take HDR=on in P3D settings only, with HDR=off no any difference.

In Custom settings I have checked "Turn off Prepar 3D HDR" (In the sim the same).

 

Hardcore settings test:

HDR=off, post processing dosen't work:

Image-068_asphpxn.jpg

HDR=on, it works:

Image-067_asphpne.jpg

 

Share this post


Link to post
Share on other sites
1 hour ago, YoYo said:

 

Доброе утро Yuri!

My default.ini: https://www.sendspace.com/file/08a197 .

According info post processing could work with HDR=off in P3D if we check Turn off Prepar 3D HDR but it dosen't.

 

Хаюшки, камрад!

Quote

IMPORTANT: To use post-processing, you SHOULD turn on HDR Lighting option in sim. However, if you don't use Prepar3D HDR Lighting and only need post-processing, you may set "Turn off Prepar3D HDR" checkbox.

You're right. To use post-processing you need to keep HDR = on in sim. But "Turn off Prepar3D HDR" checkbox allows you to switch off HDR code if you don't like it. 

Cheers,

Share this post


Link to post
Share on other sites

Thx Yuri, now its clear, my foul. Im working now with new preset with HDR=on in the sim and off in PTA.

Share this post


Link to post
Share on other sites

 

Hi, 

After many tests I decided to do PTA with HDR=OFF (in P3D - it saves fps a lot) but + add ReShade.

Here result of the preset for PTA 2.11:

Prepar3D-_asahaax.jpg Prepar3D-_asahaap.jpg Prepar3D-_asahaah.jpg Prepar3D-_asahasa.jpg

  • Upvote 2

Share this post


Link to post
Share on other sites

Wow! Looking great! Very realistic and balanced shots/videos. REX clouds and sky?

Share this post


Link to post
Share on other sites

I agree with Yuri  - These settings look stunning!

Are you only using ReShade to add HDR, or are you adding other effects?

If you are adding other effects can you please share some details of your settings and the sky/cloud textures that you are using? 

Thanks,

Dave

Share this post


Link to post
Share on other sites
On 3/27/2017 at 5:37 PM, YoYo said:

 

Hi, 

After many tests I decided to do PTA with HDR=OFF (in P3D - it saves fps a lot) but + add ReShade.

Here result of the preset for PTA 2.11:

looks fantastic. any chance to get the presets?

Share this post


Link to post
Share on other sites

Yes, sorry I will add it. Id like to add "Deband option". Nice filter for the sky.

Prepar3D-_aarpxep.jpg

Prepar3D-_aarpxex.jpg

 

Share this post


Link to post
Share on other sites

I was too using HDR option all the time then once try without it and... now I can't really go back.

Look more realistic to me.

But I'm not a fan of reshade tbh, it does have quite a habit of crashing the game and uninstalling is a mess.

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now