Captain Z

1.660 alpha exp broke a lot of stuff......

Recommended Posts

So, was getting ready to fly tonight......started up Chaseplane.....it downloaded the latest build. And with this latest build, the main things I use chaseplane for no longer work.

Those things are looking around the cockpit, and switching between the views I created in the cockpit.

Every time (and I mean every single time) I try to look around the cockpit with the mouse now, it instantly drops straight down, then back up again.

I never had this problem before, I could smoothly pan around with the mouse whenever I wanted. Now, the moment I use the mouse, the cursor drops to the bottom of the screen instantly, my view is of the seat.

I could avoid the mouse for now, and just use my hat switch, which is also set up to pan around, but then there's the view switching......

Whenever I try to switch views (the plane I was in only has 2, pilots seat view, and view of the GPS) it goes to some random outside view first, then back in to the view it's switching to.

It does this whether I cycle or select directly. Outside the plane, then back in. Outside the plane, then back in. These are the most basic functions I use, and both are totally fubar now.

It's possible that a rollback may be in order, until the kinks are worked out of this latest build. The previous build, everything seemed to work fine, with the exception of hat switch + track aircraft (but that's never worked.....yet).

Anyways, I guess I'm cancelling my flight tonight, as I can't successfully look around the cockpit, or change views. Hope this gets fixed or rolled back quick. Thank you. Still love CP, but latest build really screwed the pooch. :biggrin:

All right, so I figured things out, and the pooch is not screwed. It's been a while since this has happened with a new build, but for some reason, control assignments long deleted in P3D reappeared.

All the issues were caused by view assignments being active in both chaseplane and P3D, like mouse look. Once removed from P3D, the cursor no longer dropped to the bottom of screen, and switching views worked.

I apologize for the post, but I did a lot of troubleshooting before writing this initially, and I thought I had covered everything. It didn't occur to me to check for phantom view assingments reappearing in P3D's options until I had already posted this.

So, things are flyable again. That leaves the only issue I have with CP (not a deal breaker, or anything) is being able to use my hat switch to pan around the plane. I have the hat switch set up in chaseplane, and all works well.

I can look around all my internal views with the hat switch. I can look around all my external views with the hat switch. But if I turn on track aircraft for any of the external views, only the mouse will move the camera around, not the hat switch.

So, that ends up being the only thing I have seen that (still) doesn't work with the latest build. Not a deal breaker, of course....just the last thing on my wishlist...being able to pan around my aircraft with the hat switch.

Again, I'm sorry about the initial post. I tried restarting CP, setting up new views, all sorts of stuff to no avail, before posting this. I just didn't think to check that P3D setting were changed with the update.

Thank you.

Edited by Captain Z
Situation changed

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

For future ref you can always switch back to 1.0 from 1.5 (experimental) you can even do this whilst in flight, as I did yesterday  (to prove a point) video available.:cool:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now