rsrandazzo

[13MAR17] [UPDATED] Faults when running the Operations Center and/or the OC based Product Updaters AND WHAT TO DO...

117 posts in this topic

Captains,

With the release of the PMDG 747-400 Queen of the Skies II we have put a product to market that uses more modern development tools than our previous product lines.  This, plus the changes in operating systems that have gone on during the previous couple of years have caused a bit of confusion for some users who can't seem to get the Operations Center to run, or the newly implemented internal product updaters for the 747 product line.

The solution for the vast majority of users has been to follow through with these steps:

PROBLEM:  OPERATIONS CENTER WILL NOT RUN

Navigate to <programs x86>/PMDG Operations Center

Delete everything in the directory EXCEPT OpsCenterUpdater.exe

Run OpsCenterUpdater.exe

Run the Operations Center normally.

You should now be running the most current version of the PMDG Operations Center.

PROBLEM: USER RUNS 747 PRODUCT UPDATER AND GETS AN ERROR REPORTING MSCVRT140.DLL AS THE FAILURE POINT:

Go to this page https://www.microsoft.com/en-gb/download/details.aspx?id=48145

Click DOWNLOAD

CHOOSE THE x86 VERSION WHEN OFFERED.  (It doesn't matter that you have an x64 operating system, the application you need to run is not an x64 application, so you need the x86 run-time)

Run the Microsoft installer downloaded in the previous step.

OPTIONAL: If you are on an x64 version of Windows and you like to keep things neat and clean, go back and download the x64 runtime and install that too.  It will save you headaches later with x64 applications.

Run the Operations Center normally and try the updater again.

As we have worked with customers via support we have found that following through these two processes has cured nearly all of the problems that have been reported.  This is simply an offshoot of confusion between operating systems and applications that rely upon newer runtimes than some users have installed.  (The 747 SHOULD be installing the runtimes...  We are investigating that avenue still...)

One other random item for you:

PROBLEM: USER UPDATES FSX, THEN UDPATES FSX:SE (OR FSX:SE AND THEN FSX) AND ONLY SEE A QUICK FLASH OF THE UPDATER WHEN UPDATING THE SECOND PLATFORM:

This is normal.  The updater usually does a very good job of checking to see if you have both platforms installed and will attempt to do them simultaneously.  The Operations Center isn't smart enough to pick up on the fact that both platforms were updated until it is exited and re-run.  Stay tuned for a long-term fix for that....

[ADDED 14MAR17 BELOW THIS POINT]

PROBLEM: USER COMPLETES UPDATE BUT FINDS 747 WILL NOT RUN. (BLANK GAUGES, ETC):

We have spent the better part of today researching this topic with the help of a few users.  We are VERY certain that the majority of users who report this problem are experiencing the results of aggressive anti-virus protection on their local machine.  The A/V software is seeing the Operations Center attempt to download an EXE file, and then a number of other files (including some dlls) and the AV software is deciding "oooooh no you don't."

In other words, your A/V software is doing what it was designed to do- but it is catching something you want done...  A classic false-positive.

While we research how to interact more gracefully with aggressive AV software- you can solve this problem by COMPLETELY disabling your AV software, THEN running the Operations Center and product update process.

We have found that in nearly all cases we have worked with- correctly white listing the Operations Center worked most of the time, but disabling the A/V temporarily while conducting the update works even more effectively.

We are working on some changes to the update methodology that should eliminate this problem at some point in the future... (It is a complex issue...)

 

0

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Updated and 747 not working at all.  Not even showing airplanes when selecting at PMDG initial menu.   Only showing some default liveries and in some cases causing CTDs inmediately after selection.

Already added exclutions to my AV(Kaspersky), but, is there some way to re-download it and try again?    For the while, product not usable at all.... :blush:

0

Share this post


Link to post
Share on other sites
9 minutes ago, Raphael_Chacon said:

Updated and 747 not working at all.  Not even showing airplanes when selecting at PMDG initial menu.   Only showing some default liveries and in some cases causing CTDs inmediately after selection.

Already added exclutions to my AV(Kaspersky), but, is there some way to re-download it and try again?    For the while, product not usable at all.... :blush:

Raphael,

Run the original installer and select repair. After it finishes run again the OC update. If this keeps happening and followed the instruction the open a ticket with PMDG

0

Share this post


Link to post
Share on other sites

Raphael,

Adding an exclusion is not sufficient.  If you read my comments in the original post closely, I mention specifically the following:

While we research how to interact more gracefully with aggressive AV software- you can solve this problem by COMPLETELY disabling your AV software, THEN running the Operations Center and product update process.

We have found that in nearly all cases we have worked with- correctly white listing the Operations Center worked most of the time, but disabling the A/V temporarily while conducting the update works even more effectively.

 

We have the benefit of collecting a TON of data from users here in the forum and via support when it comes to solving problems- so follow the directions we give you and it SHOULD work out...

Keep us posted on your progress, please?  I'd like to make sure you get up and running normally!

 

0

Share this post


Link to post
Share on other sites
38 minutes ago, rsrandazzo said:

Raphael,

Adding an exclusion is not sufficient.  If you read my comments in the original post closely, I mention specifically the following:

While we research how to interact more gracefully with aggressive AV software- you can solve this problem by COMPLETELY disabling your AV software, THEN running the Operations Center and product update process.

We have found that in nearly all cases we have worked with- correctly white listing the Operations Center worked most of the time, but disabling the A/V temporarily while conducting the update works even more effectively.

 

 

 

Getting  back  to disabling  your  av you will find  that most  developers of  addons  already  suggest  to disable your av whilst downloading  and installing and  thought  it  was  well known  to users,  well guess not,  and  looks  some users  dont  actually   read  what  they are  suppose  to do   as  to your original post  on how  to install the new update  feature  by letting  to do its  thing:biggrin:

0

Share this post


Link to post
Share on other sites

Not being a computer geek, but out of simple boyish curiosity, I was wondering if the problems I and many others have been encountering might have been being caused not by my anti-virus program but rather by the new PMDG Operation Center method of downloading updates.

While I realize that this little thought borders almost on blasphemy I mention it only because for the last five years or more I've only been flying two aircraft; The PMDG 737NGX and the VRS F18E Super Hornet with TacPAC.  These are both highly complex aircraft with large base downloads and updates. All of these base downloads and updates have come and been installed as manual installers. In all case, without exception, I have used the same anti-virus program, Bit Defender, and never have I had the slightest problem with any of them.

 After installing my newly purchased PMDG 747-400 Queen of the Sky which also installed and flew like a dream I finally used the PDGM Operations Center to install update #1 for The "Queen" and it, too, worked without any complications.  After flying a bit to prove that update #1 was also working as it should I then again used the Operations Center to install update #2.......and it was here that "the ice cream turned to............". I suffered all the same manifestations that so many others have talked about.........no panels, landing gear up, no flight control function, no functional buttons or keys. While the VC cockpit looked as it always has nothing other than a lonely little key which I had program to bring up a CDU worked(?).

Based on all my proceeding "gibberish" isn't at all possible that the problems lie with the Operation Center's installation process and not the anti-virus program?

Thanks for all your hard work in trying to unravel this mess. I know it will get done but I guess it's back to my PMDG 737NGX and the VRS F18E until that Golden day.   

0

Share this post


Link to post
Share on other sites

Hello,

First, I am very happy with the plane after using the main installer. I followed all the steps to install the update but I get stuck. This is what happens:

- The OC works well

- The update downloads well

- When I click on install  I get an error message: api-ms-win-crt-runtime-l1-1-0.dll missing...

- If I install or rather reinstall vc-redist.x86.exe I get another error message: set up not completed, 0x80040154 - class not registered.

I am using FSX on Windows 7/64. Again everything else works well and the 747 runs perfectly on my rather old PC with a GTX260...

Cheers

Luc

 

0

Share this post


Link to post
Share on other sites
6 minutes ago, Quink said:

Thanks for all your hard work in trying to unravel this mess. I know it will get done but I guess it's back to my PMDG 737NGX and the VRS F18E until that Golden day.   

Frank,

I think you and I said basically the same thing.  It works for 99% of users out there- but there are some corner cases that didn't appear in wide area testing, so we are adapting the process to eliminate them.

That is how the process SHOULD work... No?

I also disagree with your assertion that there is a mess to unravel.  Follow the hints we gave you and you will be off and running.  If not- give us feedback- and we can continue to stomp out the corner cases.

 

0

Share this post


Link to post
Share on other sites
4 minutes ago, rsrandazzo said:

Frank,

I think you and I said basically the same thing.  It works for 99% of users out there- but there are some corner cases that didn't appear in wide area testing, so we are adapting the process to eliminate them.

That is how the process SHOULD work... No?

I also disagree with your assertion that there is a mess to unravel.  Follow the hints we gave you and you will be off and running.  If not- give us feedback- and we can continue to stomp out the corner cases.

 

Robert,

Never a doubt on my part! I not only have blind, child-like faith in you and the PMDG gang's ability to help us resolve it. There is a "mess" for those who can no longer fly and "our tongues are hanging out to our third fly buttons" to fly the "Queen" we've lusted after for so long. There's no accusation here of you or PMDG. I'm one your biggest supporters!

"Follow the hints we gave you and you'll be off and running"

Robert, there are now so many different hints scattered out there on our forum from both PMDG and various users that I no longer even know where to begin with them.  Unfortunately many of them are way above my computer pay grade and my ability to discern which are usable and which might make the situation worse.

Since the problems seem similar in their effects perhaps the answers might be similar.  It might be most helpful  it  PMDG could filter these posts and write one closed post written in simple "Dick, Jane, and Spot" format for us computer special children to follow step-by-step.

As to the "feedback" That was sent to PMDG day before yesterday and the answer arrived in a record short time, great customer service, but unfortunately it didn't work.

Regards,

Fred (not "Frank")  

0

Share this post


Link to post
Share on other sites
3 hours ago, Quink said:

Robert, there are now so many different hints scattered out there on our forum from both PMDG and various users that I no longer even know where to begin with them.  Unfortunately many of them are way above my computer pay grade and my ability to discern which are usable and which might make the situation worse.

The entire reason for this thread (that is to say, the first post herein) is to offer hints at solving the issues. He's referring to the first post wherein he offers suggestions on where to look. This, of course, would be the first place, before worrying about the hints scattered elsewhere.

3 hours ago, Quink said:

Since the problems seem similar in their effects perhaps the answers might be similar.  It might be most helpful  it  PMDG could filter these posts and write one closed post written in simple "Dick, Jane, and Spot" format for us computer special children to follow step-by-step.

Scroll to the top of this page.

0

Share this post


Link to post
Share on other sites

PMDG, congrats!

just loaded the latest OC update then went to the QOTS one...

It took a while but... everything went well, all 62 files loaded. I just did a quick tour around LSGG and everything works fine.

Great job, thanks a lot!

Luc

0

Share this post


Link to post
Share on other sites

Posted (edited)

For what it's worth here is what I did after multiple tries to update, all resulting in no click spots, no gear and no countdown after loading. From my ticket in Support. 

Hi Ryan,
Here is what I've just done. (Everything started as Admin.)
1) Deleted {properly and completely uninstalled}  the 744 which was installed but not working
2) Restarted the PC and turned off virus and firewall
3) Downloaded a new copy of the 744 from you
4) Installed it. DID NOT RUN IT.
5) Re booted my PC and turned off virus and firewall
6) Opened Ops C
7) Installed the update
8) Re booted my PC
9) Ran the 744
10) It hung the PC
On returning home and before doing all this I installed a new set of speakers.
11) Went back to your previous note and deleted the sound device line in the .ini file
12) Re ran FSX, loaded a 744 and all worked fine.
Hope this info is helpful.
Thanks
Chris

Edited by funkyhut1
In 11), replace the word file with line.
0

Share this post


Link to post
Share on other sites

I'm loving this update feature :biggrin:can now get fixes and improvements so much faster from PMDG :happy:

0

Share this post


Link to post
Share on other sites

Works great and a really neat way to deliver incremental updates. Only thing I'd say is that the cmd window sometimes looks like it's hung, even if it hasn't hasn't. It seems to take its sweet time over some of the updates. Just let it do its thing and go make a cup of tea. 

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now