Jump to content

Sign in to follow this  

Unresponsive Virtual Cockpit

Recommended Posts

I bought the PMDG 737-800/900 from the official  PMDG website, and it has been working properly for the first 2 months or so.

(I play on FSX:SE) Around 2 weeks ago a problem started occurring. On (some) flights, (maybe something like 2 in 5 flights) the virtual cockpit stops responding to my mouse clicks mid-flight wile cruising. The 2D panels work fine, but the 2D cockpit looks something like this: (thanks @qantas747)


I literally can't use anything while in VC. I tried changing camera views using (A) and getting an outside view of the aircraft then going back in, but nothing worked. I tried changing to full screen since I play in windowed mode, and it was responsive again. But once I clicked on one button, it would go back to unresponsive mode. I changed back to windowed mode and the same thing happened. But once I changed to full screen again it would stay unresponsive no matter how many times I switched between the two modes.

The same problem happens if I change the scenery while already loaded in-game.

This problem is way too annoying and even more frustrating because I play online nowadays. If I play offline its not too big of a deal as I can save the flight, exit the game, relaunch the game, load the flight again and it would work. It is still frustrating either way.

I have already submitted a ticket, but would like to hear your opinions.

Zack Brown

Share this post

Link to post
Share on other sites

It seems like I am having the same issues (using SE). It worked for a while, so I'm not sure where the conflict came in. When I load the NGX only certain switches and knobs work. Nothing on the MCP works, the gear lever and flaps don't work, etc. However, some switches and knobs work and everything works with the 2D panel. 

After reading, this obviously seems like a simconnect issue, but I have all of the simconnects installed per instructions. I even uninstalled and reinstalled all of them and I still can't get it to work. I've tried restarting, reinstalling, moving viewpoints, windowed to full screen and back, etc. and still no joy. 

I own the NGX for P3D as well and it is still (at least the last time I checked) working as it should. I just purchased and installed the P3D version so maybe there is a conflict with having the NGX installed in both sims on the same system?

I also run FSX:SE in DX10 with Steve's tool, but I don't think this would be causing the issue as I've read/seen many others doing the same thing. It is frustrating as I like to use FSX:SE for scenery that's not compatible with P3D. 

Hoping we can find a solution, 

John Lee

Share this post

Link to post
Share on other sites
On 4/25/2017 at 6:41 PM, jbrett2634 said:

After reading, this obviously seems like a simconnect issue

Not sure about that as it has also happened to me while playing offline around 2 times or so.

Here's PMDG's reply to my ticket:



As best we can tell the clickspot issue tends to happen when the sim gets heavily loaded down with CPU and memory tasks. It's definitely an issue with the sim itself and not the airplane, we don't have any control over clicking and mouse response, that's simulator and Windows functions. Unfortunately, we're working with an 11+ year old platform here with FSX and it can do weird things, especially on modern PCs it was never designed for.


The issue in the screenshot is caused by having both the main 2D panel and the VC opened at the same time (usually by pressing Shift+1) - this doesn't work in our aircraft due to the way the gauges are designed, you have to choose either the VC or 2D, not both simultaneously. The correct way to switch to 2D is to right click and choose the "Cockpit" view preset, which is the 2D.

Monitoring my CPU (i7-6700K) load using Task Manager, it is around 33-41% and my memory's load is around 38%. That is while playing online. Not sure what's causing it, it's frustrating as hell! And it shouldn't be a problem with these loads...

I did some more research and saw some people having freeze problems on FSX as a whole, caused my FSUIPC Autosave. I don't have a registered version of it but autosave has always been off for me.

Zack Brown

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online

  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.

    $10,915.00 of $25,000.00 Donate Now
  • Create New...