Jump to content
Sign in to follow this  

124th ATC Plugin doesnt show up

Recommended Posts

Hi ,

I installed the 124th ATC Plugin in the respective folder as per manual but after starting X11 no ATC124 plug in is shown in the simulator? Any tips why this doesnt show up?

Thx in advance


Share this post

Link to post
Share on other sites

I think I had this issue - turned out that 124th was inside a folder that was inside Plugins. Needed to take it out of that folder and place directly inside Plugins. Might have been the way I unzipped. Check your folders!

Share this post

Link to post
Share on other sites

I have the same problem I put the 124thATC64 folder in the resources/plugins directory and it does not show up.

Share this post

Link to post
Share on other sites

Did you ever figure this out?  I have the same issue.  Things I tried to remedy this is:

1. I tried unzipping the file several different ways.

2.  I placed the 124thATC folder in the xplane/resources/plugins folder 

3. I placed the contents of the 124thATC folder into my plugins folder directly

4. I redownloaded 124thATC and tried all of the above again.

5. I downloaded and install the C++ files that was recommended on another site.

6. I even deleted xplane, reloaded it from scratch and made 124thATC. My very first plugin

None of these efforts have remedied the issue.  If any one has found a way around this please post your fix.  Thanks

Share this post

Link to post
Share on other sites

Note: These instructions will work for XP10 installations too.

Hi all -- to fix your 124thATC issue in XP11 (for Windows), download and install multiple 64-bit C++ redist DLLs, starting with the latest VC++ redist DLL (2015 & higher as of July 4, 2020), then install the VC++ 2010 redist DLL, the VC++ 2012 redist DLL, and the VC++ 2013 redist DLL.  The order of installation is not important for the latter 3 DLLs.

All the DLLs above can be accessed and downloaded directly from Microsoft, free of charge.  URL: https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

Important: Scroll down to find, access and download the 2010, 2012,  and 2013 DLLs -- NO NEED to install Visual Studio or Visual Studio Service packs to fix this issue, only download the 64-bit redistributable libraries (DLLs).

After the 64-bit libs have been installed (no need to reboot), make sure the 124thATC64 folder is copied in its entirety to X-Plane 11\Resources\plugins, then start XP11.  XP11 may pause at "Will initialize plugins" for a minute or two (literally) while the 124thATC plugin is being processed.

Summary:  Install

  • VC++ 2015 redist DLL, x64
  • VC++ 2013 redist DLL, x64
  • VC++ 2012 redist DLL, x64
  • VC++ 2010 redist DLL, x64
  • If not already installed, install the 124thATC plugin per the instuctions
  • Start/restart XP11 (or XP10, if that's what your using)
  • Enjoy!

Best regards,


  • Like 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online

  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Create New...