Jump to content

Sign in to follow this  
sueede

Graphics flickering and distortion - in both FSX De Luxe and FSX-SE

Recommended Posts

When starting to play at a location suddenly ground textures partly disappeared, outside graphics becan to flicker and jump and changed layers when moving the spot plane view point, startup vc has changed viewpoint (floor) and zoom level, in default flight the cockpit dispers into parts and flutter, the aircraft move sideways (tried with different planes and locations) but responds to power and somewhat to joystick. The 2D panel works but views aoutside in that mode are ripped apart and flicker.

Does anyone recognize this situation and has an idea what causes it? I have uninstalled and reinstalled both FSX-SE and FSX De luxe (and tried both with and without SP!/SP2) - the issue is the same in both sims. I run Win10 updated, Gigabyte GeForce GTX660OC (both earlier and latest (february) drivers). There are no visual issues in other applications like Netflix movies and the game Talos Principle.

I hope there is someone out there who can help me save myself. Or my sim at least.

Tommy Engman

Edited by sueede
Tag added

Tommy Engman

Share this post


Link to post
Share on other sites

Sounds like a video memory issue , you might test with scenery sliders left or turn off aircraft shadows. If it stops happening you have found the issue , and a solution , running without shadows will reduce the load on your rig.

 

Best CJ

Share this post


Link to post
Share on other sites

Thanks,

but I run without shadows on everything, partly because IVAO AI aircraft seem to disappear if "aircraft cast shadows on the ground" and "on itself" or whatever - and for FPS-reasons. I suppose I should record what it looks like for members to get an idea. But on the other hand have you experienced this weird behavour of FSX I think you would feel "aha!! There are more FS pilots who have experienced this!". It probably is a hardware issue, the graphics card despite having served me and FSX well for a year has started withering. At the same time I hate the idea of spending €150 to find that it's *not* the graphics card that is the problem.


Tommy Engman

Share this post


Link to post
Share on other sites

Did you get the Creator's Update for Windows?
If so, it may very well be your video drivers.

Share this post


Link to post
Share on other sites

As Chuck suggested, try moving all of your sliders in FSX fully to the left and see if you still have the problem. If not, try moving them right a little at a time until you find the point at which the problems return.


 i7-6700k | Asus Maximus VIII Hero | 16GB RAM | MSI GTX 1080 Gaming X Plus | Samsung Evo 500GB & 1TB | WD Blue 2 x 1TB | EVGA Supernova G2 850W | AOC 2560x1440 monitor | Win 10 Pro 64-bit

Share this post


Link to post
Share on other sites
15 hours ago, Zatoichi said:

Did you get the Creator's Update for Windows?
If so, it may very well be your video drivers.

No, I haven't updated to Creator's yet.


Tommy Engman

Share this post


Link to post
Share on other sites
12 hours ago, n99wb said:

Could be a cable.  Re-seat everything and run DXDIAG.

Cables/card removed and reset. Dxdiag run. DirectX-version: DirectX 12. No error indication.


Tommy Engman

Share this post


Link to post
Share on other sites

I discovered that the calender of FSX is blank (no date numbers) in a brownish colour, occuring with the scenery distortions. Any experiences of that?


Tommy Engman

Share this post


Link to post
Share on other sites
22 hours ago, sueede said:

At the same time I hate the idea of spending €150 to find that it's *not* the graphics card that is the problem.

Don't we all. . . .  

When starting to play at a location<===  Only that location?

Does your CPU have integrated graphics?  Can you pull your card and try them?

 

N99WB

Share this post


Link to post
Share on other sites

One other thing.  Do you have a restore point you can run from before this started?

Share this post


Link to post
Share on other sites
2 hours ago, n99wb said:

One other thing.  Do you have a restore point you can run from before this started?

Hi.

This happens at every location, nomatter how I get there: From start, moving during gaming a.s.f  There are no integrated graqphics: Gigabyte Geforce GTX 660 OC. And now I have no restore point. Have reinstalled six or seven times.

Thanks for you concern!


Tommy Engman

Share this post


Link to post
Share on other sites

Problem probably solved.

In another Forum I was suggested to delete shader cache files, and/or try ticking the DX10 button in the display screen. Well, i tried the DX10 ticking and just like that graphics and aircraft behave normally. Unticked the DX10 button: Still seems OK. I was about to but e new graphics card...

 

Regards,

Tommy Engman


Tommy Engman

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...