Jump to content

Sign in to follow this  
RancidViper

My Traffic 6 installation issue v4

Recommended Posts

Hi all,

I just added my My Traffic 6 installation to v4 through Elaine's method, as my v3 installation was still installed in a separate folder. Did everything as instructed but the ai models are all messed up. Please help.

2017-6-5_13-26-25-327.jpg


Intel Core i7-6700k CPU Overclocked to 4.50GHz - 16GB RAM, Nvidia Geforce GTX980ti 6GB, Windows 10 Home 64-bit

Share this post


Link to post

hello.
also problems here:

installed V6a.
insertet the path in my simobjects.cfg from V4.
installed the scenery in scenery library.
deactivatet the default traffic.bgl in scenery/world/scenery

set traffic to 100%. but no AI´s there.
what have you done to see this planes?

Share this post


Link to post

That's what happened to me first. I then followed the install advice with the add-on xml file and that worked. 


Hans Schmitz

Share this post


Link to post
29 minutes ago, hjsmuc said:

That's what happened to me first. I then followed the install advice with the add-on xml file and that worked. 

Hans,

Please would you point me to the install advice with the add-on xml file.

M


Mario Lobo

 

P3D v:4.4| Win 10 Anniversary x64 pro | ASUS Z170 PRO GAMING | i7 6700K@ 4.6Ghz(OC) | Thermaltake Water Extreme 3.0 | G.Skill RipJawz V 16GB (2x8GB) DDR4-2666, 15-15-15-35 @ 1.2v | ASUS STRIX GTX1080 TI - 11GB | 1x SAMSUNG PRO 950 Nvme SSD 512GB | 1x SAMSUNG Pro 850 1TB SSD | Tt ToughpowerXT 875W | CoolerMaster HAF X Tower

Share this post


Link to post
1 hour ago, hjsmuc said:

That's what happened to me first. I then followed the install advice with the add-on xml file and that worked. 

I tried that method as well but that didn't work either. Now I seem to have completely messed up my v4 installation. Scenery is all messed up. Trying to reinstall now..

Update :  Seems like re activating ORBX after the reinstall is not working properly and completely messing up the scenery. I've posted a thread in their forum about it.


Intel Core i7-6700k CPU Overclocked to 4.50GHz - 16GB RAM, Nvidia Geforce GTX980ti 6GB, Windows 10 Home 64-bit

Share this post


Link to post

For MyTraffic to work - only 2 things are required
 
a path to the MyTraffic aircraft folder
a path to the MyTraffic scenery folder
 
This can be done a number of different ways. 
 
This method avoids messing with the P3D system simobjects.cfg and scenery.cfg
-------------------------------------------------------

Create a simple add-on.xml that contains all the required information.

<SimBase.Document Type="AddOnXml" version="3,3" id="add-on">
    <AddOn.Name>MyTraffic6</AddOn.Name>
    <AddOn.Description>My Add-on developed by My Company.</AddOn.Description>
    <AddOn.Component>
        <Category>SimObjects</Category>
        <Path>D:\FS_Apps\MyTraffic Professional\MyTraffic\Aircraft</Path>
    </AddOn.Component>
    <AddOn.Component>
        <Category>Scenery</Category>
        <Path>D:\FS_Apps\MyTraffic Professional\MyTraffic</Path>
        <Name>MyTrafficScenery</Name>
		<Layer>114</Layer>
    </AddOn.Component>
</SimBase.Document>

 

Note this file contains complete paths to both the aircraft and scenery folders. It also tells P3D where to place it in the scenery library.

Make sure you use the complete paths that refer to your installation.  Mine is installled  in D\FS_Apps

Place the addon.xml in a subfolder you create in the \Prepar3D v4 Add-ons folder

C:\Users\yourname\Documents\Prepar3D v4 Add-ons\MyTraffic\add-on.xml

When you start P3D it will ask you if you want to activate - Yes

 

Notes

You can check if MyTraffic has installed propery by going to

Top Menu > Options > Addons

Note it is also possible to disable it from this screen - thought it will require a sim restart

The MyTraffic scenery folder contains the aircraft routes and schedule.....it also contains a lot of AFCAD files, some scenery files and other 'stuff'.  

In my own set up I seperate the two as these extras files seem to cause enormous problems especially when using addon scenery.

 

 

 

  • Upvote 3

i9900K@4.8 + 16GB DDR4 + Asus 1080 Gaming

Share this post


Link to post

Thanks Tony, will monitor this and similar threads further. I will eventually move to P3Dv4 when more of my preferred add-ons are compatible.


Mario Lobo

 

P3D v:4.4| Win 10 Anniversary x64 pro | ASUS Z170 PRO GAMING | i7 6700K@ 4.6Ghz(OC) | Thermaltake Water Extreme 3.0 | G.Skill RipJawz V 16GB (2x8GB) DDR4-2666, 15-15-15-35 @ 1.2v | ASUS STRIX GTX1080 TI - 11GB | 1x SAMSUNG PRO 950 Nvme SSD 512GB | 1x SAMSUNG Pro 850 1TB SSD | Tt ToughpowerXT 875W | CoolerMaster HAF X Tower

Share this post


Link to post

Mario

I also use this technique for my P3Dv3 install 

  • Upvote 1

i9900K@4.8 + 16GB DDR4 + Asus 1080 Gaming

Share this post


Link to post

Perhaps you didn't used the proper text editor that I outlined in my post on how to do this properly!  v4 uses a different format for the text of the .cfg files and as pinned in the top of this forum, if your not careful it will mess up your install and you'll have to start again!

let me know if you need any assistance


Dave Robertson

BE20, BE35, BE02, C560, CRJ, MD80, E190, B777

Share this post


Link to post

Does anyone know if you must use the DX10 compatible option or if both DX9 and 10 work in P3Dv4?


I7-7700k@4.7ghz | 32gb RAM | EVGA GTX1080 8gb | Mostly P3Dv4.4 (also IL2:BoX, DCS, XP11)

Share this post


Link to post
11 hours ago, AirCanada235 said:

Perhaps you didn't used the proper text editor that I outlined in my post on how to do this properly!  v4 uses a different format for the text of the .cfg files and as pinned in the top of this forum, if your not careful it will mess up your install and you'll have to start again!

let me know if you need any assistance

I used notepad ++. I didn't change any settings, just copy/pasted your text, changed the file path and saved.

One thing I did notice though was that it seemed the MT6 installation I had was not the MT6a version so I may have missed that update. I have downloaded the latest version and will update and try again.

For the previous issue that happened with the scenery, a reinstall of the ORBX libraries seems to have fixed that.

I will post here again tonight after trying with the updated version.

Cheers.


Intel Core i7-6700k CPU Overclocked to 4.50GHz - 16GB RAM, Nvidia Geforce GTX980ti 6GB, Windows 10 Home 64-bit

Share this post


Link to post

Good lord....all I did was use Notepad++,  add the following, and everything works fine.

simobjects.cfg in ProgramData

Quote

[Entry.XX]
PATH=C:\MyTraffic Professional\MyTraffic\Aircraft
TITLE=MyTraffic Vehicles
ACTIVE=true
REQUIRED=true

And then added MyTraffic scenery folder to the scenery library. Voila...done...


    marc

ZXRPYTw.jpg

i7 2700K 4.7GHz | Corsair 16GB 2100MHz | Corsair H100i | MSI RTX 2080 Gaming Trio | TCL 43" 4K60 | (2) ASUS 27" 1080P60

Share this post


Link to post
3 hours ago, RancidViper said:

I used notepad ++. I didn't change any settings, just copy/pasted your text, changed the file path and saved.

One thing I did notice though was that it seemed the MT6 installation I had was not the MT6a version so I may have missed that update. I have downloaded the latest version and will update and try again.

For the previous issue that happened with the scenery, a reinstall of the ORBX libraries seems to have fixed that.

I will post here again tonight after trying with the updated version.

Cheers.

Okay. Let me know how it goes and if I can help


Dave Robertson

BE20, BE35, BE02, C560, CRJ, MD80, E190, B777

Share this post


Link to post
10 hours ago, Gridley said:

Does anyone know if you must use the DX10 compatible option or if both DX9 and 10 work in P3Dv4?

The DX9 option might not work fully as that may include FS8/9 format models.  They are reported to have problems in P3DV4 including missing moving parts.  As that's a legacy format, it's probably not something that will be fixed in the simulator.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    10%
    $2,505.00 of $25,000.00 Donate Now
×
×
  • Create New...