Jump to content

Sign in to follow this  
captain420

How to stop annoying "black" texture popping in P3D v4?

Recommended Posts

7 minutes ago, Dean_EGTC said:

Why can't people read the entire topic before berating others and making himself look a fool.

Take it easy Dean :smile:


Howard
P3DV4.5, MSFS2020, MSI Mag Z490 Tomahawk MB, i7-10700 CPU @ 5ghz, Nvidia RTX3090 GPU, 32gb RAM@3200Mhz, SSD/2Tb+SSD/500Gb+OS, Western Digital 1Tb HD + Storage, Corsair 1000W PSU, Philips BDM4350UC 43" 4K IPS, PFC Yoke, MFG Crosswind rudder pedals, CPlight MCP, Virtual Fly TQ.



Banner_FS2Crew_Supporter.jpg

Share this post


Link to post

Sorry.  It was made pretty clear though.  If he had simply misunderstood I wouldn't have batted an eyelid, but to mock others for his own shortcomings .........

Merry XMas! 


- Dean

P3Dv4 & XP11

space

Share this post


Link to post

To be totally fair, when I was in H.S. Reading Comprehension was readily taught. I think that got way-laid about 20 years ago. So nowadays, someone a lot younger than I get tripped up by printed phrases that are comparable to other similar printed phrases. When things aren't taught, they disappear. (just sayin')

By the way, I have problems with AI aircraft models doing that black thing, so I'm going to try the tip provided.


i7 7700K @4.2, GTX 1060 6 Gig, Windows 10, P3D v 5, and MSFS 2020 and a couple of SSD's

Share this post


Link to post

Are there any impacts on performance when using these tweaks? If it was as simple as changing a few numbers around in the config file, then why hasn't LM implemented it already? :) 

Skeptical, 


Regards,

Shelman S.

Intel i9 9900KS, o/c @ 5.1 GHz; EVGA RTX 2080 Ti FTW3 Ultra Gaming; GIGABYTE Z390 AORUS MASTER; Thermaltake 32GB RAM @ 3600 DDR4; 3xSabrent Rocket 4.0 2TB SSDs; LG UltraGear 38GL950G-B 38" 21:9 Curved 144 Hz G-SYNC IPS Gaming Monitor; Acer Predator x34 UHD (3440x1440) @ 100hz GSYNC; Windows 10 64 bit; X-Plane 10; X-Plane 11.5r2, DCS World Open Beta, Prepar3dv4.5; Prepar3dv5 Professional. Honeycomb Yoke, Saitek Pedals, Switch, and Autopilot Panels. Obutto R3Volution Cockpit. Thrustmaster HOTAS Warthog and F18 Joysticks and Throttle. 

Share this post


Link to post
7 minutes ago, ssair1 said:

Are there any impacts on performance when using these tweaks? If it was as simple as changing a few numbers around in the config file, then why hasn't LM implemented it already? :) 

Skeptical, 

You have to look at it from LM point of view.

Take your PC. If everyone had a cpu@4.9 and a 1080Ti  default setting would be very different. Even TEXTURE_SIZE_EXP=10 might be the standard setting.

But they have to make it run on 4+ year old PC and cannot have setting for everything in a UI as a lot of people will screw the sim up. 

I use  TextureMaxLoad=80 because it gives more throughput with a 1070 but the default is designed to work for all cards, hence a safe low number.

v4 does not need tweaking like p3d v1-3 or fsx I only use 2

TextureMaxLoad=80 being one of them. Do you need to add any? probably not. But can you help your PC to get more out of it? probably yes.

You're right being Skeptical there is a lot of miss information even on here.

 

 


David Murden.  MSFS2020 • M20  CJ4WT       DCS  A10CII  AV-8B  F-14A/B  F-16C  F/A-18C 

10900K@4.9 All Cores HT ON  Asus ROG Strix Z490-E  32GB DDR4 CL14 3200MHz RTX 3080  Corsair iCUE H150i Pro XT 360mm 

Corsair HX850i Platinum Plus 2x 1TB Samsung EVO Plus M.2  Phanteks Enthoo Evolo X Case  Thrustmaster Warthog HOTAS & TPR 

TrackIR • Samsung G7 32" 1440p 240Hz • Internet BT 75 Mbps Unlimited 
 

Share this post


Link to post
14 minutes ago, Nyxx said:

You have to look at it from LM point of view.

 

Thank you, David; I do agree with your assertions: seems reasonable. Just out of curiosity, since I do encounter the annoying black spots phenomenon, what setting would you recommend? As a side note, I’ve had some success with Process Lasso, Affinity mask, and NI refresh rate limiter settings thus far. I was experiencing micro stutters and am hesitant to continue fiddling around with my config file…

Kind regards,


Regards,

Shelman S.

Intel i9 9900KS, o/c @ 5.1 GHz; EVGA RTX 2080 Ti FTW3 Ultra Gaming; GIGABYTE Z390 AORUS MASTER; Thermaltake 32GB RAM @ 3600 DDR4; 3xSabrent Rocket 4.0 2TB SSDs; LG UltraGear 38GL950G-B 38" 21:9 Curved 144 Hz G-SYNC IPS Gaming Monitor; Acer Predator x34 UHD (3440x1440) @ 100hz GSYNC; Windows 10 64 bit; X-Plane 10; X-Plane 11.5r2, DCS World Open Beta, Prepar3dv4.5; Prepar3dv5 Professional. Honeycomb Yoke, Saitek Pedals, Switch, and Autopilot Panels. Obutto R3Volution Cockpit. Thrustmaster HOTAS Warthog and F18 Joysticks and Throttle. 

Share this post


Link to post
13 minutes ago, ssair1 said:

Thank you, David; I do agree with your assertions: seems reasonable. Just out of curiosity, since I do encounter the annoying black spots phenomenon, what setting would you recommend? As a side note, I’ve had some success with Process Lasso, Affinity mask, and NI refresh rate limiter settings thus far. I was experiencing micro stutters and am hesitant to continue fiddling around with my config file…

Kind regards,

Even with you PC you might not get rid of the black spots as LM tried to optimize memory to stop OOM so "it" unloads textures it feels are not needed. If I was you I would test it.

Go around 4,000ft in a default aircraft were you find you can see black textures with no tweaks. Try  TextureMaxLoad=80 or even 160 given the power of your GFX and see what it brings. I feel it will not stop it as LM built in the code to offload the textures "not needed". But I hope you will find it helps.

That's why you're right in being Skeptical. If you see it helps, class that as a result even if it does not totally do away with the problem. Let everyone know how it does work your end as people with a 1080Ti am sure would like to know.

I don't want to go into setting as it's way too long but even with your high end PC I would suggest you set FPS to limited within the sim. The sim works in a different way with fps locked and you have/should have all the headroom you need with that great PC of your. 


David Murden.  MSFS2020 • M20  CJ4WT       DCS  A10CII  AV-8B  F-14A/B  F-16C  F/A-18C 

10900K@4.9 All Cores HT ON  Asus ROG Strix Z490-E  32GB DDR4 CL14 3200MHz RTX 3080  Corsair iCUE H150i Pro XT 360mm 

Corsair HX850i Platinum Plus 2x 1TB Samsung EVO Plus M.2  Phanteks Enthoo Evolo X Case  Thrustmaster Warthog HOTAS & TPR 

TrackIR • Samsung G7 32" 1440p 240Hz • Internet BT 75 Mbps Unlimited 
 

Share this post


Link to post
33 minutes ago, Nyxx said:

Even with you PC you might not get rid of the black spots as LM tried to optimize memory to stop OOM so "it" unloads textures it feels are not needed. If I was you I would test it.

Go around 4,000ft in a default aircraft were you find you can see black textures with no tweaks. Try  TextureMaxLoad=80 or even 160 given the power of your GFX and see what it brings. I feel it will not stop it as LM built in the code to offload the textures "not needed". But I hope you will find it helps.

That's why you're right in being Skeptical. If you see it helps, class that as a result even if it does not totally do away with the problem. Let everyone know how it does work your end as people with a 1080Ti am sure would like to know.

I don't want to go into setting as it's way too long but even with your high end PC I would suggest you set FPS to limited within the sim. The sim works in a different way with fps locked and you have/should have all the headroom you need with that great PC of your. 

Ok, So I went ahead and added “TextureMaxLoad=80,” as the last entry under [Display] in my Config file. Flying the A2A Cessna, over London (EGLC), at 4000 feet, I noticed a considerable improvement; Although I should continue testing, I have yet to notice any black spots. And I have limited my FPS with Nvidia Inspector to 31.5 and running ½ of my refresh rate with VSync and triple buffering set ON. These NI settings, in conjunction with Process Lasso and AM of 116, have alleviated the micro studders, resulting in a smoother experience. Thanks again, David!

Regards,


Regards,

Shelman S.

Intel i9 9900KS, o/c @ 5.1 GHz; EVGA RTX 2080 Ti FTW3 Ultra Gaming; GIGABYTE Z390 AORUS MASTER; Thermaltake 32GB RAM @ 3600 DDR4; 3xSabrent Rocket 4.0 2TB SSDs; LG UltraGear 38GL950G-B 38" 21:9 Curved 144 Hz G-SYNC IPS Gaming Monitor; Acer Predator x34 UHD (3440x1440) @ 100hz GSYNC; Windows 10 64 bit; X-Plane 10; X-Plane 11.5r2, DCS World Open Beta, Prepar3dv4.5; Prepar3dv5 Professional. Honeycomb Yoke, Saitek Pedals, Switch, and Autopilot Panels. Obutto R3Volution Cockpit. Thrustmaster HOTAS Warthog and F18 Joysticks and Throttle. 

Share this post


Link to post
44 minutes ago, ssair1 said:

Ok, So I went ahead and added “TextureMaxLoad=80,” as the last entry under [Display] in my Config file. Flying the A2A Cessna, over London (EGLC), at 4000 feet, I noticed a considerable improvement; Although I should continue testing, I have yet to notice any black spots. And I have limited my FPS with Nvidia Inspector to 31.5 and running ½ of my refresh rate with VSync and triple buffering set ON. These NI settings, in conjunction with Process Lasso and AM of 116, have alleviated the micro studders, resulting in a smoother experience. Thanks again, David!

Regards,

Your welcome and it's great to know that tweak worked for you.

Happy to help.


David Murden.  MSFS2020 • M20  CJ4WT       DCS  A10CII  AV-8B  F-14A/B  F-16C  F/A-18C 

10900K@4.9 All Cores HT ON  Asus ROG Strix Z490-E  32GB DDR4 CL14 3200MHz RTX 3080  Corsair iCUE H150i Pro XT 360mm 

Corsair HX850i Platinum Plus 2x 1TB Samsung EVO Plus M.2  Phanteks Enthoo Evolo X Case  Thrustmaster Warthog HOTAS & TPR 

TrackIR • Samsung G7 32" 1440p 240Hz • Internet BT 75 Mbps Unlimited 
 

Share this post


Link to post

Friends,

I'm not sure what a TextureMaxLoad setting of 80 would do, because as best I remember, TextureMaxLoad has to be set in multiples of 3.  I don't know how P3D would handle a setting that is not as multiple of 3, but it might disregard the setting and use a default.

 


Dave-Aerosoft-2021-Small.png

Share this post


Link to post
37 minutes ago, DaveCT2003 said:

Friends,

I'm not sure what a TextureMaxLoad setting of 80 would do, because as best I remember, TextureMaxLoad has to be set in multiples of 3.  I don't know how P3D would handle a setting that is not as multiple of 3, but it might disregard the setting and use a default.

 

 


David Murden.  MSFS2020 • M20  CJ4WT       DCS  A10CII  AV-8B  F-14A/B  F-16C  F/A-18C 

10900K@4.9 All Cores HT ON  Asus ROG Strix Z490-E  32GB DDR4 CL14 3200MHz RTX 3080  Corsair iCUE H150i Pro XT 360mm 

Corsair HX850i Platinum Plus 2x 1TB Samsung EVO Plus M.2  Phanteks Enthoo Evolo X Case  Thrustmaster Warthog HOTAS & TPR 

TrackIR • Samsung G7 32" 1440p 240Hz • Internet BT 75 Mbps Unlimited 
 

Share this post


Link to post
On 15/12/2017 at 1:05 PM, ssair1 said:

Ok, So I went ahead and added “TextureMaxLoad=80,” as the last entry under [Display] in my Config file. Flying the A2A Cessna, over London (EGLC), at 4000 feet, I noticed a considerable improvement; Although I should continue testing, I have yet to notice any black spots. And I have limited my FPS with Nvidia Inspector to 31.5 and running ½ of my refresh rate with VSync and triple buffering set ON. These NI settings, in conjunction with Process Lasso and AM of 116, have alleviated the micro studders, resulting in a smoother experience. Thanks again, David!

Hello,

What version of Nvidia Inspector are you using?
Do you use the "normal" frame limiter or v2?
What settings do you apply in Prepar3D so that they do not interfere with the Nvidia settings? FXAA, AA, TF, Vsync, Target frame rate in Prepar3D?

Thanks

Share this post


Link to post
On 15.12.2017 at 2:04 PM, Nyxx said:

You have to look at it from LM point of view.

I use  TextureMaxLoad=80 because it gives more throughput with a 1070 but the default is designed to work for all cards, hence a safe low number.

 

 

 

On 15.12.2017 at 6:50 PM, Nyxx said:

 

David, your setting TextureMaxLoad=80 and the info from SteveW in the link you posted seem to contradict each other. SteveW wrote there:

Quote

 

From the P3D site:

[DISPLAY]

TextureMaxLoad=6

Non-Default entry. This entry will not exist in your Prepar3D.cfg file by default and must be added to the file.

Performance Tuning Tip:

This can induce stutters. Use multiples of 3 only such as 3, 6, 9, etc. This is perfect for photorealistic scenery

 

Not that what humans write is always Bible to me but DaveCT2003 raised a vaild point. What if your setting of TextureMaxLoad=80 (which is out of 3 multiplies) is just a placebo and there's something else in your cfg, that works very well to eliminate those black textures for you instead? Could be easily checked by removing that line.

Thanks.  

Edited by Dirk98

Share this post


Link to post

I'll try your setting on my end and see. I'm affected by the black textures as well, so it will be easy to check.

 

Share this post


Link to post

I'm confused. Am getting to old:blush:

OK after reading thought this topic 4 times I now see  what your saying. 

I apologies I think old age got to me.

On 12/15/2017 at 11:04 AM, Nyxx said:

I use  TextureMaxLoad=80 because it gives more throughput with a 1070 but the default is designed to work for all cards, hence a safe low number.

The default low number is 30.......explained below.

The clue to my mistake is I was talking about throughput. Here I did the same mistake but the clue to my senile demecher is here because 80-160 are not for texturemaxload

On 12/15/2017 at 11:31 AM, Nyxx said:

Try  TextureMaxLoad=80 or even 160

Its.....and I was referring to.....

TEXTURE_BANDWIDTH_MULT =

Sorry my sincere apologize for the confusion. @Dirk98and @DaveCT2003 

 

  • Upvote 1

David Murden.  MSFS2020 • M20  CJ4WT       DCS  A10CII  AV-8B  F-14A/B  F-16C  F/A-18C 

10900K@4.9 All Cores HT ON  Asus ROG Strix Z490-E  32GB DDR4 CL14 3200MHz RTX 3080  Corsair iCUE H150i Pro XT 360mm 

Corsair HX850i Platinum Plus 2x 1TB Samsung EVO Plus M.2  Phanteks Enthoo Evolo X Case  Thrustmaster Warthog HOTAS & TPR 

TrackIR • Samsung G7 32" 1440p 240Hz • Internet BT 75 Mbps Unlimited 
 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    43%
    $10,945.00 of $25,000.00 Donate Now
×
×
  • Create New...