Recommended Posts

7 hours ago, Rob Ainscough said:

I was going to make a quick tip video on this, but working right now and don't have the time ... here is what needs to happen:

.................................

.Hope this helps.  For some reason the PMDG 777 seems to be more problematic than other aircraft, not sure why.  

rob

thanks for your notes .....no joy using your "approach" with the PMDG737 (but you have success with the 777 ??)

I tend to agree with claude as next, but then why the T7 works !

it is so f...................!

10 hours ago, Claude Troncy said:

So I checked this dll it is a 32 bits one, and I cannot understand how it could work in P3DV4 64 bits !

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

16 minutes ago, vadriver said:

no joy using your "approach" with the PMDG737

Are you selecting the "PMDG737NGX" (not PMDG737) from the dropdown (in ControlPanel)?

The VAInterface.DLL doesn't work in P3D V4, that's why I suggested it be disabled and/or removed from the DLL.XML ... in fact you definitely don't want to use it at all, per my steps outlined above.

Cheers, Rob.

Share this post


Link to post
Share on other sites

Thanks to you Rob, I've got it working with my 777. However, like you, I'm not getting return data on my ipad; the <DISCONNECT prompt stays displayed.

Oh well, it's a start. Hopefully Virtual Avionics will get us a full up and running, two-way interface soon.

Also, Many Thanks Rob for your endless contributions to this community. Your posts and videos have greatly helped me with my re-entry into this hobby!

Don

Share this post


Link to post
Share on other sites
3 hours ago, wrap23 said:

However, like you, I'm not getting return data on my ipad; the <DISCONNECT prompt stays displayed.

Hi Don, I'm gonna recommend you do Step 5 (in my post above), remove any EXE.XML and DLL.XML entries for VAInterface.  Start VAInterface.exe manually using "Run As Administrator" before you start P3D.  Once in P3D, tab out and locate the ControlPanel.exe and manually "Run As Administrator", then select appropriate aircraft and exit.  This seems to be "reliable" method of connection with feedback going to iPad/Android.  This method is working for me for the PMDG737NGX, PMDG777, Aerosoft A320, iFly 747, iFly 737 (all fully functional) ... however PMDG 747 still has "partial" functionality with no return data to my iPad.

Cheers, Rob.

Share this post


Link to post
Share on other sites

Bonjour,

After deleting everything concerning the VAInterface.dll, the procedure is not working for me with P3DV4 737NGX.

A soon as P3D starts VAInterface quit with an error in the log file provided by FSCommMgr saying unable to get file name 

In the ini file there is an entry 
[P3DV4]
DLLXML=YES

created during the install process. It aslo create an entry in the DLL.XML and a VAInterface.dll is copied in the module folder.
But this DLL is a 32 bit one. So I am lost ! :cool:

Cheers and thanks Rob for your support in the forum.
Claude

Share this post


Link to post
Share on other sites
16 hours ago, Rob Ainscough said:

Oops, yes you're correct, I missed the last entry in the list.

Unfortunately like you, I'm not able to get my iPad display to sync visually with the PMDG 747 ... it accepts input and changes happen on the PMDG side, but no return data on the iPad side.

Cheers, Rob.

Found that to. Do NOT run in administration mode and it should work.

Not running VA Interface in administration mode, have it working with NGX, 777, 747 in P3DV4. I start VA Interface before starting P3D. Select aircraft in control panel after aircraft loaded and power to the FMC. It's the 737NGX, not the other one for the 737.

Share this post


Link to post
Share on other sites
6 hours ago, Claude Troncy said:

But this DLL is a 32 bit one. So I am lost !

See my thread here: 

 

Share this post


Link to post
Share on other sites
13 minutes ago, Rob Ainscough said:

See my thread here: 

Yes I tried everything without success, I still have an error in the log file.
I have open a ticket.
Cheers

Claude

Share this post


Link to post
Share on other sites

Thanks Rob. I've tried all of your suggestions and it still doesn't work. I additionally removed the DLL.XML file in the >VAinterface>modules. Didn't change a thing. 777 Virtual CDU still works just doesn't get feedback on ipad. Wish I had an understanding of what these files did but...I'm only a pilot!

Still hoping Virtual Avionics comes up with a solution soon.

Thanks again,

Don

Share this post


Link to post
Share on other sites
9 hours ago, B777ER said:

Found that to. Do NOT run in administration mode and it should work.

What security context are you running P3D V4 under?  Mine is set to "Run As Administrator" on the compatibility tab ... my understanding is you need to match whatever security context is being employed.

2 hours ago, wrap23 said:

777 Virtual CDU still works just doesn't get feedback on ipad.

Not sure what to suggest, I have it working ... I'll try to make a quick tip video this weekend showing what I do to make it work.

I agree, hopefully the VA support/devs will provide a less finicky version in the future but my understanding is the EXE they provided is considered "Beta" so I would expect some issues.

Cheers, Rob.

EDIT: I'm assuming people are NOT installing VA Interface into it's default location which I believe is C:\Program Files x(86) ??  I would recommend you install VA Interface outside of "C:\Program Files ..."  especially since the new VAInterface.exe is a 64bit file so it really should NOT be residing under "C:\Program Files x(86)".

 

Share this post


Link to post
Share on other sites

Well after 90 mins. or so I managed to get the PMDG 737, & 747 to work but not the 777. I start VAInterface_2.24.0.11633.exe manually from folder first NOT as administrator. (BTW VA Interface install folder; C:\Virtual Avionics) Start sim, load aircraft then set control panel to appropriate aircraft, exit control panel. This worked for 737, & 747 but not 777. With the 777 getting no return data. Using Android.

Share this post


Link to post
Share on other sites

I've tried repeatedly to get it to work with the IFly 747 in P3Dv4 to no avail. All Rob's advice has been followed.

I've opened port 9000 in the Windows 10 firewall and allowed the latest VA exe in and out.. No result.

So in desperation I turned off the Firewall altogether. Works fine now. This is not a long term solution I know but might be a clue for everyone else?

Cheers

Chris

 

Share this post


Link to post
Share on other sites
13 hours ago, Rob Ainscough said:

What security context are you running P3D V4 under?  Mine is set to "Run As Administrator" on the compatibility tab ... my understanding is you need to match whatever security context is being employed.

 

P3D as "run as administrator" but not VA Interface.

Share this post


Link to post
Share on other sites

With the 777, after successful connection, I have to hit the Menu button on my iPad then I get a matching display 

Cheers, Rob

Share this post


Link to post
Share on other sites

Bonjour,

I get this answer from Ricardo Dutra (Virtual Avionics) where he says that VAInterface only works in W10 not in W7, he also gives some clue concerning their 32 bits DLL.
Cheers

Claude

Quote

There is probably nothing wrong with your config.
The main problem is that we are struggling with an issue with the 64-bit APIs for Win7.

The 2.24.0.11633 beta release works fine for Win10, but not for WIn7.
It seems some of the internal Windows functions that are used to interact with Prepar3D in 64-bit have obscure behavior in Win7.

This is not an issue to the add-on because it runs within the simulator, but for an external process, such as VAInterface, who needs to detect what sim is being used and, in case of P3D, dialogue with SimConnect in order to send and retrieve data, this is turns out to be particularly difficult.

Internally, P3D still uses the 32-bit SimConnect, this is why the VA.dll is still 32-bit, but for other modules, the 64-bit is now being used and are for those that we are having trouble with.

 

Share this post


Link to post
Share on other sites
3 hours ago, Rob Ainscough said:

With the 777, after successful connection, I have to hit the Menu button on my iPad then I get a matching display 

Cheers, Rob

Thank you Rob. Unfortunately this didn't work for me.

Share this post


Link to post
Share on other sites
On 8/11/2017 at 10:23 AM, chrisal said:

I've tried repeatedly to get it to work with the IFly 747 in P3Dv4 to no avail. All Rob's advice has been followed.

I've opened port 9000 in the Windows 10 firewall and allowed the latest VA exe in and out.. No result.

So in desperation I turned off the Firewall altogether. Works fine now. This is not a long term solution I know but might be a clue for everyone else?

Cheers

Chris

I've looked at this again and checked all my settings. With the Firewall on it sticks on "connecting" and then I get "please check if VAInterface 2.3 or later is running"

Turn off the W10 "private" Firewall and it works as intended. Am I missing a trick with the Firewall settings do you think? Program and port are "allowed"

Cheers

Chris

Share this post


Link to post
Share on other sites

all

good news awaits most of you in the morning i believe !

time for lunch downunda ....

Share this post


Link to post
Share on other sites

 

2 hours ago, vadriver said:

all

good news awaits most of you in the morning i believe !

time for lunch downunda ....

I see there is a later version beta release VAInterface_2.24.1.11639.exe and a new controlpanel.exe. Getting ready to try it out on the 777 that I couldn't get to work.

https://virtualavionics.zendesk.com/hc/en-us/articles/115008729148-About-P3Dv4-Support

Now detects right sim. The 777 works now.:smile: 

All PMDG's work now.

Edited by bills511

Share this post


Link to post
Share on other sites
7 hours ago, bills511 said:

 

I see there is a later version beta release VAInterface_2.24.1.11639.exe and a new controlpanel.exe. Getting ready to try it out on the 777 that I couldn't get to work.

https://virtualavionics.zendesk.com/hc/en-us/articles/115008729148-About-P3Dv4-Support

Now detects right sim. The 777 works now.:smile: 

All PMDG's work now.

I've installed the latest version VAInterface_2.24.1.11639 for the T7 and it's connected but I don't get a matching display. Hitting the menu button like Rob suggested isn't working for me.

Any help is appreciated.

Cheers

Share this post


Link to post
Share on other sites
2 hours ago, celin101 said:

I've installed the latest version VAInterface_2.24.1.11639 for the T7 and it's connected but I don't get a matching display. Hitting the menu button like Rob suggested isn't working for me.

Any help is appreciated.

Cheers

On your device press LSK 1L. That works for me.

Share this post


Link to post
Share on other sites

Hello Captains!

It's been a while now and here at VA we are working hard to solve all problems in our beta version! We have a new release for you, it's basically the same steps to install it.

You just have to follow the instructions bellow:

  1. Download the .zip file with the new VAInterface files clicking here
  2. Extract both files into your VAInterface folder;
  3. Right click in VAInterface_2.24.1.11639.exe and Run as administrator

Remember always to create an exception in your firewall and anti-virus and the files ARE NOT a installer, you have to lace them in the VAInterface folder!

You can see our article about VAInterface for P3dv4 in our support platform by clicking here.

 

Kind Regards,

Share this post


Link to post
Share on other sites
11 hours ago, vitormfs said:

It's been a while now and here at VA we are working hard to solve all problems in our beta version!

Tested out all the following and working perfectly:

PMDG 747
iFly 747
PMDG 737
iFly 737
AS A320
PMDG 777

But the MJC Q400 and CRJ 700/900 still not working ;)

Cheers, Rob. 

Share this post


Link to post
Share on other sites
27 minutes ago, Rob Ainscough said:

But the MJC Q400 and CRJ 700/900 still not working ;). 

nor the LD757 expansion of the LD767 FMC,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now