ESzczesniak

RAAS Not Showing in P3Dv4 Add-on Menu

Recommended Posts

I just purchased the new 64-bit RAAS Pro.  I'm sure this is something I'm doing, but I'm not seeing it in the add-on menu.  I also don't see any log files, etc.  Any help to where I should turn to start sorting this out?  Thanks!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

18 hours ago, ESzczesniak said:

I just purchased the new 64-bit RAAS Pro.  I'm sure this is something I'm doing, but I'm not seeing it in the add-on menu.  I also don't see any log files, etc.  Any help to where I should turn to start sorting this out?  Thanks!

Hmmmmm, we got a ton of RAAS 64 users now who aren't having problems...

Take a look at the DLL.xml file... open it with notepad.

It's located here:

C:\ProgramData\Lockheed Martin\Prepar3D v4

Make sure there's a RAAS entry on it.

Maybe you  have a write permission issue?

 

Share this post


Link to post
Share on other sites

Hey Bryan,

Regarding the dll.xml... I looked at it in order to help the OP and found out that have no RAAS entry in that file despite I have it running fine in P3D! 

I check also the exe.xml in case and no entry there either (which is normal I think). 

I'm wondering whether there was something different in P3D v4/RAAS that doesn't need any entry in the dll.xml.

 

Share this post


Link to post
Share on other sites

RAAS 64 definitely uses the DLL.xml, or it wouldn't load.

But the 64 bit version doesn't use the one in App Data anymore.

It uses the one in the ProgramData folder.

The location's changed.

 

Share this post


Link to post
Share on other sites

I do have the RAAS entry.  I see this at the bottom of my dll.xml file:

    <Launch.Addon>
        <Name>RAASPRO</Name>
        <Disabled>False</Disabled>
        <Path>.\RAASPRO\RAASPRO.dll</Path>
        <DllStartName>module_init</DllStartName>
        <DllStopName>module_deinit</DllStopName>
    </Launch.Addon>

I think this is related to an issue/error with my dll.xml though.  My only other entry is for PMDG, which also is not showing up in my add-ons menu.  I never noticed this, as I haven't really needed to access the PMDG menu since so much is done through their CDU.  I do have FSUIPC, SODE 1.5.2, and the FSDreamTeam associated (GSX, Coautl, add-on manager), but these are not in the dll.xml.

I know this means it's beyond a RAAS issue, but any thoughts as to why my P3Dv4 install might be ignoring the dll.xml file?  Perhaps there is another one somewhere made by these other add-ons that it's looking at instead? 

Share this post


Link to post
Share on other sites

Hard to guess if your other stuff isn't loading as well.

Did you read this?

Also try asking PMDG Support and P3D V4 support; maybe they have an idea.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now