davecessna

PTA asking for activation code every run

Recommended Posts

As mentioned, every time I start PTA, it asks me to enter my serial as if the program is being run for the first time. The PC shouldn't have any issues with admin rights and the program itself is located in a full permissions folder. I have tried reinstalling, moving folders, running in safe mode. I emailed Matt for support, but he must be swamped so I figure I would ask on the forums. It's worth mentioning that once I enter the serial, every works fine including the application of tweaks.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Is your PTA set up to pass through your firewall? It may need to activate/check for updates with the server on startup.

Adam.

Share this post


Link to post
Share on other sites

Hi Dave,

I answer support emails usually within 30 minutes to 1hr during working hours - don't worry about my workload, I dug my own grave when I took this on :)

Anyway, on to your issue... PTA needs to be able to write to settings.res (located in the same folder you run PTA.exe from). You need to run PTA as administrator by right clicking on it and "Run as Administrator" (even if your PC has an admin account & has all of the correct permissions - don't ask me why, it's just Microsoft being fantastic at development). Once you've done that and entered your key, it'll store it securely and then you'll never have to activate it again.

Let me know if that fixes it.

Thanks,

Matt.

Share this post


Link to post
Share on other sites
On 7/8/2017 at 10:34 AM, MattDavies said:

Anyway, on to your issue... PTA needs to be able to write to settings.res (located in the same folder you run PTA.exe from). You need to run PTA as administrator by right clicking on it and "Run as Administrator" (even if your PC has an admin account & has all of the correct permissions - don't ask me why, it's just Microsoft being fantastic at development). Once you've done that and entered your key, it'll store it securely and then you'll never have to activate it again.

Let me know if that fixes it.

Thanks,

Matt.

I always run PTA as administrator and it is asking to be activated every time I start it.  Also it is not accepting my activation.

It has totally corrupted my P3Dv.4 install and I am going to have to completely re-install P3Dv4 now.  On top of that, PTA will not activate with the key that I purchased. I'm not happy at all!

 

Bob

Share this post


Link to post
Share on other sites

I think I can shed a little light on the problem.

1) I tried to re-activate my existing 2.51 and got the activation error.

2) I restored my default shaders from the back-up, from within 2.51 ... so as to be ready for 2.52.

3) Installed 2.52 and successfully activated it (with the same/original key).

4) Imported my old 2.51 preset. Seems to work OK, but have yet to work my way through all the settings.

I think people maybe are forgetting to the "restore from backup" step <??>.

Matt - what's new in 2.52?

Adam.

Share this post


Link to post
Share on other sites

Seems funny though.  Even if I did it wrong, the software should activate.

I totally broke my P3Dv4 with this PTA.  I have it fixed now by running repairs on the "Client" and "Content", then I had to run repair on my NGX to get it working again.  I'm scared to use PTA now.  That software can really screw things up.

Share this post


Link to post
Share on other sites

Ok, I tried running PTA.exe in Windows 7 compatibility mode, it does create a settings.res file when activation succeeds and does not ask for it again.

 

For experiment's sake, I temporarily deleted the new settings.res file that was created and the same issue occurs again. I restored the file and it seems to be ok. I believe there is an issue with how the settings.res file is generated.

Share this post


Link to post
Share on other sites

This is a bit late but I have the solution. What you need to do is go to your antivirus (For me Norton) And allow the PTA app to access the internet. After I allowed it, worked perfectly.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now