Sign in to follow this  
oskar111

P3D v4 CTD when loading PMDG B737

Recommended Posts

Hello,

after the update to the new version of the base package PMDG 737-800/900 and installation of ASN for P3D v4 the PMDG will not load after choosing in the aircraft menu. The P3D is doing then a CTD.

This problem still exists after a reinstalling the base package. The problem is still there if I start P3D whitout the ASN.

Regards Holger Schraepel 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

29 minutes ago, oskar111 said:

Hello,

after the update to the new version of the base package PMDG 737-800/900 and installation of ASN for P3D v4 the PMDG will not load after choosing in the aircraft menu. The P3D is doing then a CTD.

This problem still exists after a reinstalling the base package. The problem is still there if I start P3D whitout the ASN.

Regards Holger Schraepel 

When you updated the base pack, did you uninstall the old one first and run the new installer as admin with antivirus disabled?

Share this post


Link to post
Share on other sites

Yes I did a clean reinstall!

Just tried again. Starting P3D v4 whit default Baron, everything is fine. Then choosing PMDG B737-800 and after 2 seconds CTD.

 

Share this post


Link to post
Share on other sites
3 minutes ago, oskar111 said:

Yes I did a clean reinstall!

When the sim starts up, what aircraft is the default selected aircraft?

Share this post


Link to post
Share on other sites
3 minutes ago, oskar111 said:

Default selected is the Beech Baron 58!

Does the sim crash when you click fly now or when you select the aircraft?

Share this post


Link to post
Share on other sites
Just now, oskar111 said:

When selecting the PMDG in the vehicle menu 

Hmmm can you go to start > type event > open event viewer > on the left expand windows logs > click application and find the crash. Should be marked with a red exclamation mark. Copy paste the details here

Share this post


Link to post
Share on other sites

Here are the details!

 

Name]   Application Hang

+EventID1002

[ Qualifiers]0

Level2

Task101

Keywords0x80000000000000

-TimeCreated

[ SystemTime]2017-07-21T16:48:37.000000000Z

EventRecordID49788

ChannelApplication

ComputerFlusi

Security

 

Prepar3D.exe

4.0.28.21686

17a0

01d302406a594e00

175

D:\Lockheed Martin\Prepar3D v4\Prepar3D.exe

6da33be6-6e34-11e7-9351-ac220bcbb9a1

55006E006B006E006F0077006E0000000000

Share this post


Link to post
Share on other sites

I'm having similar issue when changing liveries.

P3D v4 loads fine everytime with the NGX at YMAV, but then change the livery to United Airlines and P3D shuts down.

Graham

Share this post


Link to post
Share on other sites
5 minutes ago, Foghorn said:

I'm having similar issue when changing liveries.

P3D v4 loads fine everytime with the NGX at YMAV, but then change the livery to United Airlines and P3D shuts down.

Please have a look at the intro manual in regards to re-loading the aircraft. Page 34ish, I think.

The short version is that the aircraft doesn't like to be loaded on top of itself. You can switch to a default plane in between, but 737 loading the 737 again can cause issues.

Share this post


Link to post
Share on other sites

Holger, someone else stepped on your thread with a separate problem.  Also be aware that full names are required on all posts, set up automatic signature to deal with that for you.

The details  you pasted do not include the faulting module name,  the fact that this is an appHang event means P3D is loading something that isn't responding.  First guess would be ASN for P3dv4... I'm not sure on this but don't you have to get the latest AS16 for use with P3Dv4?  Be sure AS16 installs the simconnect module with P3D not running. Even if AS16 is not started, its simconnect dll is still involved because as_bootstrap.exe gets loaded by exe.dll.  Second guess would be the NGX installer is unable to successfully modify the dll.xml because you didn't run it with admin rights.  Hope this helps.

Share this post


Link to post
Share on other sites

Thank you Dan for your help. I was thinking in your direction to your point of view depending on ASN for P3D v4. Could be the troublemaker. I will uninstall ASN for P3D v4 and uninstall and than reinstall the PMDG B 737 as a Admin.

Will try it tomorrow regards

Holger Schraepel 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this