Sign in to follow this  
captain420

PTA is causing my sim to load up with a black screen!

Recommended Posts

I never thought I would have so much problems with an add-on before. This is the worst $20 I've spent. I'm not sure what is going on but everytime I load my sim up, I get a black screen, the sim is running, because I'm able to hit ESC and exit out of it. 

How to fix this? I read the PTA manual and it says it seems like it's not compiling the shaders for some reason? I am using the PTA Absolute 2.52.ini preset. I manage to fix this black screen problem earlier, but then I changed to another preset/restore my P3D shaders (I don't remember exactly what I did). But now the blackscreen problem is back. How can I fix this?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The black screen is normal, after any shader reconfiguration in P3Dv4.    It should stay there for about 5-10 seconds, then the textures should load. 

Have you re-loaded the default P3Dv4 shader set, in PTA, and then checked the sim - to rule out issues with a specific preset?

Share this post


Link to post
Share on other sites

I know that its normal, but for a black screen to stay there more than 10 minutes, is definitely not normal. It doesn't take that long to recompile the shaders. There's something definitely going wrong with PTA trying to write the shaders here.

I've spent almost the whole day yesterday trying to figure out whats wrong. Yes I reloaded the the default P3D shaders and it still happens.

 

But there was a moment when I actually could get the sim to load up normally, but I'm not sure what exactly fixed it as I did so many things. But now that I used PTA to change presets and stuff it has happened again. I have tried the default, matt davies and PTA ABsolute presets and I am not having any luck here. :( Sigh. I don't want to reinstall my entire sim from scratch again, as I have a lot of addons and stuff.

Share this post


Link to post
Share on other sites

You should never have to do a full reinstall of the sim, perhaps the Client at most.

Send me an email - matt.davies@projectfly.co.uk and I'll help you out. I'd take a guess that it's a relatively simple fix.

Thanks,

Matt.

Share this post


Link to post
Share on other sites

Matt Davies I am having the same issue I load a preset and my aircraft in the menu is not visible and when i load in my screen stays black. Also I always get errors when loading my presets i'll copy and paste the log for your preset below. Any help you can provide will be much appreciated.

Applying preset B:\Downloads\pta_2.61\MattDavies1.3.ini...
   Applying [Reduce cloud brightness at dawn/dusk/night] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
   Applying [Clouds shadows extended size] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
ERROR applying tweak [Clouds shadows extended size]  Problem with patch #0 - Patched block not found.
   Applying ["No popcorn" modifier] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
ERROR applying tweak ["No popcorn" modifier]  Problem with patch #0 - Patched block not found.
   Applying [Turn off clouds directional lighting] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
ERROR applying tweak [Turn off clouds directional lighting]  Problem with patch #1 - Patched block not found.
   Applying [Clouds Fog tuning] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\Cloud.fx
   Applying [Cirrus lighting] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
   Applying [Objects lighting] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
   Applying [Autogen emissive lighting] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
   Applying [Sky saturation] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx
   Applying [Terrain lighting] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
   Applying [Urban areas lighting at night] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
   Applying [Terrain saturation] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
   Applying [Water surface tuning] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
   Applying [Waves size] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fx
   Applying [Rayleigh scattering effect] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\FuncLibrary.fxh
ERROR applying tweak [Rayleigh scattering effect]  Problem with patch #1 - Patched block not found.
   Applying [Sky Fog tuning] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\FuncLibrary.fxh
ERROR applying tweak [Sky Fog tuning]  Problem with patch #2 - Patched block not found.
   Applying [Waves speed] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\GPUTerrain.fxh
   Applying [Turn off HDR luminance adaptation effect] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\HDR.hlsl
   Applying [Alternate tonemap adjustment] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\HDR.hlsl
   Applying [FXAA quality] to B:\Program Files\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\FXAAResolve.hlsl
   Applying [Tweak main config (prepar3D.cfg)] to Main config file
Preset has been applied with errors. See log above
Shaders cache cleared
 

 

Share this post


Link to post
Share on other sites

Send me an email with your order info to matt.davies@projectfly.co.uk and I'll help you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this