Sign in to follow this  
dadriel

RAASPro crashing P3Dv4 in PMDG 747

Recommended Posts

Hello,

I have a problem with the PMDG 747-400 QOTS II since they released the update that includes the locked RAASPro for the airplane. Whenever the plane finishes the alignment process for the IRS the sim will crash ~30 secs later. When I disable the loading for the  RAASPro.dll in dll.xml of the sim the problem disappears. I already talked to the PMDG support and they referred me to you for troubleshooting.

Operating System: Win10 64bit
SimVersion: P3D v4 with most recent update
Plane: PMDG 747-400 QOTS II with most recent updates

The location in the sim does not matter, it happens on any airport regardless if its stock or an addon airport.

Addons running in the Sim: GSX, Active Sky, ChasePlane (tried deactivating all off them for testing, but none had any effect)

I used the most recent makerwys.exe to create the date for the addon, but that didn't affect the behaviour.

When the sim crashes the event in the eventviewer always points kernelbase.dll being the broken module.

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Yes, I already tried uninstalling the Windows Update and it didn't change I see. Also the sim itself runs fine with other airplanes, e.g. I can complete a flight with the PMDG 737 without a problem.

Share this post


Link to post
Share on other sites

And try disabling RAAS via the FMC to further isolate.

There's no connection between RAAS and the IRS.

 

Share this post


Link to post
Share on other sites
40 minutes ago, dadriel said:

Yes, I already tried uninstalling the Windows Update and it didn't change I see. Also the sim itself runs fine with other airplanes, e.g. I can complete a flight with the PMDG 737 without a problem.

did you try  after   you  deleted  the update ,  just  asking  since  the  update  might  have  installed  again

Share this post


Link to post
Share on other sites
3 minutes ago, pete_auau said:

did you try  after   you  deleted  the update ,  just  asking  since  the  update  might  have  installed  again

Good point... windows update could have brought it back...

Share this post


Link to post
Share on other sites

I know tried deactivating the RAAS in the aircraft with the FMC options and succesfully managed to get aircraft aligned and sitting on the tarmac without a crash. I then activated the RAAS again in the FMC -> shortly after that the sim crashed. 

I also went through all my test for the aircraft with the above mentioned update uninstalled (Windows was actually also telling me that it was missing), but it didn't change the behaviour at all. As said above, the sim itself runs fine, it is just the 747 that keeps crashing.

I'm surprised as you are to this connection triggering the crash and it also took me quite a while to find the root cause here. The activation of the RAAS in the 747 was the only major thing that changed between my last succesful flight with the plane and the crashing now.

Share this post


Link to post
Share on other sites
4 minutes ago, dadriel said:

yes, I used the makerwys.exe version 4.8.2 for the creation of the data, that is the most recent version for the P3Dv4 I know off.

Not only makerwys 4.82 but Lorby-SI AddonOrganizer also as detailed in the documentation and required for P3Dv4 ?

Share this post


Link to post
Share on other sites

I left that one out, since according to the docs it is only required if you use the addon.xml configuration for scenery addons, which none of the airports I use do.

Share this post


Link to post
Share on other sites

You've checked this I assume:

 

Problem:  No sounds play and/or I'm getting a Crash to Desktop (CTD) associated with the "RAASAudio32.dll" or Flight Simulator will not load "RAASPRO.DLL".

Solutions:
 

If you have two sound cards running in parallel, disable one of them.  If you have multiple playback devices enabled, only have one as Primary.

Disable your firewall and ensure your OS has all the latest Updates.

If you are running any audio editing program in the background that attempts to strip Digital Music Rights (DRM) from music, such as Audials, Tune Bite, Sound Taxi or Sound Bite, please UNINSTALL them.  They interfere with FS2Crew's Microsoft based Audio Engine.  Some of these types of programs are legal in parts of Europe, but they are not legal in the United Sates.

Re-install RAAS Professional again, but do not click 'cancel' during the install.  Wait for the install to finish.

If using a Creative Labs X-Fi Extreme Audio Sound Card, uninstall the latest driver and re-install the original driver off the CD that came with your Sound Card.  The latest driver conflicts with the Microsoft XACT - FS2Crew Audio engine.  (If you no longer have your original driver disk, click here to download the original driver).

If you have a Dolby 5.1 or 7.1 speaker sound system, set your speaker configuration to "Stereo" via the Realtek Audio Manager (assuming you're using the Realtek Audio Manager).

Sometimes users have corrupt system files/data on their Operating System.  They solved their problem by doing a clean re-install of their OS or by repairing their OS.  Follow this link to learn how to repair a corrupt Windows 7 installation.  You will need to go to the Windows Download Center and Download Windows 7, for example, with SP1 and install using the Update option.  You will need to re-activate Windows 7.

Sometimes users have corrupt versions of the FSX.CFG file.  Delete the FSX.CFG file.  It will re-build automatically when you load Flight Simulator.  Your FSX.CFG file is located here:

Windows XP: \Documents and Settings\<username>\Application Data\Microsoft\FSX

Windows Vista/ 7 / 8/ 10: \Users\<username>\AppData\Roaming\Microsoft\FSX

Share this post


Link to post
Share on other sites

Yes, I worked through that guide during my troubleshooting.

Only thing I couln't do is actually reinstall the RAASpro programm, since I only have the version that came with the airplane. I reinstalled the airplane though, so that might check that box for the troubleshooting?

I also still have a parallel install of FSX:SE on my system including planes that also have the RAAS included (PMDG 777 and Aerosoft Airbusses). Maybe there is some conflict on some level with these older addons?

Yes, I worked through that guide during my troubleshooting.

Only thing I couln't do is actually reinstall the RAASpro programm, since I only have the version that came with the airplane. I reinstalled the airplane though, so that might check that box for the troubleshooting?

I also still have a parallel install of FSX:SE on my system including planes that also have the RAAS included (PMDG 777 and Aerosoft Airbusses). Maybe there is some conflict on some level with these older addons?

Share this post


Link to post
Share on other sites

I generally don't recommend parallel installs.  They can cause problems for installers, but they generally shouldn't cause problems for addons in game.

Your problem frankly is a big who knows.

We have probably 50,000 plus RAAS units in service because everyone who owns the PMDG 777 or 747 or Aerosoft Airbus or CRJ get's it for free, at least the unlocked version.

Reports of issues are almost non-existent.

Personally, I would try re-installing RAAS first.

Who knows, maybe that will clear something up.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this