Jump to content

Sign in to follow this  
MattDavies

PTA v2.60 Released (P3D v4.1 Compatibility & New Features)

Recommended Posts

Hello, 

First off - Thanks for the update, I love PTA. When I am closing down PTA after applying a preset I am getting an error box come up stating “I / O error 103” - I was just wondering if anybody had any ideas?

Many Thanks, 

Jonathan 


- Jonathan Daley

Share this post


Link to post
Share on other sites
3 hours ago, Jack_Sawyer said:

That's a good question, do we have to revert back to the original shaders before running the new PTA?

As long as you have no confirmation it may be a wise decision and won't harm. If you backed up your default P3D shaders and now save your actual preset settings, nothing can go wrong when updating PTA. And maybe note your settings so you can enter them in the new PTA if your preferred preset doesn't work in the new version. At least most values should be transferable.

Share this post


Link to post
Share on other sites

Sorry if this already got answered somewhere. Can I also use the new PTA 2.6 version and options with P3D 4.0? Just in case I feel no need to update P3D for now.

Share this post


Link to post
Share on other sites
17 minutes ago, tremor595 said:

Sorry if this already got answered somewhere. Can I also use the new PTA 2.6 version and options with P3D 4.0? Just in case I feel no need to update P3D for now.

Yes


Matt Davies

Founder/CEO - Mettar Simulations

=====
Prepar3D Tweak Assistant (PTA) available here: https://www.simtweaks.com
projectFLY - one of the most used virtual aviation platforms (now with GLOBAL schedules):  https://www.projectfly.co.uk

Share this post


Link to post
Share on other sites

SOLVED!! everyone just unistall and reinstall the client.msi. It literally takes no longer than 5 minutes and now everything is back to normal, Happy landings all!

Share this post


Link to post
Share on other sites

Is this AFTER going to 4.1 and installing the new PTA?

It would bee nice to have a step-by-step guide.  One for people who have upgraded to 4.1 first without the new PTA and another for  people like me who have not upgraded P3D to 4.1 yet or installed the new PTA.

 

 


Jack Sawyer

Share this post


Link to post
Share on other sites

Jack, I think it doesn't matter which P3D version you have as Matt confirmed the new PTA 2.6 can be used with 4.0 too. 

Most important, backup and save. And let it be a system and storage image prior to a major P3D update for example, which always comes with a lot of others updates of addons at the same time.

Just a general advice. An image prior to the hype's peak is always useful...:biggrin:

Share this post


Link to post
Share on other sites
9 minutes ago, tremor595 said:

Jack, I think it doesn't matter which P3D version you have as Matt confirmed the new PTA 2.6 can be used with 4.0 too. 

Most important, backup and save. And let it be a system and storage image prior to a major P3D update for example, which always comes with a lot of others updates of addons at the same time.

Just a general advice. An image prior to the hype's peak is always useful...:biggrin:

First thing I do before anything ever goes in my sim is an Acronis full global backup.

But my question is the exact sequence.

Correct me if I'm wrong but I would surmise that the correct steps are as such.

1. Acronis

2. Run the version of PTA I now have installed and tell it to restore all the original shaders.

3. Run the sim.

4. Uninstall the Client and install it.

5. Reboot

6. Run the sim

7. Run the new PTA and run my modified PTAbsolute Natural Set which what I use now, but will this preset work?

8. Run the sim and see how it looks.

So now the question is will that PTAbsolute Natural Set work because this one to me is the best looking, in my opinion.  If not then I'll stick with P3Dv4 and not even upgrade PTA.

Thanks.


Jack Sawyer

Share this post


Link to post
Share on other sites

ERROR: shader file C:\Lockheed Martin\Prepar3D v4\ShadersHLSL\General.fx is not original Prepar3D shader and can't be used
ERROR: shader file C:\Lockheed Martin\Prepar3D v4\ShadersHLSL\FuncLibrary.fxh is not original Prepar3D shader and can't be used
ERROR: shader file C:\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\HDR.hlsl is not original Prepar3D shader and can't be used
ERROR: shader file C:\Lockheed Martin\Prepar3D v4\ShadersHLSL\PostProcess\FXAAResolve.hlsl is not original Prepar3D shader and can't be used
 

What to do? I have deleted the relevant folders and run p3d to let it create the files again but still getting this messages.

Thanks.


Ahmet Can

Share this post


Link to post
Share on other sites
24 minutes ago, Jack_Sawyer said:

First thing I do before anything ever goes in my sim is an Acronis full global backup.

But my question is the exact sequence.

Correct me if I'm wrong but I would surmise that the correct steps are as such.

1. Acronis

2. Run the version of PTA I now have installed and tell it to restore all the original shaders.

3. Run the sim.

4. Uninstall the Client and install it.

5. Reboot

6. Run the sim

7. Run the new PTA and run my modified PTAbsolute Natural Set which what I use now, but will this preset work?

8. Run the sim and see how it looks.

So now the question is will that PTAbsolute Natural Set work because this one to me is the best looking, in my opinion.  If not then I'll stick with P3Dv4 and not even upgrade PTA.

Thanks.

Jack, I would do it exactly like you described it. Maybe with my own completely desaturated settings... And if it doesn't work as expected... We have our image. Sure, generally I also hope not having to revert to an image. But if you don't want to wait for the dust to settle... Give it a go.

Share this post


Link to post
Share on other sites
Just now, tremor595 said:

Jack, I would do it exactly like you described it. Maybe with my own completely desaturated settings... And if it doesn't work as expected... We have our image. Sure, generally I also hope not having to revert to an image. But if you don't want to wait for the dust to settle... Give it a go.

Thank you kind sir, I appreciate it.  But I need to know if PTAbsolute Natural Set will work, it seems on another thread here people say it won't which stinks as it's the only one I really like, it looks the best to my tired old eyes.

If it doesn't work I'd like to know why it won't work as some presets do and some do not.  Which not knowing enough about PTA is a real puzzler to me.


Jack Sawyer

Share this post


Link to post
Share on other sites

Jack, in this case I also would give the ball to the devs or to the time... 

But what still counts, try if it works on your computer, if not... Acronis, or in my case Macrium, is our friend.

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...