markoni

vsync and lower fps than monitor freq. causes screen distortion

Recommended Posts

Hi,

I am having problems with my screen distortion whenever I set fps lower than my monitor refresh rate 60hz.

Screen shakes and distorts. When I set to 60 fps it is fine. Vsync also doesn't help, even setting to adaptive half refresh rate.

Is it maybe because I use old lcd monitor.

I would appreciate any help.

Thanks.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

The monitor shouldn't make any difference. I notice you mention adaptive rate.. have you tried leaving out driver adjustments and just tried using in game settings? If you have and still have same problems, maybe corrupt graphic drivers. A lot of users have quit playing with driver overrides and just use P3D settings.

Share this post


Link to post
17 hours ago, markoni said:

Vsync also doesn't help, even setting to adaptive half refresh rate.

Try using the new "fast sync" option from the NVIDIA Control panel or NVIDIA Inspector. I suffered from screen tearing when using a head tracker and tried many combinations of vsync and FPS limiting with varying degrees of success. I now use fast sync with unlimited frame rates and have smooth, tear-free performance. Fast sync is only supposed to work well at very high frame rates but a number of users here have reported that it works successfully for them.

Share this post


Link to post

Thanks to both of you guys. I will post a video soon just to present the problem better. I am affraid of defective graphic card, because I have noticed this in some other game, although I did a lot of gpu tests with various apps. My setup is brand new with skylake and gtx 1070

Share this post


Link to post

Aghh, bummer. I haven't had card failure since the 90's. It can sure catch you off guard, and it's almost automatic that you don't want to even consider that possibility. 

Share this post


Link to post
4 hours ago, markoni said:

My setup is brand new with skylake and gtx 1070

Have you got the latest NVIDIA drivers installed? I'd be surprised if it was a faulty GPU if it works normally at higher frame rates.

Share this post


Link to post

Do you run Nvidia Inspector at all? If so, run it and select Prepar3d and reset the global profile and see if that helps.

 

Vic

Share this post


Link to post

I have finished with my research and hopefully realize that my gpu is just fine :) Unfortunately, the cause for this screen distortion is low fps set in P3D in combination with VSync. I have been simming since early FS9 and after I switched to FSX, I always followed  NickN bible, setting up everything from scratch, based on his sugestions. This is my first switch to P3D after FSX and I set adaptive VSync with half refresh rate, setting up 60 fps in P3D, again based on Nickn recommendation. This simply doesn't work for me. Landscape far from the aircraft starts to distort whenever there is any small stutter. Disable VSync and set fps to 60 just make the problem solved. Setting  fps to unlimited makes the sim smooth as much as possible. What is strange for me is that system can handle unlimited fps without problems and makes the stutters with screen distortion on 30 fps. Also, I am afraid my system is not going to be able to handle unlimited fps smoothly in some have sceneries with few addons I am planning to add, without stutters. That is why I was hoping to keep 30 fps with adaptive VSync.  

Share this post


Link to post
6 hours ago, markoni said:

 This is my first switch to P3D after FSX and I set adaptive VSync with half refresh rate,

Both adaptive VSync and half refresh rate do not work in P3D.
Best you can do is set your monitor refresh rate to 30Hz if possible and run with vsync on in the sim.

gb.

Share this post


Link to post
15 hours ago, markoni said:

That is why I was hoping to keep 30 fps with adaptive VSync.  

Did you try Fast Sync and unlimited frame rates?

Share this post


Link to post
1 hour ago, vortex681 said:

Did you try Fast Sync and unlimited frame rates?

Hi. I didn't. I am not very familiar with the Fast Sync. Could you please explain me what I could expect with it regarding P3DV4

Thanks.

Share this post


Link to post
37 minutes ago, markoni said:

Could you please explain me what I could expect with it regarding P3DV4

Not specifically for P3D, but Fast Sync is NVIDIAs newest take on vsync. Traditionally standard vsync has tended to introduce input lag and reduce framerates - if you switch vsync off you generally get around 10% better performance but will probably also see tearing at some point. Fast Sync, which is effectively triple buffering at the driver level, has no noticeable effect on performance with virtually no input lag. In theory, it should only work if your framerates are much higher than the monitor refresh rate but a number of us here on the forums have found it works really well at the lower frame rates we generally get whilst simming. Additionally, unlike the other vsync modes, it doesn't limit your FPS to your monitor's refresh rate (or some fraction of it).

Try it, you've got nothing to lose (but, perhaps, a lot to gain). You can set it in the NVIDIA Control Panel. I would make it a specific program setting rather than a global setting.

 

 

Share this post


Link to post
1 hour ago, vortex681 said:

Not specifically for P3D, but Fast Sync is NVIDIAs newest take on vsync. Traditionally standard vsync has tended to introduce input lag and reduce framerates - if you switch vsync off you generally get around 10% better performance but will probably also see tearing at some point. Fast Sync, which is effectively triple buffering at the driver level, has no noticeable effect on performance with virtually no input lag. In theory, it should only work if your framerates are much higher than the monitor refresh rate but a number of us here on the forums have found it works really well at the lower frame rates we generally get whilst simming. Additionally, unlike the other vsync modes, it doesn't limit your FPS to your monitor's refresh rate (or some fraction of it).

Try it, you've got nothing to lose (but, perhaps, a lot to gain). You can set it in the NVIDIA Control Panel. I would make it a specific program setting rather than a global setting.

 

 

Thank you. Should I also turn on vsync in P3D or only set fast vsync in specific P3D profile under nvidia control panel together with unlimited fps in P3D settings?

Share this post


Link to post
Just now, markoni said:

Should I also turn on vsync in P3D or only set fast vsync in specific P3D profile under nvidia control panel together with unlimited fps in P3D settings?

I would try with unlimited FPS and just the Control Panel fast vsync setting and see how it goes.

Share this post


Link to post

Hi,

although I managed to solved screen tearing in P3D, setting FPS to unlimited (it was not the way I was hoping to solve the problem), I am facing it in all other aspect of my daily computing.

Here is the video I made to try to describe the problem better, hope that someone could have idea:

Just to mentioned that I have tried all the setups with vsync, simply doesn't help.

Thanks.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now