SKIPS2

Anyone got LatinVFR SCEL working in P3D?

Recommended Posts

Tried to install it but got weird texture bleeds throughs of the Default airport.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Seems fine here in v3.4, with no conflicting bgl files that I can see

Share this post


Link to post
On ‎11‎/‎15‎/‎2017 at 11:50 AM, SKIPS2 said:

Tried to install it but got weird texture bleeds throughs of the Default airport.

Tried in P3D v4 but bleeds as well on some areas.

Share this post


Link to post

Seems like this is the case in several old scenery being installed into P3D v4.

Elevation data changed?

 

Shom

Share this post


Link to post

They are supposed to be redoing this for P3Dv4 this year. I'd wait.

  • Upvote 1

Share this post


Link to post
3 hours ago, B777ER said:

They are supposed to be redoing this for P3Dv4 this year. I'd wait.

Hope they do! Its in need of an urgent upgrade. I am a local and work at the ariport. There is even a new terminal being built.

I have it installed for P3DV4.1. I used the migration tool to install it. Using another method causes the weird issue with the elevation, because there is a BGL that is misplaced (SCEL_ALT_RGM.BGL).

Share this post


Link to post
3 hours ago, N_matus said:

Hope they do! Its in need of an urgent upgrade. I am a local and work at the ariport. There is even a new terminal being built.

I have it installed for P3DV4.1. I used the migration tool to install it. Using another method causes the weird issue with the elevation, because there is a BGL that is misplaced (SCEL_ALT_RGM.BGL).

I have EMT but it is advised not to use it with P3D v4.

Any idea how this can be fixed manually?

Thanks

Shom

Share this post


Link to post
7 hours ago, B777ER said:

They are supposed to be redoing this for P3Dv4 this year. I'd wait.

Link?

Share this post


Link to post

I have LatinVFR SCEL loaded in P3Dv4.1 and I do not have a problem with it.  No problem with elevation either, no migration tool within 5 miles of my computer and the elevation stub mentioned by Shom cannot be found.... I didn't know there is supposed to be one.  The AF file indicates an elevation of something like 1552 and the charts indicate 1568 (from memory) so I don't see a major issue.  An update would be nice to capture the work in progress on the runways.

Share this post


Link to post
1 hour ago, downscc said:

I have LatinVFR SCEL loaded in P3Dv4.1 and I do not have a problem with it.

I think the bleeding thru very close to LatinVFR SCEL airport and runway is a visual problem. I am waiting for an update from the Developer.

Share this post


Link to post

I did get it working in P3D4.1, but it did have serious bleed-through issues as previously noted here before I started.  P3Dv4 uses a different terrain mesh than FSX and perhaps P3D3, so airfields, especially in mountainous areas, tend to need new elevation and flatten work to whip them back into shape.

I started by copying the scenery folder over from my FSX install. I left the aforementioned SCEL_ALT_RGM.BGL elevation correction file (in scenery\world\scenery) in FSX without copying that to P3D4.

I used ADE v1.76 on the SCEL_ADE_RGM.BGL airport file, and made two changes.  First, I used Tools -> Change Airport Reference Data to change the field elevation to 474.05 meters.  The stock airfield in P3D is at 473.964m, and the unmodified LatinVFR FSX scenery is at 473.704m, so the higher stock field elevation on the revised P3D4 mesh causes the bleed-throughs.  Second, I placed a flatten under the entire airfield with the ADE "add polygon" tool.  I then compiled the ADE and replaced the LatinVFR airport ADE file with the two bgl files generated by ADE (one is a CVX with the flatten).  This also creates and places a new altitude correction bgl into scenery\world\scenery--something you'll want to remember to remove if/when LatinVFR cranks out a new and improved P3D native version.  I finished by using Lorby SI's Addon Manager to add it to the P3Dv4 scenery configuration.

With these changes, SCEL is back in action.  Though it's somewhat dated, I personally want to keep it in play the way it is--I was the US Air Force air attache to Chile back about 10 years ago, and spent a lot of time in that airport working VIP movements, rubbing elbows with the Grupo 10 guys that did Chilean VIP airlift, and working US participation in the big FIDAE airshow every couple of years.  The current form of SCEL is just like I remember it, preserved for posterity's sake.

Regards

 

Share this post


Link to post

I've done the steps described by Bob for several locations; however, there does not seem to be a problem with the LatinVFR SCEL in my configuration. Perhaps it is because I have the Pilot's FS Global Ultimate NG for P3Dv4 mesh and the Orbx S Amer region?

I just flew an Atlas B744 KMIA SCEL 5Y61 flight yesterday, and I've always enjoyed the awe inspiring experience of descending into a coastal valley with 22400 ft peaks to the East and ridges lower but still substantial to the Northwest.  Awesome.

EDIT:  Ummm... had to modify the AF file to get GSX pushback working (original has erroneously created a second parking link instead of a vehicle link, nooby error) but then I am getting the elevation problems noted by others.  Okay, my todo list now includes creating the elevation stub suggested by Bob after I complete my return 5Y62 trip SCEL-KMIA.

Share this post


Link to post
On 2/3/2018 at 5:10 PM, w6kd said:

I did get it working in P3D4.1, but it did have serious bleed-through issues as previously noted here before I started.  P3Dv4 uses a different terrain mesh than FSX and perhaps P3D3, so airfields, especially in mountainous areas, tend to need new elevation and flatten work to whip them back into shape.

Bob, I went through the steps you outlined for SCEL. But I'm still getting bleedthrough of the default tarmac, which means taxiways aren't even in the right place and it's all just a mess (also seeing default taxiway signs). Did I miss a step? Are you sure you didn't make the polygon in ADE something more than just flatten?

James

Share this post


Link to post

Boys,

Attached you will find this BGL which fixes the Altitude and bleeding issues. Please let me know if this works for you! (Your Drive:\Prepar3D v4\Scenery\World\scenery)

SCEL_ADE_RGM_ALT

  • Upvote 3

Share this post


Link to post
2 hours ago, N_matus said:

Boys,

Attached you will find this BGL which fixes the Altitude and bleeding issues. Please let me know if this works for you! (Your Drive:\Prepar3D v4\Scenery\World\scenery)

SCEL_ADE_RGM_ALT

Brilliant, worked for me!

James

Share this post


Link to post
18 hours ago, N_matus said:

Boys,

Attached you will find this BGL which fixes the Altitude and bleeding issues. Please let me know if this works for you! (Your Drive:\Prepar3D v4\Scenery\World\scenery)

SCEL_ADE_RGM_ALT

Is this the only file to insert it? It appears not working for P3D v4 yet. Maybe other SCEL files need to editing / add or removing?

Share this post


Link to post
28 minutes ago, trisho0 said:

Is this the only file to insert it? It appears not working for P3D v4 yet. Maybe other SCEL files need to editing / add or removing?

This is the file to get SCEL correctly working on P3DV4. Unfortunately, LatinVFR hasn't relaeased this scenery for V4 yet.

Share this post


Link to post
2 hours ago, trisho0 said:

Is this the only file to insert it? It appears not working for P3D v4 yet. Maybe other SCEL files need to editing / add or removing?

Be sure you put the elevation stub (also sometimes called something like preload bgls) in the <p3d>\Scenery\World\Scenery folder.  Worked exactly as expected in my P3Dv4.1 configuration.  I still had to use ADE to nudge the Parking 40 Ramp Cargo spot I'm using to line up with pavement markings in the scenery, but that is not unusual and find many developers are sloppy in this area.

Share this post


Link to post
4 hours ago, trisho0 said:

Is this the only file to insert it? It appears not working for P3D v4 yet. Maybe other SCEL files need to editing / add or removing?

I apologize to all it was my mistake placing the file wrong place. Now working fine, a beauty. Thanks a punch. 

Share this post


Link to post

Found something weird but hey, LatinVFR SCEL still beautiful in P3D v4. Hopefully LatinVFR releases an update which should not be so hard. Of course N_matus did it work without bleedings thru.

Is it possible to fix the missing shadows from the runway as seen in here......?

NoShadowsbut.jpg

Share this post


Link to post
10 hours ago, trisho0 said:

Found something weird but hey, LatinVFR SCEL still beautiful in P3D v4. Hopefully LatinVFR releases an update which should not be so hard. Of course N_matus did it work without bleedings thru.

Is it possible to fix the missing shadows from the runway as seen in here......?

Don't know how to do that. It is possible (just speculating) that the Ground Textures are not compatible with the shaders and shadows system for P3D V3 and V4. (This issue was also present in P3D V2...)

Share this post


Link to post

Thanks guys...i've yet to try the revised BGL

Share this post


Link to post
On ‎2‎/‎6‎/‎2018 at 6:32 AM, N_matus said:

Don't know how to do that. It is possible (just speculating) that the Ground Textures are not compatible with the shaders and shadows system for P3D V3 and V4. (This issue was also present in P3D V2...)

I flew from SCIE to SCEL and while approaching to rwy 17R the ground guide lights area were flickering all the time until just landed. Any ideas with P3Dv4?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now